SOLVED

Google home page not opening on start up of Edge

New Contributor

Hey, new to the forums, for some reason as of yesterday, when I start up Edge, I get a Microsoft home page even though I have Google.com as my home page and start up page. how do i stop this from happening, as I said above it was working fine until yesterday, I've not added any new software.
Version 91.0.864.37 (Official build) (64-bit)
Thank you for your help

21 Replies
Hi @dosi70 ,
Please make sure, that on picture 3 > "manage search engines" all sites exept google are deleted.
Also check that the adress is written right.

Best regards,
Schnittlauch

"First, No system is safe. Second, Aim for the impossible. Third no Backup, no Mercy" - Schnittlauch

My answer helped you? Don't forget to leave a like. Also mark the answer as solved when your problem is solved. :)
same build, same problem, got https://start.me/ as startup page but the 'new tab page' overrides any user choice.
I got the same problem with 91.0.864.37, any user choice of startup page gets overridden by the 'new tab page'

Resetting solved the problem. but it resets the search from google to bing. that is annoying.  

Microsoft has dictated to us unless you have the bing search as default then they will not allow the pages of your choice to open at startup. If they do not reverse this tyrannical policy then bye bye Edge for me.

Resetting did not solve it. And also resetting means you have to go back and reset your search engine (Delete BING) and such.

 

So now, instead of opening my home page, MS has decided that I don't want to do that anymore and opens their NEW TAB page. - this is as of today - they made an update that denies users the ability to set their own home page.

 

Nice way to get people to hate your new browser, guys. Guess it'a back to Chrome for me.

 

@dosi70 

@shasta1305 

I've started experiencing this today on Edge (Chromium) 91.0.864.37.

I previously had 5 "home tabs" set to open when Edge launched then suddenly today it just started ignoring this setting and open a "new tab" page instead. Clicking the Home button also opens a "new tab" page. 

I have tried removing all 5 home tabs set up in Edge Settings and change the default to be "new tab" page, restarted the browser, reverted back to adding a custom tab as home page but it still opens the "new tab" page no matter which setting I have chosen.

The problem is (for me too!) that there's NO more 'Homepage' except the one they've chosen for us.
No amount of resetting or configuring can get mutts.com to open with Edge upon startup.
It happened quite suddenly, around Noon May 29. Worked in the morning I think?  
EDIT: 
dftf-wip (below) offers a solution that works for me:  (It still opens the Start Tab, but separately)

 


Find a shortcut to the Edge browser (for example, on your desktop), then right-click it and choose "Properties".  In the Target box, right at the end (after msedge.exe") leave a single space, and then type the web-address you want Edge to start with.  Click OK, and use that shortcut now to launch Edge.

I had abandoned chrome and was using the edge and I was loving it
However the 91.0.864.37 update also caused this problem here and it doesn't let me put google as the homepage anymore
The interesting thing about this "bug" is that if you set bing as the default search engine then you can open your defined homepage
It really is a very strange bug that seems to induce you to have to use bing
Well, it makes me go back to using chrome and say goodbye to edge
@use246 - You are absolutely right. I thought I was going crazy, but the latest "feature update" download screwed up Edge such that, unless you have Bing as your search engine, it won't load your home pages. Incredible.
best response confirmed by dosi70 (New Contributor)
Solution

@dosi70 There are two workarounds you can try:

 

Workaround 1: Change your search-provider to Bing

 

In the Address Bar, go to edge://settings/searchEngines and then click the "..." at the end of the Bing option and choose "Make default".  Close all Edge windows.  Next time you open a new Edge window, your startup-page should be working again.

 

Workaround 2: Add the site(s) into the shortcut for Edge (applies to Windows users only)

 

Find a shortcut to the Edge browser (for example, on your desktop), then right-click it and choose "Properties".  In the Target box, right at the end (after msedge.exe") leave a single space, and then type the web-address you want Edge to start with.  Click OK, and use that shortcut now to launch Edge.

Edge_OnStartupIssue_5.png

 

NOTE: if you want Edge to load more-than one site when it starts, just leave a single space between each website address, for example:

msedge.exe" https://www.google.co.uk https://www.bbc.co.uk 

Same issue...definitely a bug...seeing reports of this all over the web.

@JoeD99 - Along with that issue, you can't open a second instance of Edge unless you use Bing - it just opens a new tab in the existing instance. Yeah, a huge bug. Wonder how this update passed QA?

I had the exact same problem after the update.... what I did was to delete all traces of my Google home page and also deleted BING search engine from within the Edge settings... and then I re-added google as my homepage...I then shut down Edge and then relaunched it.... et viola... all was working as it should...:-) 

I uninstalled the "preview" quality update from May28 and got Edge functionality restored. Homepages and new instances now working normally while having Google as my search engine. Interestingly, after uninstalling the update, I checked for updates again and it doesn't show. Is that normal behavior for an uninstalled update or did Microsoft see all the issues and pulled the update to fix things?

Frankly, the "best solution" doesn't really fix the problem for those who detest Bing. Sure, you could append your homepage to the shortcut, but that doesn't solve the inability to launch a second instance. At best, they are good work-arounds until Microsoft gets its act together. But uninstalling the offending update, which was only a preview, is much simpler.

@PeloCampo 

 

I also had an issue, which just started a few days ago, with Edge not allowing me to set the home page.  I finally got it fixed.  I just needed to set Bing as my search engine.  Once that was done, I had no issue setting any page as my homepage.

'Cumulative Update Preview for Windows 10 Version 20H2 for x64-based Systems (KB5003214) ' showed up again today, it was originally installed last thursday and most probably was the root cause of all the following kerfuffle, after 12 hours it seems everything is back to normal, accepting and retaining user choices of search engines, startup pages etc....
I found it it's it's an extension problem, I turned off adguard and it works fine, turn adguard on it goes back to the old Bing page. Reset only worked because it turned off adguard.

UPDATE: in the recent Edge v96 Stable-Channel release, this same issue is happening again!  Does anyone at Microsoft ever actually test these things before releasing to the public-channel, as I'd think something so-obvious as your "start-up page" being broken should be obvious?

 

EdgeHomepageNotWorking.png