[FIXED] Read Aloud doesn't work when I choose any Online voices


It works with the first 3 voices that are offline (David, Mark, Zira) but the rest of the voices which are Online are having problems.


Annotation 2019-11-02 131108.png



I can select them and the Read Aloud animation starts playing but there is no sound.


Annotation 2019-11-02 131314.png


for example I tried Read Aloud right now in this page and selected Hazel online UK both in Immersive reader mode and normal mode, but no sound at all, I even wait 1 minute for it to start.


it's been like this for a couple of weeks actually but right now that I'm reporting Edge is Version 80.0.320.0 (Official build) canary (64-bit)

Windows 10 insider build 19013

I have no other sound problem in Windows nor in any websites.


20 Replies

I am having the exact same issue with recent builds but what I found is that the same Edge version on the same version of Windows works with the online voices on my Surface Pro tablet but not my desktop. Like you, on my desktop, only the office voice work and my symptoms are as described.

sorry for the late reply,
it's fixed for me in today's update
Edge insider canary version 80.0.327.0

I received 80.0.328.4 recently and it still does not work for me. Zira continues to work but when I switch to Jessa or any other online natural voice, the UI pauses the word by word follow along and the voice stops. I switch back to Zira and it picks up where it left off. Odd thing is that this same browser version works fine on a second PC and my Surface Pro and at one point worked fine on the PC it no longer works on as well.

Yeah it's the same for me, on one build it works and the next update breaks it.

Same exact issue happening to me right now on new release Edge: Version 79.0.309.71 (Official build) (64-bit)


I'm not even sure whether it's server side or client side :\

@HotCakeX Well I'm guessing it's not server, because on another computer here they work fine. :facepalm:


There's no clue as to what to check on disk or in the registry maybe?

Not really, there are lots of experiments going on in Edge and there is no clear documentation as to how to configure them

Well, by some miracle, I have found the online voices in Read Aloud to suddenly work again today.



Yeah..it's really really random, after each update they can change, so one update might fix or and the next update breaks it.

@HotCakeX hmmm This was in the same Edge version, though, .71... It wasn't working for over 2 whole weeks, then suddenly it does today. So I guess it must be server/network related. (I did just happen to update my network card driver yesterday, but that would be too strange a coincidence. lol)

I'm sure it's not related to your network adapter :)

@HotCakeX I'm running into the same issue! How did you get it working?

Unfortunately it's too random that i'm not sure :(
i'm checking now on Version 82.0.418.0 (Official build) canary (64-bit) and it's Not working again...
I think the issue is only on the Canary.
Read aloud always works on the stable channel. now i'm trying it on
Version 80.0.361.48 (Official build) (64-bit) which is stable and it works perfectly. all online voices.
but when I try it on Canary 82, it doesn't work. both of them installed on the same system.


Still doesn't work for me on stable 83.0.478.37. Giving up, useless feature I guess. :cry:


Well, guess what... STILL doesn't work for me, now on stable 84.0.522.40! ☠

Well, it's been quite a long wait, but just today I have found the online natural voices to finally be working again! -- 89.0.774.45
That's good, hope it stays that way.

I had the same issue. I noticed that I didn't have this problem on my other computer though so I tried restarting and that seems to have fixed my problem. It may just be a bug, hopefully simply restarting fixes this issue for others too.@HotCakeX