SOLVED

[Fixed] Edge Canary Automatically Closing - Version 80.0.316.0

Honored Contributor

Update 2:

users report that the issue is back in Version 80.0.331.0 (Official build) canary (64-bit)

 

Version 80.0.317.1 (Official build) canary (64-bit) Fixed the issue, which was originating from Sync options.

 

I just updated my Edge insider Canary to Version 80.0.316.0

and it keeps automatically closing itself after every 2-3 minutes. I have about 4 tabs open and mostly this Microsoft tech community 

 

51 Replies
best response confirmed by HotCakeX (Honored Contributor)
Solution

@causefx @HotCakeX this is a known issue with Sync.  If you turn sync off, the crashes should cease.  Thanks - Elliot

@Elliot Kirk 

 

LOL, i can't even get to the setting fast enough to turn it off... is there a flag for this setting?

 

EDIT: incognito mode worked to change setting.

Thank you, that fixed the issue :)
Okay but better if push an update hotfix for this, here it same but closed after 3-5sec when started the edge :D

@norbertwell This.  Can't get into settings or incognito mode to supposedly fix it.  Maybe a good 2-3 seconds here before crash.

Same issue here.  Turning off sync fixed it, but is obviously a band aid solution.  I'm sure a fix will be forthcoming:)

@chriscata 

 

open Edge directly into incognito mode.  right click the icon and select new inprivate window.

 

clipboard_image_0.png

Yes indeed, if we be lucky today but most likely tomorrow :)
Option doesn't exist for me, personally. Only for Edge, but not Edge Canary.

@chriscata if you have the shortcut on desktop, right click that and select Pin to taskbar.  You only get that option when it's pinned to the task bar.

even private is closing the window, i can't access the settings fast enough, its closing in 2 seconds.

@HotCakeX same issue for me

edge crash no matter how I open it (normal or incognito with and without extensions activated).

 

@HotCakeX Can't be quick enough to get Sync Off, even using InPrivate.

I had thought about that, thanks! No go, option is not there. Can't even create shortcut and append -private to the end to set the mode on open on this version either. I do think for some it's worse than others.

Digging around the AppData\Local\Microsoft\Edge SxS\Application\80.0.316.0 for now..see if I find anything useful I can break since it's borked anyways lol. It's not a huge deal, it's Dev for a reason. Just usually...stuff is "kinda" broken but somewhat usable.
maybe try the url -> edge://settings/profiles
and sync > and sync turn off now button
Guys,
try restarting your computer and see if it slows it down, if not, try uninstalling Edge Canary and then reinstall it, during uninstallation, you must check the box that says "delete all user data"

@norbertwell OK - so if you're quick enough THAT works.  It takes too long to get to the settings normaly, so copy pasting that into browser as soon as it opens, then taking 2-3 tries to move my mouse fast enough to sign out, then another 2-3 tries to sign-out fast enough - finally worked.

 

You have to complete the sign out in 2 seconds.  And it's Launch -> Paste -> Click Sign-out -> Click that you're sure to sign out.  

 

Nice.

youpi I was fast enough to click on the log off button :p this solved the problem (for now)