Fix "New window" and "New InPrivate window" for multiple profiles

%3CLINGO-SUB%20id%3D%22lingo-sub-1387556%22%20slang%3D%22en-US%22%3EFix%20%22New%20window%22%20and%20%22New%20InPrivate%20window%22%20for%20multiple%20profiles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1387556%22%20slang%3D%22en-US%22%3E%3CP%3EAs%20it%20is%20right%20now%20if%20you%20have%20multiple%20Edge%20profiles%20configured%20and%20open%20and%20right-click%20on%20the%20taskbar%20icon%20for%20a%20profile%20and%20select%20%22New%20window%22%20or%20%22New%20InPrivate%20window%22%20it%20opens%20the%20new%20window%20based%20on%20the%20Settings%20%26gt%3B%20Profiles%20%26gt%3B%26nbsp%3BMultiple%20profile%20preferences%20%26gt%3B%20Default%20profile%20for%20external%20links%20setting.%20This%20is%20a%20confusing%20experience%20as%20the%20new%20window%20may%20open%20under%20a%20completely%20different%20profile.%20Creating%20new%20windows%20from%20the%20taskbar%20jump%20list%20shouldn't%20follow%20that%20setting%2C%20it%20should%20just%20create%20the%20new%20window%20under%20the%20profile%20that%20was%20right-clicked.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1387904%22%20slang%3D%22en-US%22%3ERe%3A%20Fix%20%22New%20window%22%20and%20%22New%20InPrivate%20window%22%20for%20multiple%20profiles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1387904%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F580648%22%20target%3D%22_blank%22%3E%40monrobot%3C%2FA%3E%26nbsp%3BThanks%20for%20reaching%20out%2C%20and%20welcome%20to%20the%20MS%20Edge%20Insider%20community.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThat's%20insightful%20feedback.%20Tagging%20in%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F211254%22%20target%3D%22_blank%22%3E%40Avi%20Vaid%3C%2FA%3E%2C%20who%20works%20on%20the%20functionalities%20for%20Multiple%20Profiles.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CI%3EFawkes%20(they%2Fthem)%3CBR%20%2F%3EProject%20%26amp%3B%20Community%20Manager%20-%20Microsoft%20Edge%3CI%3E%3C%2FI%3E%3C%2FI%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1391273%22%20slang%3D%22en-US%22%3ERe%3A%20Fix%20%22New%20window%22%20and%20%22New%20InPrivate%20window%22%20for%20multiple%20profiles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1391273%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F580648%22%20target%3D%22_blank%22%3E%40monrobot%3C%2FA%3E%26nbsp%3BI'm%20unable%20to%20repro%20this%20issue.%20When%20I%20right%20click%20and%20open%20an%20inprivate%20window%20from%20my%20taskbar%20icon%2C%20it%20opens%20under%20the%20profile%20whose%20icon%20I%20right%20clicked%20(by%20design%20and%20according%20to%20your%20preferred%20behavior).%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWhat%20you're%20running%20into%20is%20probably%20a%20bug.%20Could%20you%20go%20to%20the%20taskbar%20icon's%20properties%20and%20ensure%20the%20target%20has%20a%26nbsp%3B--profile-directory%3D%22Profile%201%22%20appended%20to%20it%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Annotation%202020-05-14%20174646.jpg%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F191921iF46AD46ABA725695%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Annotation%202020-05-14%20174646.jpg%22%20alt%3D%22Annotation%202020-05-14%20174646.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1401043%22%20slang%3D%22en-US%22%3ERe%3A%20Fix%20%22New%20window%22%20and%20%22New%20InPrivate%20window%22%20for%20multiple%20profiles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1401043%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20the%20reply%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F211254%22%20target%3D%22_blank%22%3E%40Avi%20Vaid%3C%2FA%3E.%20I%20have%20three%20profiles%20setup%2C%20they%20all%20have%20a%20--profile-directory%3D%22Profile%20X%22%20(X%20is%20numbers%201%2C%203%20or%204%2C%20depending%20on%20the%20profile).%20These%20are%20the%20steps%20you%20can%20use%20to%20repro%20this%20problem.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3EEvery%20profile%20has%20the%20Settings%20%26gt%3B%20Profiles%20%26gt%3B%20Multiple%20profile%20preferences%20%26gt%3B%20Default%20profile%20for%20external%20links%20set%20to%20%22Last%20used%20(default)%22%3C%2FLI%3E%3CLI%3EOpen%20Edge%20with%20one%20of%20your%20profiles%3C%2FLI%3E%3CLI%3EDo%20some%20work%20in%20that%20profile%2C%20open%20a%20new%20tab%20or%20something%3C%2FLI%3E%3CLI%3ERight-click%20on%20the%20pinned%20Edge%20icon%20for%20a%20%3CSTRONG%3Edifferent%3C%2FSTRONG%3E%20profile%20and%20select%20%22New%20InPrivate%20window%22%3C%2FLI%3E%3CLI%3EThe%20InPrivate%20window%20opens%20under%20the%20profile%20you%20were%20working%20in%20in%20step%203%20not%20the%20profile%20you%20just%20right-clicked%20on%3C%2FLI%3E%3C%2FOL%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1416335%22%20slang%3D%22en-US%22%3ERe%3A%20Fix%20%22New%20window%22%20and%20%22New%20InPrivate%20window%22%20for%20multiple%20profiles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1416335%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F211254%22%20target%3D%22_blank%22%3E%40Avi%20Vaid%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20update%20on%20this%3F%20Were%20you%20able%20to%20reproduce%20the%20issue%20with%20the%20steps%20I%20provided%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1440730%22%20slang%3D%22en-US%22%3ERe%3A%20Fix%20%22New%20window%22%20and%20%22New%20InPrivate%20window%22%20for%20multiple%20profiles%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1440730%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F211254%22%20target%3D%22_blank%22%3E%40Avi%20Vaid%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFor%20what%20it's%20worth%20this%20issue%20seems%20to%20have%20been%20fixed%20in%20the%20latest%20version%20(%3CSPAN%3E83.0.478.37).%20New%20windows%20now%20open%20under%20the%20appropriate%20profile%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

As it is right now if you have multiple Edge profiles configured and open and right-click on the taskbar icon for a profile and select "New window" or "New InPrivate window" it opens the new window based on the Settings > Profiles > Multiple profile preferences > Default profile for external links setting. This is a confusing experience as the new window may open under a completely different profile. Creating new windows from the taskbar jump list shouldn't follow that setting, it should just create the new window under the profile that was right-clicked.

5 Replies
Highlighted

@monrobot Thanks for reaching out, and welcome to the MS Edge Insider community.

 

That's insightful feedback. Tagging in @Avi Vaid, who works on the functionalities for Multiple Profiles.

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Highlighted

@monrobot I'm unable to repro this issue. When I right click and open an inprivate window from my taskbar icon, it opens under the profile whose icon I right clicked (by design and according to your preferred behavior). 

 

What you're running into is probably a bug. Could you go to the taskbar icon's properties and ensure the target has a --profile-directory="Profile 1" appended to it?

 

Annotation 2020-05-14 174646.jpg

Highlighted

Thanks for the reply @Avi Vaid. I have three profiles setup, they all have a --profile-directory="Profile X" (X is numbers 1, 3 or 4, depending on the profile). These are the steps you can use to repro this problem.

 

  1. Every profile has the Settings > Profiles > Multiple profile preferences > Default profile for external links set to "Last used (default)"
  2. Open Edge with one of your profiles
  3. Do some work in that profile, open a new tab or something
  4. Right-click on the pinned Edge icon for a different profile and select "New InPrivate window"
  5. The InPrivate window opens under the profile you were working in in step 3 not the profile you just right-clicked on
Highlighted

Hi@Avi Vaid

 

Any update on this? Were you able to reproduce the issue with the steps I provided?

 

Thanks

Highlighted

@Avi Vaid

 

For what it's worth this issue seems to have been fixed in the latest version (83.0.478.37). New windows now open under the appropriate profile