File Save As missing in IEMode.

Copper Contributor

When running in IEMode and you want to save the displayed content you have no "save as" and the menu via .../more tools/save page as is greyed out.

Ctrl+S does not work either.

Please advice on how to accomplish this simple task?

18 Replies

@Ulrich_Bernskov Thanks for reaching out! We'll loop in our IE Mode Team and let you know if they have any insights to share about saving functionalities.


Fawkes (they/them)
Project & Community Manager - Microsoft Edge


This is functioning as intended.

Saving a link in IE mode results in a webpage being saved from the IE perspective and will always open in Edge (since the location is not on the site list). We end up having content meant for IE opening in Edge, and want to avoid possibly incorrect behavior.

Can you help us understand if there is a particular scenario where this is required to work for you?




We have several situations where there is a need to save the content in the browser to a file.

We have an ERP system that needs to run in EMIE mode as it uses Java and we need to save output to CSV/TXT (joblists, inventory list etc)

In another system it generates XML that we cannot save as all 'save as' options are disabled and greyed out.

It is not and .LNK/.WEBSITE file we want - it is the content in the browser we want to save

@Shilpa_Subramanian We also use sites in IE mode which generate txt or csv info. In IE, we are able to save it as a TXT file, but now we have lost this functionality. We are required to select-all, copy, and paste the text into a txt file manually. This is not ideal. Is there a better workaround?


We use this functionality to troubleshoot the print spool output from a Web Application.

It was as simple as saving as text before everything changed from Edge. What was the reason it being turned off or removed?



We have exactly the same situation for our users!!!

Please MS 

Any update on this issue? I ran into the same problem by trying to download (save as) xml content to a file. It's working fine in IE but not in Edge (IE mode). The workaround (copying the content into a text editor and then save) is not really ideal for me.


@Bender67 @Ulrich_Bernskov @Navik57 @juliyus @CHGVASD Hello!  We've released a Windows Update that will allow you to use Ctrl+S to save the page in IE mode.  


March 25, 2021-KB5000854 (OS Build 17763.1852) Preview (

March 25, 2021—KB5000850 (OS Build 18363.1474) Preview (

March 29, 2021—KB5000842 (OS Builds 19041.906 and 19042.906) Preview (


It is mentioned under "Improvements and fixes" 


I believe the new policy is Enable IE mode Hotkeys.  Please give that a try!  Thanks! 



This doesn't seem to have resolved the issue, for both the shortcut key and the greyed out option to save the page in Edge (IE Mode).

Save page still works in native IE but not in IE Mode
This does not appear to be fixed. We are also using an ERP where we currently have to use Edge with IE Comp Mode. And we often have text files that open in the browser. Edge not being able to save the file down to my PC is beyond frustrating and overly complicated for a simply request.

Exactly the same situation as the others - we're going to have to re-enable IE as standalone browser for a large portion of our users if this is not resolved quickly. This is key functionality we rely on. 


Is this issue fixed ?? We still have the issue. I have enabled the group policy  Save Page As still it is grayed out. 

Win10 21H2


Thank you, 




I just set the GPO manually on my own PC, and while Save Page As is grayed out, Ctrl S now works and provides several file format options - including .txt. 



Would you provide which GPO setting to change?

Still have this problem, thanks.

@Cooper_Chiang Hi!  I believe it is EnableExtendedIEModeHotkeys, more information can be found here: 




Many thanks! It works!!

Finally successfully saved by using ctrl s, but the button on the menu is still grayed out(it doesn't matter anyway).

@Kelly_Y Please note the information on the page linked is incorrect. It should be like this:


ADMX Info:

  • GP Friendly name: Allows enterprises to provide their users with a single-browser experience Enable extended hot keys in Internet Explorer mode
  • GP name: EnableExtendedIEModeHotkeys
  • GP path: Windows Components/Internet Explorer/Security Features/Add-on Management
  • GP ADMX file name: inetres.admx

Thank You very very much Kelly, that was the solution to the whole thing,

PS.: In-case of (for some-reason) and anyone couldn't find this setting in the GPO as mentioned then setting the registry key and deploying in through GPO would work too.