File links not opening parent directory in File Explorer (IntranetFileLinksEnabled)

Copper Contributor

Hi Insiders,


I am experiencing an undocumented behaviour when using MS Edge with IntranetFileLinksEnabled group policy.


Our SPA displays anchors with file URL e.g.

<a class="link-text" href="file://" rel="noopener noreferrer" target="_blank">
   <span data-cy="search-result-path">Share1/fs1/case1/README.txt.summary</span>


Without IntranetFileLinksEnabled enabled, we get the expected error message displayed in the console i.e. Not allowed to load local resource...


When enabled, instead of opening the parent directory and selecting the file as stated in the policy description, the browser is loading the file URL into the browser address bar with the error message Access to the file was denied as shown:


Refreshing the page opens the file.


The file is also accessible to the user via File Explorer with the file URL


Have verified the following:

  • SPA web application using https (self signed certificate and root CA certificate added to Certificate Manager)
  • Have added the SPA https URL in Intranet Zone:
    • Add URL to list of Websites
    • Checked option "Require server verification (https:) for all sites in this zone"
    • Checked options:
      • Include all local (intranet) sites not listed in other zones
      • Include all sites that bypass the proxy server
      • Include all network paths (UNCs)
  • Configured IntranetFileLinksEnabled on the domain controller and have confirmed that Edge picks up the policy (via edge://policy)


  • Windows 10 Build 17763.rs5_release.180914-1434
  • MS Edge 100.0.1185.29

Have tried the following:

  • Removed attributes rel="noopener noreferrer" and target="_blank"
  • Added SPA web app as a Trusted Site


Would appreciate any suggestions to achieve the desired behaviour of opening the parent directory in File Explorer and selecting the file item.





6 Replies


Just had the same problem. For me the issue was that the file was blocked, as seen in the properties of the file at the bottom of the general tab:

This File Came From Another Computer and Might Be Blocked

Once "allowed" the link in Edge behaves as expected. It seems this protection setting gets checked even though Edge won't directly launch the file.

Edit: Reading your question again, it seems to be a different problem since a reload wouldn't open the file in my case.

Thanks @giordnas

Checked the properties of the file and it isn't blocked.

Do you know if it is possible to enable debugging in Edge and monitor for this error? Might reveal something specific about the setup of my environment.
I don't know if Edge has debugging options, but maybe have a look at the console tab in the developer tools (press F12 while on the website) while clicking the link.

After a bit of a hiatus, I revisited this issue and managed to get it work.


I got it to work by using a "PlainHostName" as the file URL's hostname. Instead of file://,  the URL that worked was file://shares/folder/myfile.docx.


For some reason, direct mapping wasn't working. I previously had added to Local Intranet Zone the following without success:

  • file:// 

@Simon_Del1  Managed to get it work after added file:// to 

Internet Options > Security >  Local Intranet > Sites > Advanced.


as from here:

@Alex Dybenko Thanks.


I am pretty sure I tried that. I found the same blog (see previous post).


The only difference I can tell is that you got it to work with a forward slash at the end:




I may have just had:




When I get an opportunity to retest, I will post my findings.