Failing CTRL+C shortcut for clipboard

Occasional Visitor

I am recently experiencing an issue that CTRL+C can fail to send selected text to the clip board frequently. It was super trouble for me but I thought it was only me because no one mentioned about it.

 

Today I found that a mini menu pops up right after selecting a text. It offers an option to hide the menu always. Once I hide it, the issue has been solved! It saves my life.

 

Therefore, the problem is, when the mini menu pops up after selecting a text, CTRL+C short cut is ignored, until the menu disappears.

12 Replies

Hey there @Katsutoshi_Hayashida, thanks for the post! Just wanted to let you know I've shared this post with the team that works on the mini menu, and thank you for posting what was causing this for you. 

 

Alex Rowell (she/her)
Community Manager - Microsoft Edge
Discuss Stable features and issues on the answers.microsoft.com forums, join us on Twitter, or join the communities over on Reddit in r/MicrosoftEdge or r/edge

Same problem here! Very annoying bug for programmers.

@Katsutoshi_Hayashida I thought I was going mad, as of late it really seemed a lot of times the CTRL+C just didn't work, and I thought it might be my keyboard, as lately the Z character seems to skip. But as I also had this problem in Edge with the same type of keyboard at work I was thinking it couldn't be that.

But I hadn't even noticed the little popup which does appear for a short time.


Now I'm glad I know I'm not crazy and it really is Edge.

I hope they fix it soon, as something simple as this should have been caught at testlevel.

But at least thanks to you we have a workaround.

I have had the same issue, until I disabled the menu you mention. Drove me crazy. Thought my keyboard or driver was faulty, but it only happened in Edge. Software quality nowadays is going down the drain. It's only features, features, faster, faster. Saying this as a professional developer. How can you break Ctrl-C....
I'm on the latest production version 97.0.1072.55 and this is *still* broken. CTRL+C doesn't work while the mini menu is up. Thankfully, I found this post and can confirm that permanently disabling the mini menu fixes it. But this is the type of bug that makes me not trust Microsoft software anymore.

Hi @rmshaffer

 

I am also using 97.0.1072.55 stable but the option still reads "show mini menu when selecting text in pdfs" and there is no mini menu when selecting text on web pages, only for PDF. For 98.0.1108.15 dev the option is there and Ctrl-C works without disabling this option.

 

More information regarding the mini menu: How to Enable & Disable Mini Menu on Text Selection in Edge (geekermag.com)

 

Ken

@Katsutoshi_Hayashida Thanks Jap! I hide it and the problem solved. It was a useless pop-up menu already.

Any News here? we get still the same problem with the Beta Version 100.0.1185.29.
Microsoft noticed me: "We want to let you know that we fixed an issue that's related to this feedback in an upcoming update to Microsoft Edge." I already feedback them in February 2022.

Oh great, then i am not crazy after all.

Disabling that menu solved the issue, who would use it anyway.

Same problem here, facing this from the moment of release of this browser. This browser is better at all aspects like performance and all. But, this feature is a basic still the team fails to provide it for more than a year.
I was struggling with this issue with only Microsoft edge, and I wonder is my computer having issue until I read clearly on this mini menu pop up. I don't even realize tehre isa mini menu every time I try to copy a text.

Microsoft edge really double standard. Such feature not only not user friendly, it create problem for user.