Failed to cache the downloaded installer


I'm trying to install and I keep getting an error message that it Failed to cache the installer. Error: 0x800b0109.  I've looked this up previously and I thought it had do with not have Windows up to date, but it is now.  I have installed successfully on two other machines.  Any ideas?

5 Replies

@Christian Long 


I would say in most cases this starts popping up because of third party protection software. 

(Firewalls, Malware, Antivirus) 

Sometimes after an update or an update to the third party software it decides to block it.


Other causes:

  • Not enough space
  • Corrupted files (would have to uninstall, restart and install again)
  • System-wide problem (other new programs have the same error during install)

I would turn off any third-party protection software if you have any and download a fresh installer

and install again whiles it's off. Then when you turn the software on adding it to the exceptions list if needed.


In some cases, a complete shutdown for 30 seconds of the computer has worked, but very randomly.


Please let me know if any  of the above helps,


@V-FRROMEthanks for the reply.  Sorry I miss the notification that you had.



It looks like I do have a firewall on but it is the Windows Security one and not third party.  Should I disable and try anyway (and then obviously re-enable)?

@Christian Long 


It would be worth a try, but usually, Windows firewall would have given you a notification to accept or block.


Please let me know if it does make a difference,


Hi @Christian Long I just ran into the same issue.


If you have not resolved this yet, running the original installer as Admin worked for me. I did try several restarts after updating windows. And I did cleared the 'Temporary file" before running the installer - although I don't know if that helped as well.


best response confirmed by rxbsantana (Microsoft)

I'm afraid that's not the case for me.
right now they removed the problematic update that's probably why you could install the update successfully.
but i even tried installing Canary on Windows Sandbox and it still failed. so no uninstall leftovers was preventing it.
also while the problematic update was on the Microsoft servers, i tried running the installer as Admin, as SYSTEM and Even as TrustedInstaller, still none of them worked.