Every time MS Edge updates, the firewall needs to ask permission again when there's no need

Occasional Contributor

Every time when there is an update to edge, for instance there is one now from 88.0.705.50 then the Win10 firewall will ask again to authorise the access outgoing, that happens i think because the folder of the new version where Edge lives has changed, namely with the version number of the new version. so i had before \Microsoft\Edge\Application\88.0.705.50 and now it has just been installed to \Microsoft\Edge\Application\88.0.705.53 which means the firewall will soon request me to approve again as if it's a new program but it's just the new version.

 

Chrome updates a similar manner but this does not influence the firewall having to request this every single time. The executable file of chrome is within the /chrome and not within the folder with the release number. on edge instead, you have msedge.exe and also msedge.exe within each folder with the version number.

 

my shortcut is of course the version OUTSIDE the folder with the release number, it will still pop the firewall.

 

I have also created an issue in feedback up please upvote it https://aka.ms/AAaxwxo

 

is anyone experiencing it? i find it really annoying having to "allow" MS Edge every single time. cmon is MS on MS why this happens?

 

best,

Gabrio

17 Replies

@gabrio-81 

The firewall complaints because the path to the executable has changed, so for it, it is a new one. Hence needing a new rule. I presume you are running Canary?

 

Regards, Henno

@Henno_Keers 

 

thanks, yes i have realised that of course but:

 

1. why is it doing it?

2. why can't they fix it? Chrome updates the same and does not do this behaviour. I don't see why asking for firewall permissions every single time would be needed. surely if i said YES once i will still be ok with it no?

 

No canary, all normal "stable/release" versions here.

Tak potwierdzam na kilku komputerach zapora blokuje Edge
Warto o tym mówić gdyby takie zdarzenie bywało u zwykłego użytkownika byłaby to bariera i problem !
Uważam że wpis do rejestru i zmiana uprawnień dla Nowego Edge aby wprowadzić do zapory Defender byłoby właściwe .
Jest potrzeba naprawy dla niezawansowanych użytkowników.
I potwierdziłem że problem istnieje

@AndrzejX 

 

good stuff, could you reply in english please? so that's confirmed. i reported this with the Feedback Hub and with the Edge's Feedback button many times.

 

is there anything else that i can do to report it to the Edge Developers?

 

or if you guys know can you let them know?

 

thanks,

Gabrio

Witam Gabrio
Bycie tu jest ważne , a praca dla społeczności bezcenna !
Każdy wpis o problemach pomaga i jest widoczny !
Ale nie można na wszystkie odpowiedzieć czas za mało !
życzę sukcesów
Andrzej
Hi,
is the OS up to date? which version/build is it?
Dziękuje Za zainteresowanie jestem ciekawy co o tym powiesz ?
Ja mam kompilację sytemu Windows 19042.804
Teraz jestem na innym urządzeniu więc piszę z innego konta
Andrzej2255
Hi,
that's strange, have you changed any default settings in Windows firewall or Windows security (Defender)?
i'm on the same build but not seeing this behavior
Oczywiście ustawiam dodatkowe zapory !
nie korzystam prawie z domyślnych !
Uważam że to jeżeli nie ma zgłoszeń to tylko indywidualny nieznaczący temat
Pozdrawiam
nope, haven't changed anything, i did notice the entry a while ago in the firewall so i deleted it, wanting him to recreate it properly, but still happening the same issue over and over.
OK !
Dla zawansowanych to są 2 kliknięcia i po sprawie !
Mamy te same Wersje Windows już za chwilę będzie 21H1 Win.
Idziemy do przodu - nie ma więcej zgłoszeń to nie jest poważny błąd !
bardzo dziękuję za współpracę

@AndrzejX 

 

alright thank you :) btw if you could write in English i dont have to go back and forth to the translator.