SOLVED

Error when installing the Power Apps site as a web app

%3CLINGO-SUB%20id%3D%22lingo-sub-2115480%22%20slang%3D%22en-US%22%3EError%20when%20installing%20the%20Power%20Apps%20site%20as%20a%20web%20app%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2115480%22%20slang%3D%22en-US%22%3E%3CP%3EI%20would%20like%20to%20install%20the%20Power%20Apps%20site%20as%20a%20web%20app%20which%20I%20can%20successfully.%26nbsp%3B%20However%2C%20when%20I%20close%20the%20web%20app%20and%20open%20it%20I%20get%20the%20error%20you%20see%20below.%26nbsp%3B%20Same%20thing%20happens%20if%20I%20pin%20the%20site%20to%20Windows%20Start%20and%20I%20open%20it%20from%20there.%26nbsp%3B%20I%20noticed%20that%20when%20the%20site%20is%20opened%20as%20a%20web%20app%20or%20from%20the%20pinned%20shortcut%20it%20opens%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fmake.powerapps.com%2Findex.html%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmake.powerapps.com%2Findex.html%3C%2FA%3E%26nbsp%3Bbut%20when%20I%20go%20to%20%3CA%20href%3D%22http%3A%2F%2Fwww.office.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ewww.office.com%3C%2FA%3E%26nbsp%3Band%20choose%20Power%20Apps%20from%20the%20list%20of%20apps%20the%20address%20is%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fmake.powerapps.com%2Fenvironments%2FDefault-bunch%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmake.powerapps.com%2Fenvironments%2FDefault-code_stuff%3C%2FA%3E%2Fhome.%26nbsp%3B%20INote%3A%20I%20didn't%20include%20the%20actual%20%22code%20stuff%22.%26nbsp%3B%20So%20when%20I%20put%20that%20address%20into%20InPrivate%20Edge%20it%20brings%20up%20the%20M365%20login.%26nbsp%3B%20That%20means%20the%20web%20app%20is%20not%20re-directing%20to%20login%20which%20brings%20up%20the%20error%20page.%26nbsp%3B%20Anyone%20know%20if%20this%20is%20a%20known%20issue%3F%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Screenshot%20(155)_LI.jpg%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F252700iF41528B4FD730A3D%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Screenshot%20(155)_LI.jpg%22%20alt%3D%22Screenshot%20(155)_LI.jpg%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2116008%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20installing%20the%20Power%20Apps%20site%20as%20a%20web%20app%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2116008%22%20slang%3D%22en-US%22%3EYeah%2C%20I%20sent%20feedback%20for%20both%20occasions%20and%20will%20send%20more%20if%20i%20encounter%20other%20websites.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2115969%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20installing%20the%20Power%20Apps%20site%20as%20a%20web%20app%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2115969%22%20slang%3D%22en-US%22%3EAgain%2C%20interesting.%20Hopefully%20someone%20on%20the%20Edge%20team%20will%20jump%20in%20on%20this%20discussion.%20Looks%20like%20Edge%20isn't%20handling%20the%20URL%20correctly%20when%20installing%20an%20app.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2115922%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20installing%20the%20Power%20Apps%20site%20as%20a%20web%20app%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2115922%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F149346%22%20target%3D%22_blank%22%3E%40Rich%20Lusk%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CBLOCKQUOTE%3E%3CHR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F149346%22%20target%3D%22_blank%22%3E%40Rich%20Lusk%3C%2FA%3E%26nbsp%3Bwrote%3A%3CBR%20%2F%3E%3CP%3EThank%20you%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3Bfor%20confirming%20that.%26nbsp%3B%20Yes%20I%20submitted%20feedback%20as%20well.%26nbsp%3B%20I%20agree%20with%20you%20that%20Edge%20uses%20the%20wrong%20URL%20for%20the%20web%20app.%26nbsp%3B%20Interesting.%26nbsp%3B%20I%20wonder%20if%20web%20apps%20only%20use%20the%20root%20of%20a%20URL%20and%20ignores%20anything%20after%20a%20forward%20slash%3F%3C%2FP%3E%3CHR%20%2F%3E%3C%2FBLOCKQUOTE%3E%3CP%3EYes%20I%20think%20so%2C%20but%20the%20problem%20is%20that%20Edge%20adds%20extra%20characters%20at%20the%20end%20of%20the%20URL%2C%20another%20example%20I%20just%20tried%20and%20successfully%20reproduced%20is%20on%20Instagram.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20went%20to%20this%20page%20on%20Edge%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fwww.instagram.com%2Fspacex%2F%3Fhl%3Den%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.instagram.com%2Fspacex%2F%3Fhl%3Den%3C%2FA%3E%3C%2FP%3E%3CP%3Ethen%20installed%20it%20as%20a%20PWA.%3C%2FP%3E%3CP%3Eclosed%20all%20browser%20windows%20and%20PWAs.%3C%2FP%3E%3CP%3Eclicked%20on%20that%20Instagram%20PWA%20icon%20and%20I%20got%20an%20error%2C%20checked%20the%20URL%20and%20it%20was%20pointing%20to%3A%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fwww.instagram.com%2F%3Futm_source%3Dpwa_homescreen%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.instagram.com%2F%3Futm_source%3Dpwa_homescreen%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eso%20it%20removed%20everything%20after%20the%20slash%20'%2F'%20and%20then%20added%20these%20characters%3A%3C%2FP%3E%3CP%3E%22%3Futm_source%3Dpwa_homescreen%22%2C%3C%2FP%3E%3CP%3Eresulting%20in%20an%20error%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22image.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F252807iA1BB4B1D2D0BFA36%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22image.png%22%20alt%3D%22image.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2115874%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20installing%20the%20Power%20Apps%20site%20as%20a%20web%20app%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2115874%22%20slang%3D%22en-US%22%3E%3CP%3EThank%20you%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3Bfor%20confirming%20that.%26nbsp%3B%20Yes%20I%20submitted%20feedback%20as%20well.%26nbsp%3B%20I%20agree%20with%20you%20that%20Edge%20uses%20the%20wrong%20URL%20for%20the%20web%20app.%26nbsp%3B%20Interesting.%26nbsp%3B%20I%20wonder%20if%20web%20apps%20only%20use%20the%20root%20of%20a%20URL%20and%20ignores%20anything%20after%20a%20forward%20slash%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2115817%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20installing%20the%20Power%20Apps%20site%20as%20a%20web%20app%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2115817%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F149346%22%20target%3D%22_blank%22%3E%40Rich%20Lusk%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20seeing%20the%20same%20thing%20in%20Edge%20v%3CSPAN%3Eersion%2090.0.789.0%20(Official%20build)%20canary%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20image-alt%3D%22fdsfs.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F252772iD76A46EE6F2141DB%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22fdsfs.png%22%20alt%3D%22fdsfs.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3Emy%20PowerApp%20works%20fine%20(left%20side)%20but%20the%20home%20page%20(right%20side)%20shows%20an%20error.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3Eif%20you%20haven't%20already%2C%20please%20submit%20a%20feedback%20using%20the%20feedback%20button%20on%20Edge%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E(shortcuts%3A%20Alt%20%2B%20Shift%20%2B%20i%20)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20think%20it's%20because%20when%20installing%20the%20home%20page%20of%20PowerApps%2C%20Edge%20saves%20this%20URL%3A%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fmake.powerapps.com%2Findex.html%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noreferrer%22%3Ehttps%3A%2F%2Fmake.powerapps.com%2Findex.html%3C%2FA%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3Ewhile%20in%20fact%20it%20should%20save%20this%20URL%3A%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fmake.powerapps.com%2Fenvironments%2FDefault-6**************************a848%2Fhome%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmake.powerapps.com%2Fenvironments%2FDefault-6**************************a848%2Fhome%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2192315%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20installing%20the%20Power%20Apps%20site%20as%20a%20web%20app%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2192315%22%20slang%3D%22en-US%22%3EI%20have%20not%20received%20any%20replies%20from%20the%20Edge%20Team%20regarding%20this%20issue.%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%20have%20you%20received%20any%20replies%20on%20this%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2192589%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20installing%20the%20Power%20Apps%20site%20as%20a%20web%20app%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2192589%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3Eno%20unfortunately%20I%20didn't%20get%20anything%20either%2C%20and%20I%20just%20tried%20the%20same%20thing%20on%20latest%20canary%2C%20still%20the%20same%2C%20(Version%2090.0.817.0)%3CBR%20%2F%3Emight%20have%20to%20send%20another%20feedback%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2335954%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20installing%20the%20Power%20Apps%20site%20as%20a%20web%20app%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2335954%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F149346%22%20target%3D%22_blank%22%3E%40Rich%20Lusk%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BHello!%26nbsp%3B%20We've%20outreached%20to%20the%20Power%20Apps%20team%20and%20they%20have%20just%20deployed%20an%20update.%26nbsp%3B%20The%20PWA%20should%20navigate%20to%20the%20correct%20URL%20now%20and%20you%20should%20not%20see%20the%20error%20message.%26nbsp%3B%20Thanks!%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CEM%3E-Kelly%3C%2FEM%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2336223%22%20slang%3D%22en-US%22%3ERe%3A%20Error%20when%20installing%20the%20Power%20Apps%20site%20as%20a%20web%20app%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2336223%22%20slang%3D%22en-US%22%3E%3CP%3EThank%20you%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F757644%22%20target%3D%22_blank%22%3E%40Kelly_Y%3C%2FA%3E.%20I%20uninstalled%20the%20PWA%20I%20had%20and%20installed%20a%20new%20PWA%20for%20Power%20Apps%20and%20it%20works!!!%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

I would like to install the Power Apps site as a web app which I can successfully.  However, when I close the web app and open it I get the error you see below.  Same thing happens if I pin the site to Windows Start and I open it from there.  I noticed that when the site is opened as a web app or from the pinned shortcut it opens https://make.powerapps.com/index.html but when I go to www.office.com and choose Power Apps from the list of apps the address is https://make.powerapps.com/environments/Default-code_stuff/home.  INote: I didn't include the actual "code stuff".  So when I put that address into InPrivate Edge it brings up the M365 login.  That means the web app is not re-directing to login which brings up the error page.  Anyone know if this is a known issue?

Screenshot (155)_LI.jpg

10 Replies

Hi, @RichLusk 

 

I'm seeing the same thing in Edge version 90.0.789.0 (Official build) canary (64-bit)

 

fdsfs.png

 

my PowerApp works fine (left side) but the home page (right side) shows an error.

 

if you haven't already, please submit a feedback using the feedback button on Edge

(shortcuts: Alt + Shift + i )

 

I think it's because when installing the home page of PowerApps, Edge saves this URL:

https://make.powerapps.com/index.html

while in fact it should save this URL:

https://make.powerapps.com/environments/Default-6**************************a848/home

 

 

 

 

Thank you @HotCakeX for confirming that.  Yes I submitted feedback as well.  I agree with you that Edge uses the wrong URL for the web app.  Interesting.  I wonder if web apps only use the root of a URL and ignores anything after a forward slash?

@RichLusk 


@RichLusk wrote:

Thank you @HotCakeX for confirming that.  Yes I submitted feedback as well.  I agree with you that Edge uses the wrong URL for the web app.  Interesting.  I wonder if web apps only use the root of a URL and ignores anything after a forward slash?


Yes I think so, but the problem is that Edge adds extra characters at the end of the URL, another example I just tried and successfully reproduced is on Instagram.

 

I went to this page on Edge: https://www.instagram.com/spacex/?hl=en

then installed it as a PWA.

closed all browser windows and PWAs.

clicked on that Instagram PWA icon and I got an error, checked the URL and it was pointing to:

https://www.instagram.com/?utm_source=pwa_homescreen

 

so it removed everything after the slash '/' and then added these characters:

"?utm_source=pwa_homescreen",

resulting in an error:

 

image.png

 

 

Again, interesting. Hopefully someone on the Edge team will jump in on this discussion. Looks like Edge isn't handling the URL correctly when installing an app.
Yeah, I sent feedback for both occasions and will send more if i encounter other websites.
I have not received any replies from the Edge Team regarding this issue. @HotCakeX have you received any replies on this?
Hi,
no unfortunately I didn't get anything either, and I just tried the same thing on latest canary, still the same, (Version 90.0.817.0)
might have to send another feedback
best response confirmed by RichLusk (Contributor)
Solution

@RichLusk @HotCakeX Hello!  We've outreached to the Power Apps team and they have just deployed an update.  The PWA should navigate to the correct URL now and you should not see the error message.  Thanks! 

 

-Kelly

Thank you @Kelly_Y. I uninstalled the PWA I had and installed a new PWA for Power Apps and it works!!! :)

That's great, thank you :)