ERR_CERT_COMMON_NAME_INVALID on Windows but not on Mac for same URL and both using Norton

Copper Contributor


I'm trying to access a Box location for work. https:/ On Windows 10 I get the error ERR_CERT_COMMON_NAME_INVALID. I tried turning off auto-protect and smart-firewall in Norton. I get the same error using Edge and Chrome.

On my Mac I can access the Box location, using the same URL, in both Safari and Chrome. Both laptops are running up to date Norton and are accessing broadband via the same router.

It's a pukka website so I would be happy with a solution where windows trusts it.

Can anyone help please?

5 Replies
the error is unlikely to be originating from Windows (unless you've removed the global certificate authorities from the built-in certificate store in Windows)
it's most likely either a website problem or your 3rd party antivirus has installed its own certificate (for web scanning purposes) and that's what's causing problem.
try uninstalling it.

@HotCakeX thanks for your suggestion. I haven't removed the global certificate authorities from the built-in certificate store in Windows. I uninstalled Norton and re-booted, when I try to access the Box site I get the same error. The detail description is this: uses encryption to protect your information. When Microsoft Edge tried to connect to this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be, or a WiFi sign-in screen has interrupted the connection. Your information is still secure because Microsoft Edge stopped the connection before any data was exchanged.

You can't visit at the moment because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.

It's unlikely to be a website problem as all the other team members are using it, mostly on Windows, and no-one else has had an issue. Also it works fine on my Mac. 


Do you have any other suggestions, perhaps in Windows network settings? Years ago we used to set a website URL as "safe". Not sure you can do that nowadays.


best response confirmed by KDkevindraper (Copper Contributor)


please try this


1. navigate to:  edge://net-internals/#hsts

2. First, to confirm the domain’s HSTS settings are recorded by Edge, type the hostname into the Query Domain section, Click Query.

If the Query box returns Found with settings information, the domain’s HSTS settings are saved in your browser.

*Note that this is a very sensitive search. Only enter the hostname, such as or without a protocol or path.


3. Type the same hostname into the Delete domain section and click on Delete.


*Note that depending on the HSTS settings provided by the site, you may need to specify the proper subdomain. For example, the HSTS settings for may be separate from so you may need to repeat the steps as appropriate.


You can test if it's working properly by refreshing or navigating to the Box website again


Thanks for your help. I experimented with your diagnostic and came across an issue by accident.


If I type the URL I get ERR_TOO_MANY_REDIRECTS - the URL changes to (repeating)

I switched to a different router/BB supplier (Virgin Media) and I can get into the box folder OK using

So it's my broadband supplier vodafone that is interfering with the URL.  I had thought that my Mac was also connected to vodafone, but in fact it was Virgin Media which is why it was working.


I can now chase this up with vodafone.  Thanks again.


Oh, that's good to hear that, nice work finding that out too, hope they'll resolve this for you on time, before holidays :)