SOLVED

Edge won't open on any channel

New Contributor

Hello, I've been using the Stable version for a long while by now and I always keep it updated. Last night an update came up before turning my computer off and after being installed I clicked the Restart button to apply it but it didn't open back again. Today I tried opening it again to see if by restarting my computer it would get fixed, I did it many times but nothing happened. I tried installing every Insider channel but none of them opened, every other browser seems to be working well. Now I am writing from an Edge executable from a previous version that I found at the "Microsoft/EdgeCore/104.0.1293.70" folder, where if I try updating the browser it shows the error code "0x80004005 -- system level".

Already tried resetting it without results.

Any help that you could provide will be welcome. Thanks in advance.

6 Replies

@Andrzej1 Thanks for your response, but neither looking for updates nor running the troubleshooter fixed it.

Not sure why but I think my previous reply got deleted.

I am also having this issue on 105.0.1343.27, suggestions from this article did not help unfortunately https://support.microsoft.com/en-us/windows/fix-error-0x80004005-9acfca89-b5e4-b976-6fa1-ef358450f3a...

as well as
https://support.microsoft.com/en-us/microsoft-edge/what-to-do-if-microsoft-edge-isn-t-working-cc0657...

I get no response trying to open any edge app, including the updater.
This was the solution that solved it. I can't begin to tell you how late I was up last night being very anxious about this issue, and the solution is so simple!

Crash reports were available, but I would have never been able to decipher them and reach that conclusion on my own!
best response confirmed by nicolas-r (New Contributor)
That was it! Problem solved :D, thanks so much for the help!