Edge v93 - v96 opens .MHT Files but shows no content ("white page")

Steel Contributor

Recently Edge started to be the Default File-Type-Association for .MHT Files.

But it seems the .MHT-File-Support is not implemented to Support true multipart/related MIME encapsulation of aggregate HTML documents but only certain style of "IE11-exported .mht Websites".

 

We have a ton of .mht Files, they are usually generated from MIME-formated-Mails. Default-Viewer was Internet Explorer 11 which renders those Files very well.

 

But Edge (I tested v93, v94, v95 Beta as well as v96 Dev) cannot render those .mht Files, shows only a "white Page".

 

Current Workaround: I configured Edge Policies to open locally stored .mht Files to open in Edge-IE-Mode. That works fine, so currently we can use this workaround as a solution.

 

But if Edge should be able to render .mht Files in a useful way itself then Edge has to support all styles of the MHTML-Standard. Wikipedia https://en.wikipedia.org/wiki/MHTML pointed me to a useful website where all styles of MHTML-Documents are listed with Samples, I mirrored those samples to my Webserver, URL: https://hitco.at/mht-test/ to quickly check those with Edge. These samples all don't work at all in Edge but work fine in IE or in Edge in IE-Mode.

 

So please have a look at this functionality, you cannot configure Edge as Default for .mht Files without really supporting the MHTML-Standard in a proper way!

5 Replies

@Gunnar-Haslinger Thank you for sharing the repro files; a support case was opened.

 

As you noted, Edge/Chromium's support for MHT files today is limited in various ways (less liberal parsing than IE, web form controls are disabled in MHT content, more restrictive same-origin-policy behavior).

Today, the best way to ensure IE-style rendering of MHT files is to use IE Mode. As of Edge 94, that should happen by default for MHTML files unless they contain metadata suggesting that they were saved from Edge mode to start with[1]. 

 

[1] https://docs.microsoft.com/en-us/deployedge/microsoft-edge-relnote-beta-channel#:~:text=Improvements...

Thanks @Eric_Lawrence for your reply.

Using IE-Mode is our current workaround and works fine.
But looking forward to see a more complete .mht Support in future Versions of edge to not depend on IE-Mode for this any more. The limitations you cited (same-origin-policy, ...) would not be a problem for us.

Some of the linked sample files just work when changing File-Endings (Unix/LF) to Windows/CRLF. But saved E-Mails (Plain/HTML-Alternative Multipart MIME) then still just show the Plain-Part and not the HTML-Part.

@Gunnar-Haslinger 

 

I know this is an old post but I'm seeing the same issue happening now with Edge V113 even with IE mode I tried the instructions included here but that didn't work.

Without setting policies .mht Files like I published in the given examples above won't work in Edge v113.

To get them to open in IE-Mode use following Policies:
1. Set "InternetExplorerIntegrationLevel" (I used Level 1 to test).
2. Set "InternetExplorerIntegrationLocalMhtFileAllowed" to 1
3. Set "InternetExplorerIntegrationLocalFileExtensionAllowList" -> "1" -> ".mht"

with those 3 policies set my Edge v113 opens .mht Files in IE-Mode by default and renders them correctly.

 

 

Here a Screenshot of my policies, filtered by "InternetExplorer":

GunnarHaslinger_0-1685554490487.png

 

Here a Link to my Test-MHT-Files: https://hitco.at/mht-test/

 

Here a Screenshot of an random .mht File, automatically opened in IE-Mode:

GunnarHaslinger_3-1685554598642.png

 

 

 

@Gunnar-Haslinger 

after setting these values and rebooting it seems to work now.