Edge Send Desktop notifications ever after closing it.

Copper Contributor

I want to get Desktop notifications when I'm actually using the browser but not when it is closed.
The main problem I have is when I'm playing any games, I get huge framedrops and lags because Edge sends desktop notifications.  



I have turned off these settings but it doesn't work. 
Edge will send every notification I have allowed even after closing the browser when I no longer want notifications from the browser. Is there any way to turn them off?


2 Replies


  • Click on the three dots menu button.
  • Click on Settings.
  • Click on Cookies and site permissions.
  • Click on Notifications.
  • Under Allow, click on the three dots next to the website you want to stop receiving notifications and click on Remove or Block.

Also, here's an MS Edge support article that covers these steps, as well as others Manage website notifications in Microsoft Edge - Microsoft Support 

Thank you so much for you reply. But removing or blocking notifications permanently stops sending notification.
In other browser like chrome and Vivaldi, when I stop their background activity, they stop sending notification while they are off. But they do send foreground notifications.

In edge, when I stopped edge background activity, it still sends me notification when the browser is off.