Edge running on Server 2019 automatically elevates itself which prevents me from signing in

Copper Contributor



I'm currently setting up a new Server 2019 RDS server to replace our old Server 2012 R2 server and I want to set up Edge as our main browser in case that we want to browse the internet. 


I've ran the latest stable installer and everything works fine except that Edge doesn't allow me to sign in because it somehow automatically elevates itself when launched on the new Server 2019 RDS and keeps complaining that "Sign in is not supported when running Microsoft Edge as an administrator. Please relaunch Microsoft Edge as a non-administrator and try signing in again."


The accounts that are working from this RDS are local admin (it acts as a jumphost for our domain admins) so it's possible to run Edge as an administrator, but I haven't configured anywhere to explicitly launch Edge with elevated permissions.


Trying to sign into Edge with exact same settings (installer, user account, permissions, GPO settings) on our old Server 2012 R2 and another Server 2016 RDS server works fine so I don't understand what's going on here.


I also tried to use the Edge server beta, but that results in the same behaviour.




3 Replies
I have the same issues on Windows server and Windows Sandbox, this limitation should be removed and even if not by default, we need to have an option in the settings to remove this and sign into browser even with Admin access. Chrome and Firefox both allow this.


Same issue here, but we are logging in directly as Domain Admins.

Oh, this is bizarre. I ran the Compatibility Troubleshooter and that actually seemed to make this work, but then I got this: