Edge refuses to load certain pages after I installed a TPM.

Copper Contributor

Hi all,


Can anyone help me, please? I've just successfully installed an ASUS TPM R2.0 onto my motherboard and have found an odd complication. I can connect to the internet (using a wired connection) to almost every page bar two (Facebook and Youtube). Every time I try to connect I get the "Your connection isn't private" message. I've tried everything I can think of to correct it (turned off and on again, reset the modem, flushed the dms, reset the firewall) but nothing works. Does anyone fancy doing a walk through with me on what I need to do please?


Many thanks.  

2 Replies
Hello, can you check edge://policy ?

@Tio_Dep Just checked that and found "No policies set" other than the normal update policies.


I have found, since I wrote the original discussion, that the problem seems to be because of another app I run called "Upvoice". When I close this down from running in the background I get access to everything again. The strange thing is that this app actually wants contact with these sites to let me earn some money.


Many thanks for your help.