Edge macos stopped syncing

New Contributor



for some reason Edge is not syncing anymore on macOS:


Sync isn't available right now

Couldn't connect to the sync server. Retrying...


I think it stopped working, after I enabled multi-factor authentication for my account in Azure. On my Windows clients sync is still working and it is limited to macOS.


I've tried uninstalling and re-installing Edge and tested other accounts from our organisation without MFA and sync works on macOS as expected. I disabled MFA for my account, but it did not solve the problem, so I re-enabled it.


Current status is, that I did not find a helpful solution via Google and have not other idea how to fix this issue. Maybe someone can help?


Thank you,


1 Reply

@Markus_Pfeifer Thanks for reporting that, and welcome to the MSFT Edge Insider's community!


We're sorry to hear that you're encountering some issues with sync. If it's still not working as expected, we have a couple of questions for you:

  1. What build number and channel are you using? This can be found at edge://settings/help
  2. If you haven't yet, can you please submit feedback and diagnostic data through the browser? (Shift + Alt +I)

Fawkes (they/them)
Project & Community Manager - Microsoft Edge