Edge Google Image Search Displaying Error

%3CLINGO-SUB%20id%3D%22lingo-sub-1917099%22%20slang%3D%22en-US%22%3EEdge%20Google%20Image%20Search%20Displaying%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1917099%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%20%26nbsp%3B%20%26nbsp%3BRecently%2C%20I%20am%20getting%20this%20displaying%20error%20from%20Google%20Image.%20It%20sorts%20the%20image%20on%20the%20main%20page%20but%20fails%20when%20you%20click%20and%20expand%20the%20image%20and%20doesn't%20even%20display%20anything%20on%20the%20sidebar.%20From%20there%2C%20it's%20being%20unresponsive%20to%20other%20expanding%20and%20collapsing%20attempts.%20Thanks%20for%20any%20feedback.%3C%2FP%3E%3CP%3EEdge%20Version%3A%26nbsp%3B%3CSPAN%3E86.0.622.69%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1917118%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20Google%20Image%20Search%20Displaying%20Error%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1917118%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F875910%22%20target%3D%22_blank%22%3E%40kindleshard%3C%2FA%3E%26nbsp%3BI%20have%20updated%20in%20the%20meantime%20to%20Version%3A%26nbsp%3B%3CSPAN%3E87.0.664.41%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EThe%20bug%20still%20occurs.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

     Recently, I am getting this displaying error from Google Image. It sorts the image on the main page but fails when you click and expand the image and doesn't even display anything on the sidebar. From there, it's being unresponsive to other expanding and collapsing attempts. Thanks for any feedback.

Edge Version: 86.0.622.69

2 Replies
Highlighted

@kindleshard I have updated in the meantime to Version: 87.0.664.41 

The bug still occurs.

Highlighted
Hi, I'm experiencing it on Edge version 88 canary too.
please also send a feedback using the feedback button on Edge browser if you haven't already