Edge devs never fixed mute tab button, I am now switching to Chrome

Occasional Contributor

I cannot click the mute tab button once I have more than ~10 or so tabs open. It just brings me to that tab instead of muting the tab like it should be. Me and others have raised this issue numerous times. It's such a simple problem that should have been fixed by now if Edge devs had ever bothered testing their product. It's a feature I and others use very frequently and is a deal breaker. 

 

Recently, Chrome has brought in the ability to mute individual tabs again, and it works flawlessly. I've switched to Chrome and will be uninstalling Edge, which is unfortunate because otherwise it is a good browser. Any other way I can give feedback directly to the Edge devs about this before uninstalling Edge? Thank you.

6 Replies
What version of Edge are you using? We recently made a fix for this in Edge Dev, so if you're using the stable release version, you may not have that fix yet.
I'm glad to hear this is being worked on. I have the latest version of Edge, and I also have Edge Dev installed, but I tried it on Edge Dev and the problem is still there.
Okay, I think you're having a different issue then, which is that when the tab becomes so small that the mute icon takes up the entire width of the tab, the mute functionality is removed since otherwise you'd have no other way to select that tab. This is something that Chrome does as well, so it's behavior that we've inherited from them. That being said, if there's anywhere that we differ from their behavior still, that would be very good to know about.
For edge this occurs way before the mute icon takes up the entire width of the tab. It happens to me when I have about 11 tabs open which is ridiculous-might as well the feature not exist at all, that's really not that many tabs. I've uploaded a screenshot: https://i.imgur.com/ZRxkXxL.png You can see here clearly there should be more than enough room to click the mute tab button, but it doesn't work. It just takes me to the tab instead of letting me click on the icon. The threshold is way lower compared to something like google chrome. Try it yourself and compare.
I can't reproduce the behavior you're experiencing on my personal machine, so I'm wondering if maybe there's a bug with the size of the button being scaled incorrectly. In your Windows settings, is the Scale of your display set to 100% or something higher? Or do you have something like Text size set to be larger than the default?
It happens on multiple machines, even with display scaling set to 100%. Maybe we're not on the same page as to what the problem is; maybe it's more or less than 11 tabs depending on scale or whatever. Try opening a few more tabs, and your speaker icon on the tab should stop working properly and it will simply switch to the tab.