Edge Dev doesn't load any websites but stable Edge & other apps works

New Contributor

Hello! I have some issues with Edge Dev 102.x on Windows 10 21H2. Why the browser wouldn't load any websites like nothing happened? Other browsers & apps are fine, but Edge Dev wouldn't do anything. Also I figured it out that when I opened Event Viewer, I got a fatal error from SCHANNEL that apparently Edge Dev tries to communicate or connecting insecure TLS or SSL but it failed. Does anyone have this issue or something on Windows 10 or 11? Edge Stable looks fine for me, so I must downgrade to Stable temporary until this bug or issue fixed.

Oh also, I already got this bug at some version around 101 or 102.

3 Replies

@Hanif76330 

Hi, please check if Defender is blocking this application, or another antivirus program if you have enabled limited access to the folder (add allowed application), but of course I guess.

@Andrzej1 It seems apparently fine in Allowed Apps on Windows Defender Firewall (look at the screenshot below and it's checked, including the Stable release.

Hanif76330_0-1650059582299.png

I tried several things like resetting the browser to default, reinstalling the browser... nothing happened. The issue still present. Previous version like 100 just working properly and now version 101 or later (including Dev 102.x) having this problem and I can't fix this problem. Also I couldn't find any solutions on the Internet, but I found quite strange error on Event Viewer when Edge Dev tries to connect or load webpages.

Hanif76330_1-1650059994438.png

Any some workaround solution here? I tried everything and doesn't work at all.

Are you using DNS over HTTPS? If so, can you try switching your "Use secure DNS to specify how to lookup the network address for websites" setting to "Use current service provider" instead of choosing a custom one? And if not, can you disable the edge://flags/#enable-first-party-sets and edge://flags/#use-first-party-set flags and see if that helps? Also, are you getting an error page, or is it just staying white and spinning forever?