Edge Dev channel not syncing on macOS

Occasional Contributor

I've got the latest Dev build (86.0.587.0) on macOS 10.15.6, and for some reason I can't get browser data syncing to work. I've tried to log out of my account and log back in, and it gives me this


Screen Shot 2020-07-28 at 4.31.36 PM.png

I get this every time I try to log in. I've even reset browser settings and uninstalled Edge altogether (even removing browser data and reinstalling).


Is anyone else experiencing this issue?

6 Replies


Hi there, you are welcome to the Microsoft Edge Insider Community Hub!


Thanks for reporting here. I would recommend you to send feedback about this bug through the in-app feedback tool in Microsoft Edge (Alt+Shift+I) with the diagnostics attached in order to help the Microsoft Edge dev team to resolve your issue as soon as possible.

@TheShaunSawI've sent feedback and I still have not heard back from anyone. I've just downloaded the Beta channel for macOS and I do not have any issues with syncing from my account on that channel. I don't know why I can't sync on the Dev channel.


Tagging @Deleted, our community manager to further look into this issue.

Good news: the team logged this as a bug and has been working on it. I just took another look, and it seems like it's been fixed! @techWiz118, please give it a try again and let me know if you're still getting that verification message.


Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge

@Deleted I just tried to sync with Dev build 86.0.594.1 and I am still encountering the same problem with syncing. 

@techWiz118 Good to know! I'm following up again with the devs, and will let you know if they have more info to share.


Fawkes (they/them)
Program Manager & Community Manager - Microsoft Edge