edge dev bugs

Occasional Contributor

Hi, recently when I open a new tab on edge dev version the language changes to Arabic, which is weird because in the language settings there is only English.

Also, I noticed that the edit address button isn't working (settings --> profiles -->addresses and more).

10 Replies


it usually shows you content based on your country/IP location.
using proxy or VPN of other countries can have the same effect.


try going to https://www.msn.com/


and change your content and language settings. first sign in and then next to your name click on the small gear icon.




@HotCakeX I'm not using a proxy, I live in an Arabic country, I have 2 PCs synchronized with the same account and using the edge dev version, only one of them is having new tab language switch, also I have installed edge since months so why I'm getting that bug now and msn website looks fine.

I never used the Arabic language on any of my old and new devices.

@VertinholI assume you sorted it out, so I'm posting for other people with the same problem... Not sure why Edge suddeny decided that, in spite of my Windows language and location being set to English and South Africa, keeps displaying in Arabic?
see attached jpg: (this is english, just flip it horisontally obviously!)
- open new tab, click the settings icon (the gear)

- 1: click on the "reset to default"
       click the blue text box to apply settings
- 2: click drop-down (this one's grayed out, but should be accesible after reset)
       select your language and click blue "save" button
That should hopefully sort it out!

@Johansa thank you for replying, I don't want to reset to default, this will delete many things and it's not worth it, I can wait for an update to fix this, just to add another information to this topic even the tab settings are in Arabic as shown in the image below.

Annotation 2019-10-01 101429.png

Well Edge apparently found out a way to detect your real language, and it's based on your IP location.
I doubt that it's a bug since you haven't set it anywhere to English,
the language in the Edge settings is Only for the program language and the UI, Not the language that websites use. when I use VPN of other countries, there are websites that load local content for me, one of them is Google.

check in the the location settings and see which websites have access to your location:


you can also check in Windows location settings and temporary turn it off, restart browser see if it changes anything.

lastly, after applying all the items above, clear your cookies and site data from here:


@HotCakeX The language switch only on the new tab, but for the rest of the options it's in English,


Annotation 2019-10-01 104727.png


Yes, the languages in here have no effect on the websites languages.

these are all only for the Edge program UI and the texts you type.


Annotation 2019-10-01 133432.png


Websites use your IP to detect your location.


did you check the site permissions in settings?




by the way, I noticed the new tab page for you is LTR (Left-To-Right) direction,


Have you activated any of these flags?


Annotation 2019-10-01 134333.png


@HotCakeX Actually I got a problem only with a new tab not websites, I managed to solve this by choosing the English language which sounds weird because it was written on the settings, but somehow it wasn't activated and didn't know that I have to take further actions to apply a language, so thank you for help.

Annotation 2019-10-01 113313.png

That's good, you're welcome!