Edge Dev 101.0.1193.0 will not start

Copper Contributor

Just started this AM.  When I try to open Edge Dev, it pops an all white window and then closes with no error.  Downloaded and reinstalled, repaired but still fails to open.  Nothing of note in the event log.  Any ideas?  Guess the next step is to remove it and reinstall.

19 Replies

@bwholl  Hi

It seems that the antivirus is blocking - ( add allowed application ).

check the Microsoft Defender firewall (limited access to the folder). Or another antivirus - if you have an ad blocker installed, this may also be the cause of the problem.

Best regards

I'm experiencing the same issue as bwholl. Aside from the Firewall itself (which has Edge Dev allowed), there's no "Add allowed application" option in Defender. Further, nothing in any of the protection history screens even indicates it prevented Edge Dev from starting or accessing the network. Edge Dev also works fine with an InPrivate window.

I don't think antivirus is the issue here.

I've run my latest .dmp from Crashpad/reports through DebugDiag's Crash/Hang Analysis.


In 3bf41046-e349-4554-97c1-0c93659527af.dmp the assembly instruction at msedge_7ff89b600000!CrashForExceptionInNonABICompliantCodeRange+5c4f00 in C:\Program Files (x86)\Microsoft\Edge Dev\Application\101.0.1193.0\msedge.dll from Microsoft Corporation has caused an access violation exception (0xC0000005) when trying to write to memory location 0x00000000 on thread 0


@bwholl I managed to roll back to 100.0.1181.0 by mostly following the steps on https://docs.microsoft.com/en-us/deployedge/edge-learnmore-rollback

One difficulty is that v100 is no longer available on the download page. Instead, I tried winget

winget install --id=Microsoft.Edge.Dev -v "100.0.1181.0" -e

 While this ended up failing, it did show the URL it downloaded the .msi from, which I was then able to download myself. I'll also note that the msiexec command didn't show anything when it finished (omit the /qn from the command if you want prompts). Launching from the taskbar also didn't seem to have rolled back, but under C:\Program Files (x86)\Microsoft\Edge Dev\Application there was now a 100.0.1181.0 folder, and msedge.exe successfully ran from there (although the restored tabs appear to be from that snapshot in time, and not what I last had open).


I understand, but there are also such examples:

Windows Firewall Blocked Edge Dev - Microsoft Tech Community


I'll try that later tonight.  The odd thing is that beta and canary work fine.  Thanks for the

My Edge Dev 101.0.1193.0 (Official build) dev (64-bit) is configured with 3 start up tabs.
It does this on the first 3 attempts to open but then on the 4th attempt it does open and seems to run fine from that point on.


I added a 4th tab, thinking it might open at launch attempt #5 but it still opened correctly on launch attempt #4.

@WayneIRE thanks for this. I ran the command and it installed, and my Edge is now working.
However I did get an error from the installer. The log shows the following:

Action start 19:43:25: InstallFinalize. CustomAction DoInstall returned actual error code -2147219187
I was able to use winget to install 100.0.1181 and that worked. Thanks. I'll see what happens when it updates.

@bwholl to be clear it didn't actually downgrade, but the issue seems to be reolved. Not sure how :smile:

I uninstalled Edge Dev and used 'winget install --id=Microsoft.Edge.Dev -v "100.0.1181.0" -e' to get 100.0.1181 installed. I'm currently doing a 'winget upgrade --all' and it is going to upgrade it again to 101.0.1193. I'll then see if it is just 101.0.1193 that my system doesn't like. I'm running 101.0.1193 on other systems with no issue but not on my corp domain and with different anti-virus software. I'll post what happens, maybe I just got a bad update on this system.


Maybe you can download and install the latest version of Edge Dev.

Dev channel update to 101.0.1198.0 is live - Microsoft Tech Community

Winget was able to install 101.0.1193 and now it works. Also, Edge updated to 1198 and that works too. All I can think of is that maybe I got a corrupted update. Thanks for all the suggestions.

Same issue here. I was able to roll back to 100.0.1181 following the instructions from @WayneIRE and @bwholl.
Then did a winget upgrade to 101.0.1198.0 after which it still worked.
However it started crashing again after a reboot of the PC :unamused:

Rolled it back again to 100.0.1181 and currently going OK. Dreading when it decides to auto-update and start crashing again...

The user that created this reddit post a week ago received a response to their feedback in which MS states they've fixed the issue and it will be in a future release. You will see I referenced this post for them.

Thanks @jdelano. Sure enough after an auto-update and reboot my Edge Dev has gone back to the white screen/crash on start.
Reverting to stable for now as it is too disruptive to keep rolling back daily, esp since it seems my cookies are blown away with the rollback.
Hope Dev gets patched this week
The fix in Version 101.0.1210.2 (Official build) dev (64-bit) has resolved this problem for me.

@enwinn Confirming 101.0.1210.2 has resolved my problem as well.

I've noticed the problem was fixed also. Thanks to everyone