Edge Chromium not loading some pages properly

%3CLINGO-SUB%20id%3D%22lingo-sub-1895135%22%20slang%3D%22en-US%22%3EEdge%20Chromium%20not%20loading%20some%20pages%20properly%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1895135%22%20slang%3D%22en-US%22%3E%3CP%3Eyesterday%20I%20switched%20to%20Edge%20and%20impressed%20by%20how%20fast%20it%20is%20moving%20all%20my%20work%20there%26nbsp%3B%3CBR%20%2F%3Ebut%20I%20had%20a%20problem%20with%20some%20sties%20like%26nbsp%3Bblockchain.com%3CBR%20%2F%3Ewhen%20I%20login%20the%20site%20keep%20loading%20forever%20although%20any%20other%20page%20on%26nbsp%3Bblockchain.com%20works%20perfectly%20expect%20my%20account%20page%20!%3CBR%20%2F%3EI%20tried%20it%20InPrivate%20mode%20to%20make%20sure%20no%20extensions%20affect%20and%20same%20problem%20goes%26nbsp%3B%3CBR%20%2F%3Ealso%20tried%20to%20reset%20Edge%20but%20didn't%20work%3CBR%20%2F%3Eon%20Chrome%20it%20work%20perfectly%20so%20any%20help%26nbsp%3B%20%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1919449%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20Chromium%20not%20loading%20some%20pages%20properly%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1919449%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3EWhich%20version%20of%20Edge%20browser%20are%20you%20using%3F%3CBR%20%2F%3ECheck%20your%20tracking%20prevention%20settings%2C%20temporarily%20turn%20it%20off%20for%20that%20website%20and%20see%20if%20it%20helps%3A%20edge%3A%2F%2Fsettings%2Fprivacy%3CBR%20%2F%3E%3CBR%20%2F%3Ealso%20make%20sure%20you're%20not%20blocking%203rd%20party%20cookies%3A%20edge%3A%2F%2Fsettings%2Fcontent%2Fcookies%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

yesterday I switched to Edge and impressed by how fast it is moving all my work there 
but I had a problem with some sties like blockchain.com
when I login the site keep loading forever although any other page on blockchain.com works perfectly expect my account page !
I tried it InPrivate mode to make sure no extensions affect and same problem goes 
also tried to reset Edge but didn't work
on Chrome it work perfectly so any help  ?

2 Replies
Highlighted
Hi,
Which version of Edge browser are you using?
Check your tracking prevention settings, temporarily turn it off for that website and see if it helps: edge://settings/privacy

also make sure you're not blocking 3rd party cookies: edge://settings/content/cookies

Highlighted

lastest Version 86.0.622.69
already tried all of that
+ InPrivate mode there is no cookies and it didn't work too