Edge Chromium run as admin not working?

Occasional Contributor



I have Edge Chromium Insider installed on a Windows Server 2012R2 SharePoint 2013 server. When I want to create a new webapplication I have to run IE11 or Chrome as admin so the new button will be enabled. When I run Edge Chromium as admin this button doesn't get enabled. 



12 Replies
just to confirm, you are on the Beta channel, right?



I downloaded the stable version that was visible in Google. V78.0.276.20


@Waaromikniet wrote:



I downloaded the stable version that was visible in Google. V78.0.276.20


Please take your time and read this article, I feel like this should be Pinned at the top of the forum.



also this article helps you understand the transition from old to new Edge.

I understand. But shouldn't run as admin work? 

When I installed Edge Beta channel, which has the same version as this so called stable version, on Windows server 2019, it didn't have problem running as admin. It was a DC server and was using built in Administrator with highest permission by default.

so maybe you hit a bug in it. try see if you can uninstall it and replace it with Beta. I hope it didn't cause any serious problems for you :\



It is on my dev box so no problems with this version.


I did just found a possible issue. When I edit the properties of my Edge icon in the taskbar and set on the compatibility tab run as admin to on and start Edge I see the message "Admin mode detected". In this case everything works like expected.


So right click on the icon and choose run as admin doesn't seem to actually run in admin mode because I don't see the message "Admin mode detected"

So when you right-click and choose run as admin, under which user account will it run?



When I open Edge with run as admin and go into task manager process overview the column elevated has the value "No". I also installed the Edge stable on my Windows 10 laptop and there I see the same behavior.


I also tried installing the insider canary build. But there I also see this behavior

best response confirmed by Waaromikniet (Occasional Contributor)



I think I have found the solution. There is a flag in "Edge://flags" called "De-elevate browser on launch". This setting has value default. When I disable this flag, and run as admin I do see an elevated process..



Eventually I didn't get what you wanted, whether you want an elevated browser session or not. so first you intentionally launch your browser as admin then you go into flags and de elevate it!?!?! lol why



I want to start Edge in an elevated session so I can use some functions in SharePoint that are only enabled within an elevated session. With this option set to default of enabled Edge automatically de-elevates the session. So for my situation this option is not useful.

Oh got ya :)