Edge Canary - Version 97.0.1065.0 - empty tabs - reduced context (right click) menu

Brass Contributor

After updating to latest build, the browser doesn't display anything.

page is blank

context menu have only 3 options
none url reachable (no problem from other browsers) - in Dev Tools error message: No resource with given identifier


What have I tried to do:

disabled HW acceleration

disabled all extensions

private mode

another user profile (version 85 working and then updated to 97.0.1065.0, same behavior, blank tabs)

44 Replies

Hey there @SiKei! Are you still seeing this with today's Canary build (1066)? 


The reduced context menu you're seeing looks like the mini menu to me. Does it show up when you right click, or when hovering selected text? Is it initially a ... menu that expands? I'd expect to see the mini menu on text hover, but it shouldn't be interfering with your right click menu. You may want to head over to edge://settings/appearance and scroll to 'Context menus' and check out your settings for the right click menu and mini menu. 


The blank page issue is interesting, looks like you've tried a lot of what I would naturally suggest for that. Are you able to access Edge internal pages like the one I linked above for settings? (If not, that probably wasn't super helpful advice was it?) Have you tried running Edge as an Administrator, and do you happen to have any third party security software running, or something that might intercept web traffic -- a Pi-hole or something equivalent, for instance? 


Alex Rowell (she/her)
Community Manager - Microsoft Edge
Discuss Stable features and issues on the answers.microsoft.com forums, join us on Twitter, or join the communities over on Reddit in r/MicrosoftEdge or r/edge

Updated and still have problems

About: blank and Edge internal settings pages are the only ones without issue and displaying full context menu.

I have non new third party software or plugins, no connectivity problems (other browser / internet application running as usual).

Other things I tried:

check Edge firewall settings: nothing unusual

deleted Edge SxS\UserData: nothing changed

deleted Edge SxS folder and reinstalled from scratch: nothing changed

installed Edge Stable: everything fine


BTW: Windows 8.1



@SiKei , Edge Canary 97.0.1069.0 - same problem.


Exact same here with Edge Canary 97.0.1069.0 on a fully patched Win 8.1 Pro 64bit machine :(

@welzewool what version of Windows are you running?

Thanks for the reports folks! Still looking in to this one.

@Alexandra-R Windows 10 Corporate 1607. Now DEV dont work too with same problem :(

I have 4 Server 2016 machines that got Dev 97.0.1069.0 yesterday that this is happening to. Send Feedback doesn't load. If I pull up developer tools on the networking tab it shows (canceled) for any site attempting to load. Uninstall/reinstall, profile removal, reset settings, clearing all cache/cookies doesn't change it. Same issue with Canary 97.0.1070.0. Beta 96.0.1054.13 works properly(thank goodness). How do we get diagnostic data into you without Send Feedback?(and of course, no Feedback Hub for Server 2016)


Here's what's happening with 97.0.1070.0 that I just installed this morning.  Loads up with about:blank, type in www.microsoft.com and press enter.  Tried forcing https:// tried going to some http:// sites, same result of (canceled) with no change in the tab.






Here's Browser Task Manager side-by-side with a working Canary on W11.  The Server 2016 one is missing several Utility tasks.




@Alexandra-R Further information. I decided to check to see if IE mode would work. Going to Settings->Default Browser showed no options. So I downloaded edge policy(97.0.1069.0) and set "Configure Internet Explorer integration" to "Internet Explorer Mode". Still doesn't show up in settings in Canary or Dev, so I can't test that.




@Alexandra-R I saw a different issue where you had recommended trying in InPrivate.  Tried that for this issue and it sill has the same error.  Including the console errors, but I don't think those are relevant.




Hey folks! Thanks for continuing to report in on this. Since we're not able to gather feedback on this we're doing it the old fashioned way (a bulleted list!) I know some of you have already given me some of this information, but if you could bear with me and provide it again (especially version, which might have changed since you provided it the first time)


Please answer the following in a response and be as complete as you can! 

  • Current browser version
  • OS and version
  • Region
  • Do internal edge pages load for you? (ex: edge://settings/help)
  • For pages that are not displaying, do you have the reduced context menu?
  • Are you using any third party antivirus/proxy/VPN software?

I'm getting this in front of the team and may ask for additional information according to what they need to dig in to what's going wrong here. 




  • Current browser version
    • Edge Canary 97.0.1071.0(does not work)
    • Edge Dev 97.0.1069.0(does not work, what triggered me coming here)
    • Edge Beta 96.0.1054.13(works fine)
  • OS and version
    • Windows Server 2016 1607 14393.4770 (4 machines I can replicate this on)
  • Region
    • English (United States)
  • Do internal edge pages load for you? (ex: edge://settings/help)
    • Yes
  • For pages that are not displaying, do you have the reduced context menu?
    • Yes, edge://settings/help I have full context menu.   about:blank gives full context menu.  Trying to go to www.microsoft.com from about:blank still gives same context menu(again, when trying to go to any http/https site, there's no change).  New tab trying to go to a site(http/https) I only have "Web capture" and "Inspect".
  • Are you using any third party antivirus/proxy/VPN software?
    • No


  • Edge Canary Version 97.0.1071.0 (Official build) canary (64-bit) (not working)
  • Edge Stable Version 95.0.1020.44 (Official build) (64-bit) (working fine)
  • 8.1 Enterprise [Version 6.3.9600]
  • Italy
  • Yes
  • Yes
  • Sophos AV


Edge Canary VS Edge Stable is missing 3 Utilities:

Utility: Network Service
Utility: Audio Service
Utility: V8 proxy Resolver

Utility: Network Service
Utility: Audio Service
Utility:V8 proxy Resolver
Thanks both of you! Could you try visiting edge://crashes (if it renders for you) and copy the most recent crash using the checkbox and copy to clipboard option, then paste that here? The team is now engaged on this and has requested this specifically =)

@Alexandra-R after trying to go to www.microsoft.com


as a fyi for settings



Clicking the "Windows diagnostic data settings"




Thanks for trying! Checking with the team on how else they might get what they need to dig into this and will circle back!

And I'm back! 


The team has requested NetLogs from folks hitting this.


Capture Network Logs (NetLog) from Edge and Chrome (and Electron and WebView2) – text/plain (textsla...

This walkthrough is written by Eric Lawrence, a Principal on the Edge team, and was requested so the team can see what's going on behind the scenes with the traffic for you all. 


For anyone willing to provide this, please DM me with the resulting file and do not post it in the thread, though you're welcome to comment that you've done so. I'll keep an eye on my DMs for these!