SOLVED

Edge Canary 77.0.211.0 always on top, dropdown menus not functioning

Highlighted
New Contributor

Latest Edge Canary 77.0.211.0 has added a couple issues:

  • Edge is always on top. Unless I minimize the edge window(s) , no other program or app can be brought to the foreground, except for other Edge windows.
  • html dropdown menus don't work. I can click on them but the menu does not popup, only the field gets selected. Navigation up and down the menu is possible by using the up and down arrows.

Anybody else having these issues? Any workaround?

71 Replies
Highlighted

@alibayram 

I found the cause of the problem and wrote a program to fix it temporarily.
Download the attachment and unzip it.

Run this script every time you open Edge :)

Highlighted
Build 18362.10

Windows 10 1903
Highlighted
I have the same problem. I'm not sure when did the problem show up, but it is still unresolved. I'm now at "Version 77.0.211.0 (Official build) canary (64-bit)" and my system is 1809,17763.557. It is annoying because I often use edge to preview my web page ,so I need to switch from edge to the editor frequently. This problem lets my efficiency drop,and reinstall the browser doesn't work at all.
Highlighted
always on top problem was in Google Chrome Canary too but few days ago it got patched. now Microsoft should patch it as well. it's related to the chromium engine.
Highlighted

I hate always on top it's confuse me!!!!!

Highlighted
Why Edge set SetWindowPos to HWND_TOPMOST in the first place, makes no sense to me.
It _could_ be a feature like in many applications, where it is a user option.
Highlighted
This fixed it for me along with the HTML drop down menus. Thanks!
Highlighted

Good to know I'm not the only one!

Highlighted

@alibayram 

I have noticed this as well

Very annoying

 

Highlighted

@alibayram Same here.  Here's a quick PowerShell hack I did that seems to work around the issue.  Same as EdgeTopmostFix.ps1 and run it.  Will need to be re-run everytime you close and reopen edge.

 

$MemberDefinition = @'
[DllImport("user32.dll")]
public static extern bool SetWindowPos(IntPtr hWnd, IntPtr hWndInsertAfter, int X,int Y, int cx, int cy, uint uFlags);
[DllImport("user32.dll")]
public static extern bool ShowWindow(IntPtr hWnd, int nCmdShow);

public static void DisableTopmost(IntPtr hWnd) {
int HWND_NOTOPMOST = -2;
uint SWP_NOSIZE = 1;
uint SWP_NOMOVE = 2;
SetWindowPos(hWnd, new IntPtr(HWND_NOTOPMOST), 0, 0, 0, 0, SWP_NOMOVE | SWP_NOSIZE);
}
'@
$User32 = Add-Type -MemberDefinition $MemberDefinition -Name 'User32' -Namespace 'Win32' -PassThru

Get-Process 'msedge' | Where-Object MainWindowHandle -ne 0 | Select-Object -ExpandProperty MainWindowHandle | ForEach-Object { $User32::DisableTopmost($_) }
Highlighted

@JeffMill @alibayram et al,

Ok, it's opinion time... they are free albeit sometimes not worth the price ;)

I don't get why anyone would be (so) focused on Canary & treating things like it's the only Edge C; it's not!  Without a need for any hacks, batch files or workarounds, just use Dev.  This always on top issue is a "Know issue" and obviously, it will be rectified asap.  Until then, just use Dev, only.  One can have both, even use both simultaneously. <-- I'm doing it every day.  Stuff can happen with Canary and less so with Dev.

Cheers,
Drew
thVY64FD02.jpg

Highlighted
Highlighted

Same issue here. Replying mostly in hopes of seeing this thread updated when the issue is resolved. I'll install the dev channel builds until then.

Highlighted

@Drew1903 


@Drew1903 wrote:

@JeffMill @alibayram et al,

Ok, it's opinion time... they are free albeit sometimes not worth the price ;)

I don't get why anyone would be (so) focused on Canary & treating things like it's the only Edge C; it's not!  Without a need for any hacks, batch files or workarounds, just use Dev.  This always on top issue is a "Know issue" and obviously, it will be rectified asap.  Until then, just use Dev, only.  One can have both, even use both simultaneously. <-- I'm doing it every day.  Stuff can happen with Canary and less so with Dev.

Cheers,
Drew
thVY64FD02.jpg

 


I think because this was an unexpected bug, almost like these two issues shouldn't happen, even if on Canary. But I do have to step back and remind myself of it too...the price I pay for cutting edge. 

Highlighted
Everything seems to be fixed in Version 77.0.213.1.
I just updated, and have no issues anymore.
Highlighted

@alibayram 

 

Fixed with last update ( 77.0.213.1). Thanks!

Highlighted

Problem fix in 77.0.213.1

Highlighted
It is alright now after the canary build update .213.1, for both Edge window on top, as well as the HTML drop down selection...
Highlighted

Thanks for reporting the issue!  Edge picked up a regression in Chromium and the window focus issue appears to be fixed in 77.0.213.1: https://bugs.chromium.org/p/chromium/issues/detail?id=979538

Please let us know if you're still experiencing the issue after updating to Canary 77.0.213.1.  

 

Highlighted