Edge asks for my Google login every time I open the browser

Copper Contributor

I have Microsoft Edge Chromium installed and every time I open the browser it asks for my Google login information. I have tried to reinstall the browser, reset the settings to default and deleted the stored passwords, without any success. Does anyone know what the reason is for this behavior? It is very frustrating and I have already started using another browser because of this issue.



7 Replies
Edge asks for Google login?! that doesn't sound right.
are you sure you are not visiting a website that asks for it? because Edge browser itself never asks for your Google credentials since it doesn't need them at all.

try temporary disabling all of your extensions: edge://extensions/
also check your startup settings: edge://settings/onStartup

there must be an extension or a website asking them.
I have set Google as default search engine and startup page. So, every time I open Edge it asks for my Google credentials, even though I have entered them before and they are stored in the Edge passwords under settings. Also, it doesn't save my search settings as well. I did the same in Firefox and it is no problem there.
You can check here, see if you set anything to be automatically cleared on browser exit:

also how do your cookie settings look like?
That's why your company will fail. Nor your programmers, nor your support team can't help customers.
You did not answered or helped with issue, just sent useless links.
The same issue with your mobile browser by the way. (if you suddenly interested how your products work)

@Matthias681595 Same here. Every time I open Gmail, Edge asks me to log in; this does not happen with any other browser (yes, latest version, credentials saved, and relevant cookies authorized). Hopefully, someone in Redmond will finally realize you lure customers with good products and decent service, not by bullying them into using their products. I searched for a solution to this problem, and all I found from MS were useless links. This user is going back to Google Chrome, which works like a charm.

Happy holidays to you all, including the "marketing" geniuses in Redmond.

I have the same problem too and have spent hours  searching for an answer . Microsoft is singularly unhelpful in resolving this issue which is clearly  widespread  as it appears on numerous forums across the internet @Anzoth 

This fixed my issue. Lesson learn... always check settings first and not quick to assume its something else.