Edge ALT+TAB functionality cannot be disabled!

%3CLINGO-SUB%20id%3D%22lingo-sub-2034584%22%20slang%3D%22en-US%22%3EEdge%20ALT%2BTAB%20functionality%20cannot%20be%20disabled!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2034584%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3CBR%20%2F%3E%3CBR%20%2F%3EI've%20disabled%20the%20ability%20to%20use%20ALT%2BTAB%20to%20cycle%20through%20edge%20browser%20tabs%20when%20cycling%20through%20programs%20in%20Windows%20Multitasking%20settings%2C%20yet%20the%20still%20appear%20when%20I%20press%20ALT%2BTAB.%20There%20appears%20to%20be%20no%20browser%20setting%20for%20disabling%20it%2C%20though%20I%20found%20one%20source%20that%20said%20a%20flag%20should%20be%20available%20(edge-window-tab-manager).%20Unfortunately%2C%20that%20flag%20appears%20to%20be%20missing%20in%20the%20current%20version%20of%20Edge.%3CBR%20%2F%3E%3CBR%20%2F%3EA%20semi-workaround%20is%20selecting%20the%20%22Open%20windows%20and%203%20most%20recent%20tabs%20in%20Edge%2C%22%20which%20indeed%20limits%20the%20number%20in%20the%20application%20switcher%20to%203.%20However%2C%20%22Open%20windows%20only%22%20does%20the%20exact%20same%20thing%20as%20%22Open%20windows%20and%20all%20tabs%20in%20Edge.%22%3CBR%20%2F%3E%3CBR%20%2F%3EHow%20can%20I%20disable%20this%20behavior%3F%20Some%20time%20back%2C%20I%20was%20enjoying%20Edge%20as%20a%20Chromium-based%20Chrome%20alternative%2C%20but%20this%20started%20happening%20and%20it%20seems%20to%20be%20impossible%20to%20disable.%20This%20makes%20the%20browser%20unusable%20for%20me%20(I%20am%20a%20developer--I%20always%20have%20numerous%20instances%20of%20IDEs%20and%20such%20open%2C%20as%20well%20as%20dozens%20of%20tabs.)%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3E(Is%20there%20a%20place%20to%20report%20bugs%20for%20Edge%3F%20This%20is%20the%20closest%20thing%20I%20can%20find%2C%20yet%20in%20my%20experience%20usually%20doesn't%20get%20replies%20from%20MS.)%3CBR%20%2F%3E%3CBR%20%2F%3EThanks%2C%3CBR%20%2F%3ETravis%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2034625%22%20slang%3D%22en-US%22%3ERe%3A%20Edge%20ALT%2BTAB%20functionality%20cannot%20be%20disabled!%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2034625%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F164310%22%20target%3D%22_blank%22%3E%40Travis%20Terrell%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3Eyes%20there%20way%20ways%20to%20send%20feedback%3C%2FP%3E%3CP%3Ein%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fa-few-updates-from-the-microsoft-edge-team%2Fm-p%2F1977784%22%20target%3D%22_self%22%3Ethis%20pinned%20post%3C%2FA%3E%20moderators%20explained%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3E%3CSPAN%3EGoing%20forward%2C%20if%20you%20find%20a%20bug%2C%20first%20please%26nbsp%3B%3CU%3E%3CSTRONG%3Ereport%20it%20through%20the%20in-browser%20feedback%20tool%3C%2FSTRONG%3E%3C%2FU%3E.%26nbsp%3B(%3CSTRONG%3E%E2%80%A6%3C%2FSTRONG%3E%26nbsp%3Bmenu%20%26gt%3B%26nbsp%3B%3CSTRONG%3EHelp%20and%20feedback%3C%2FSTRONG%3E%26nbsp%3B%26gt%3B%26nbsp%3B%3CSTRONG%3ESend%20feedback%3C%2FSTRONG%3E).%20If%20you%20need%20personalized%20help%20with%20troubleshooting%20an%20issue%2C%20especially%20if%20it%20relates%20to%20your%20specific%20device%20or%20account%2C%20please%26nbsp%3B%3CU%3E%3CA%20title%3D%22https%3A%2F%2Fwww.microsoftedgeinsider.com%2Fen-us%2Fsupport%22%20href%3D%22https%3A%2F%2Fwww.microsoftedgeinsider.com%2Fen-us%2Fsupport%22%20target%3D%22_blank%22%20rel%3D%22noreferrer%20noopener%20nofollow%22%3Econtact%20our%20Insider%20Customer%20Support%20team%3C%2FA%3E%3C%2FU%3E.%20This%20is%20a%20small%2C%20specially%20trained%20team%20to%20solely%20support%20our%20Insider%20community%2C%20so%20they%20can%20provide%20the%201%3A1%20assistance%20that%20you%20or%20your%20Enterprise%20environment%20might%20need.%3C%2FSPAN%3E%3C%2FLI%3E%3C%2FOL%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi,

I've disabled the ability to use ALT+TAB to cycle through edge browser tabs when cycling through programs in Windows Multitasking settings, yet the still appear when I press ALT+TAB. There appears to be no browser setting for disabling it, though I found one source that said a flag should be available (edge-window-tab-manager). Unfortunately, that flag appears to be missing in the current version of Edge.

A semi-workaround is selecting the "Open windows and 3 most recent tabs in Edge," which indeed limits the number in the application switcher to 3. However, "Open windows only" does the exact same thing as "Open windows and all tabs in Edge."

How can I disable this behavior? Some time back, I was enjoying Edge as a Chromium-based Chrome alternative, but this started happening and it seems to be impossible to disable. This makes the browser unusable for me (I am a developer--I always have numerous instances of IDEs and such open, as well as dozens of tabs.) 

(Is there a place to report bugs for Edge? This is the closest thing I can find, yet in my experience usually doesn't get replies from MS.)

Thanks,
Travis

2 Replies

@Travis Terrell 

Hi,

yes there way ways to send feedback

in this pinned post moderators explained:

 

  1. Going forward, if you find a bug, first please report it through the in-browser feedback tool. ( menu > Help and feedback > Send feedback). If you need personalized help with troubleshooting an issue, especially if it relates to your specific device or account, please contact our Insider Customer Support team. This is a small, specially trained team to solely support our Insider community, so they can provide the 1:1 assistance that you or your Enterprise environment might need.

@Travis Terrell 

 

about the flag you mentioned, edge://flags/#edge-window-tab-manager
it's been available in Edge canary, if everything goes well, it will make it to Beta and eventually stable release of Edge too, maybe even becomes an option in Edge settings.

 

 

in Windows settings, this option only shows window(s) for me, not individual tabs. tested just now on Edge 87 stable and 89 canary.

 

ff.jpg

 

 

showing only open windows should be the same experience you'd have in other browsers such as Firefox.

 

if you're still seeing individual tabs even though you're using "open windows only" option then something must be wrong as it's not the expected behavior.

 

make sure Edge is up to date and more importantly, Windows 10 is up to date.

 

 

as a suggestion, you can use virtual desktops in Windows 10 for organizing your works and separate them in any order you want, they can be given custom names, open programs can be moved between virtual desktops, and also, Edge in Canary (probably Dev channel too by now), supports custom names for each window.