Edge 88 Slow Opening Websites

Brass Contributor


Recently I upgrade to Edge 88, and found it to be very slow opening webpages.  I did some research, and found a post Reddit with a solution that worked for me.  Just go to the Proxy settings and disable "Automatically Detect Settings".  There was a big improvement after I disable this setting.    


I hope this issue is solved in a future release.



9 Replies

@Daniel Velez 

Thank you for sharing this. Function automatically detect proxy is there for years. I was stupid to update EDGE because I wanted to have function sharing history and tabs across devices. So this is what I got, just another bug. 


Everybody who reads it, turn off updates and stay literally SAVE from Microsoft misfits. They are completely out of control and dangerous to everyone and to themselves. 

@Daniel Velez Thank you so much for posting this. Web pages were delaying loading by around 2-5 seconds every single time I clicked on anything in Edge. I reinstalled network drivers, rebooted modem, and other things. Finally I tried Chrome and found it was working fast. I tried downloading the latest Edge Dev channel build and it did not help either. Your suggestion to disable automatic proxy detection fixed the edge problem immediately for me. 

Having the same issue after updating to edge 88

I experienced the same behavior very slow open the link, Chrome is ok.@srfteixeira 

Hi folks! 


We're currently tracking this issue! For anyone that comes across this thread and is willing to assist us with some logs, Missy has a detailed write-up on what we're looking for over on Reddit. We'd appreciate your help investigating this further! 


cc: @Daniel Velez @panpanbebe1325 @srfteixeira @RobertEhlers @Cent2x 



@Daniel Velez glad to see I am not the only one encountering this issue.


What resolved the issue for me was going to Settings > Privacy, search and services and disabling the following setting:

Use secure DNS to specify how to lookup the network address for websites


My device is already configured to use Cloudflare's secure DNS via Network Options in Control Panel, so I have no qualms about disabling this in Edge.


As soon as I disabled Use secure DNS to specify how to lookup the network address for websites page times returned to their normal speedy selves  ^_^


What's weird though is I am still seeing the "Downloading proxy script..." message appear as a status message at the lower-left corner of the browser UI :p

@binaryhelix Can confirm. Have cloudflare dns set on windows settings. If I turn off "Use secure DNS" on edge settings, even with the windows setting "Auto detect proxy settings"turned on, don't see "Downloading proxy script..."  and edge is not slow anymore.

@Daniel Velez 

Merci beaucoup c'est parfait comme solution :)

This is still an issue in Edge 88.0.705.63. But your fix works.

What's odd is that Chrome doesn't have an issue with "secure DNS" enabled.