SOLVED

Do Not Clear - Not Persistent

Contributor

We recently gained a great new feature:

  • Added the ability to create a list of sites that are exempt from the deletion of cookies when the browser is configured to delete browsing data upon closing.

Upon adding sites to this list the entries can be seen in two areas of the browser settings:

  • Privacy & Services > Clear Browsing Data > Cookies & Other Site Data > Do Not Clear
  • Site Permissions > Cookies & Site Data > Allow

Problematically however is that my list of sites, once created, is not persistent. In other words, after a browser close and restart my list is empty.

 

Annotation 2020-04-15 091806.png

 

Following the suggestion of @josh_bodner I tried creating my site list using a variety of domain naming conventions, such as:

To be clear, I tried each of the above one at a time. I would add a single entry, close the browser, and then reopened to see if that example was retained. In each of the 5 test runs the browser opened with an empty list stating "No sites added".

 

Extensions in use:

Bitwarden, uBlock Origin, Cookie AutoDelete, Decentraleyes, and HTTPS Everywhere

 

So, am I the Lone Ranger here, or is anyone else experiencing this?

8 Replies

I'm on Version 84.0.485.0 (Official build) canary (64-bit)

and they are retained after browser restart

 

gfdgdf.png

 

 

I have ublock origin and bunch of other extensions that Don't have anything to do with connection, cookies etc.

so try disabling your extensions in case they are incompatible

@TrafGib it looks like you've also got other switches besides cookies turned on.  Can you try turning them off so that you're only clearing cookies when you exit and see if that also makes a difference?  

@josh_bodner 

 

The problem stems from the "Site Permissions" flag.

Annotation 2020-04-15 144423.png

I turned off every flag and then cycle through turning each one on one-by-one. The site list remains persistent across browser close & restart as long as the "Site Permissions" flag is set to off.

@TrafGib 

Nice job finding the root cause of that problem

 

I can now reproduce it on Version 84.0.486.0 (Official build) canary (64-bit)

 

gfdgd.png

 

@HotCakeX 

 

Excellent. I am experiencing it on Dev.

Version 83.0.478.5 (Official build) dev (64-bit)

best response confirmed by TrafGib (Contributor)
Solution

@TrafGib great detective work!  I'll get a bug filed right now.  

This problem has returned as of Version 87.0.664.47 (Official build) (64-bit).

I consider this a major problem will need to move to another browser until this is fixed!

Post Script: I do not have any Site Permissions set, this is not part of this current issue as far as I can tell!

@TomWatts  

I got this to work on Version 89.0.774.68 by NOT selecting the "Include third-party cookies on this site" box when adding the site.