Disable high DPI scaling in Microsoft Edge (when Windows setting is at 125%)

%3CLINGO-SUB%20id%3D%22lingo-sub-1067544%22%20slang%3D%22en-US%22%3EDisable%20high%20DPI%20scaling%20in%20Microsoft%20Edge%20(when%20Windows%20setting%20is%20at%20125%25)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1067544%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EIs%20there%20any%20way%20to%20disable%20the%20High%20DPI%20scaling%20of%20Microsoft%20Edge%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThat%20UI%20looks%20awfully%20big%20if%20my%20DPI%20is%20set%20for%20125%25.%20I%20have%20it%20disabled%20on%20Chrome.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EExample)%26nbsp%3Bchrome.exe%E2%80%9D%20%2Fhigh-dpi-support%3D1%20%2Fforce-device-scale-factor%3D1%E2%80%9C%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EBut%20this%20may%20be%20the%20only%20thing%20preventing%20me%20from%20using%20Microsoft%20Edge.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EAs%20expected%2C%20changing%20the%20compatibility%20settings%20for%20the%20executables%20(msedge.exe)%20doesn't%20work.%20But%20is%20there%20another%20workaround%3F%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1077082%22%20slang%3D%22en-US%22%3ERe%3A%20Disable%20high%20DPI%20scaling%20in%20Microsoft%20Edge%20(when%20Windows%20setting%20is%20at%20125%25)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1077082%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F489921%22%20target%3D%22_blank%22%3E%40coolpix%3C%2FA%3E%26nbsp%3BThanks%20for%20letting%20us%20know.%20It%20looks%20like%20this%20was%20a%20known%20issue%2C%20so%20the%20good%20news%20is%20that%20the%20scaling%20should%20be%20fixed!%20Can%20you%20please%20give%20it%20a%20try%20in%20Dev%20(and%20if%20that%20doesn't%20do%20it%2C%20the%20newest%20version%20of%20Canary)%20and%20let%20us%20know%20if%20the%20issue%20persists%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EFawkes%20(they%2Fthem)%3CBR%20%2F%3EProject%20%26amp%3B%20Community%20Manager%20-%20Microsoft%20Edge%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1139214%22%20slang%3D%22en-US%22%3ERe%3A%20Disable%20high%20DPI%20scaling%20in%20Microsoft%20Edge%20(when%20Windows%20setting%20is%20at%20125%25)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1139214%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F484598%22%20target%3D%22_blank%22%3E%40fawkes%3C%2FA%3E%26nbsp%3B%20%26nbsp%3BHello%20-%20Is%20it%20possible%20to%20provide%20a%20setting%20where%20desktop%20zoom%20for%20High%20DPI%20is%20ignored%20by%20Edge%20but%20a%20default%20Zoom%20setting%20is%20accepted%20so%20all%20tabs%20and%20Edge%20instance%20look%20properly.%20At%20present%2C%20in%20Chrome%2C%20I%20have%20to%20manually%20set%20zoom%20in%20each%20tab%20so%20page%20is%20easier%20to%20use.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1151223%22%20slang%3D%22en-US%22%3ERe%3A%20Disable%20high%20DPI%20scaling%20in%20Microsoft%20Edge%20(when%20Windows%20setting%20is%20at%20125%25)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1151223%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F538407%22%20target%3D%22_blank%22%3E%40HDMan%3C%2FA%3E%26nbsp%3BThanks%20for%20the%20suggestion.%20Can%20you%20tell%20us%20more%20about%20how%20that%20specific%20zooming%20feature%20would%20be%20helpful%20for%20you%20and%2For%20what%20situations%20you'd%20use%20it%20in%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CI%3EFawkes%20(they%2Fthem)Project%20%26amp%3B%20Community%20Manager%20-%20Microsoft%20Edge%3CI%3E%3C%2FI%3E%3C%2FI%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2180758%22%20slang%3D%22en-US%22%3ERe%3A%20Disable%20high%20DPI%20scaling%20in%20Microsoft%20Edge%20(when%20Windows%20setting%20is%20at%20125%25)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2180758%22%20slang%3D%22en-US%22%3EOh%20man%2C%20this%20issue%20shoul%20have%20been%20solved%20by%20now.%20Sadly%2C%20it%20hasn't.%20I'm%20on%20Edge%20Dev%20version%20and%20a%203200%20x%201800%20display.%20Windows%20Scaling%20of%20175%25%20zooms%20in%20all%20of%20the%20web%20content%20(including%20image%20files)%20instead%20of%20only%20the%20interface.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2593450%22%20slang%3D%22en-US%22%3ERe%3A%20Disable%20high%20DPI%20scaling%20in%20Microsoft%20Edge%20(when%20Windows%20setting%20is%20at%20125%25)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2593450%22%20slang%3D%22en-US%22%3EThe%20issue%20has%20returned%2C%20Edge%20scaling%20is%20causing%20problems%20with%20some%20websites.%3C%2FLINGO-BODY%3E
Regular Visitor

Is there any way to disable the High DPI scaling of Microsoft Edge?

 

That UI looks awfully big if my DPI is set for 125%. I have it disabled on Chrome.

Example) chrome.exe” /high-dpi-support=1 /force-device-scale-factor=1“

 

But this may be the only thing preventing me from using Microsoft Edge.

As expected, changing the compatibility settings for the executables (msedge.exe) doesn't work. But is there another workaround?

5 Replies

@coolpix Thanks for letting us know. It looks like this was a known issue, so the good news is that the scaling should be fixed! Can you please give it a try in Dev (and if that doesn't do it, the newest version of Canary) and let us know if the issue persists?

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

@Deleted   Hello - Is it possible to provide a setting where desktop zoom for High DPI is ignored by Edge but a default Zoom setting is accepted so all tabs and Edge instance look properly. At present, in Chrome, I have to manually set zoom in each tab so page is easier to use.

@HDMan Thanks for the suggestion. Can you tell us more about how that specific zooming feature would be helpful for you and/or what situations you'd use it in?

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Oh man, this issue shoul have been solved by now. Sadly, it hasn't. I'm on Edge Dev version and a 3200 x 1800 display. Windows Scaling of 175% zooms in all of the web content (including image files) instead of only the interface.
The issue has returned, Edge scaling is causing problems with some websites.