Disable high DPI scaling in Microsoft Edge (when Windows setting is at 125%)

Copper Contributor

Is there any way to disable the High DPI scaling of Microsoft Edge?


That UI looks awfully big if my DPI is set for 125%. I have it disabled on Chrome.

Example) chrome.exe” /high-dpi-support=1 /force-device-scale-factor=1“


But this may be the only thing preventing me from using Microsoft Edge.

As expected, changing the compatibility settings for the executables (msedge.exe) doesn't work. But is there another workaround?

5 Replies

@coolpix Thanks for letting us know. It looks like this was a known issue, so the good news is that the scaling should be fixed! Can you please give it a try in Dev (and if that doesn't do it, the newest version of Canary) and let us know if the issue persists?


Fawkes (they/them)
Project & Community Manager - Microsoft Edge

@Deleted   Hello - Is it possible to provide a setting where desktop zoom for High DPI is ignored by Edge but a default Zoom setting is accepted so all tabs and Edge instance look properly. At present, in Chrome, I have to manually set zoom in each tab so page is easier to use.

@HDMan Thanks for the suggestion. Can you tell us more about how that specific zooming feature would be helpful for you and/or what situations you'd use it in?


Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Oh man, this issue shoul have been solved by now. Sadly, it hasn't. I'm on Edge Dev version and a 3200 x 1800 display. Windows Scaling of 175% zooms in all of the web content (including image files) instead of only the interface.
The issue has returned, Edge scaling is causing problems with some websites.