Dev channel update to 93.0.926.0 is live


Hello Insiders!  Today we’re releasing build 93.0.926.0 to the Dev channel, although we also will be adding a .1 or .2 patch later this week. 


On the welcome page, you may have noticed in a tile that we’re beginning to roll out Efficiency Mode.  We’ll have more details about that soon.  For today, we’re announcing the arrival of a much-requested feature from both users and web devs:  dark themed form controls!  Check out the blog post with all the details here:  As for everything else that’s new and noteworthy this week: 


Added features: 


  • Enabled by default the ability to import passwords from a CSV file. 
  • Enabled by default the ability to change the font in Immersive Reader. 
  • Enabled Kids Mode by default. 
  • Added more themes in Kids Mode. 
  • Added a keyboard shortcut for toggling between vertical and horizontal tabs layouts. 
  • Added a message on the update Settings page to warn when the browser can’t be restarted to install an update because another user on the device has it open. 
  • Added a confirmation the first time F12 is pressed that allows users to disable it as an entry point for the Dev Tools.  Note that it can be re-enabled or disabled at any time in Settings. 
  • Enabled support for management policies from Chromium to control if Insecure Private Network Requests are Allowed, Chromium to control the list of what Insecure Private Network Requests are Allowed For which Urls, and to control if Triple DES is Enabled, which allows/disallows the use of 3DES cipher suites in TLS. 


Improved reliability: 


  • Fixed a crash on launch. 
  • Fixed a crash on shutdown. 
  • Fixed an issue where certain webpages crash with a STATUS_BREAKPOINT error. 
  • Fixed a hang when opening new tabs or windows. 
  • Fixed a crash when sending feedback. 
  • Fixed a crash when navigating using certain protocols in IE mode tabs. 
  • Fixed an issue where one installation of the browser can sometimes cause another on the same machine to be unable to update. 
  • Fixed an issue where the Web Widget is sometimes blank or doesn’t load. 


Changed behavior: 


  • Increased the number of PDFs that can be open at once. 
  • Fixed an issue where middle-clicking on a folder inside a folder on the favorites bar doesn’t open all of the favorites in that sub-folder in new tabs. 
  • Fixed an issue where shortcuts to PWAs are sometimes broken after the browser is updated. 
  • Fixed an issue where a sign-in prompt repeatedly appears when opening certain PDFs, and then keeps reappearing, even after the PDF is closed. 
  • Fixed an issue where Guided Switch preferences sometimes can’t be edited or deleted.  
  • Fixed an issue where dragged vertical tabs don’t follow the mouse cursor properly. 
  • Fixed an issue where extensions that were hidden unexpectedly become visible. 
  • Fixed an issue where the --start-minimized command line flag doesn’t work. 
  • Fixed an issue where Office file downloads sometimes fail. 
  • Fixed an issue where Office documents can’t be opened in Kids mode. 
  • Fixed an issue where printing multiple pages per sheet sometimes rotates the page unexpectedly. 
  • Fixed an issue where the Web Capture toolbar sometimes stays onscreen unexpectedly. 
  • Fixed an issue where the browser profile picture sometimes isn’t shown in places it should be. 
  • Fixed a visual glitch with extensions in PWAs. 
  • Fixed an issue where app info for PWAs or websites installed as apps sometimes is incorrect or gone. 
  • Fixed an issue where prices aren’t visible on Collections items that come from shopping sites. 
  • Fixed an issue where multiple files can’t be downloaded from a single website while in IE mode. 
  • Deprecated the management policy to control if Legacy Same Site Cookie Behavior is Enabled. 
  • Obsoleted the management policy to control how the New Tab Page Set the Feed Type. 


Known issues: 


  • Certain extensions such as the Microsoft Editor extension don’t work on Linux.  As soon as they’re installed, they crash and are disabled.  We’re currently investigating. 
  • Users of certain ad blocking extensions may experience playback errors on Youtube.  As a workaround, temporarily disabling the extension should allow playback to proceed.  See this help article for more details. 
  • Some users are still running into an issue where all tabs and extensions immediately crash with a STATUS_INVALID_IMAGE_HASH error.  The most common cause of this error is outdated security or antivirus software from vendors like Symantec, and in those cases, updating that software will fix it. 
  • Users of the Kaspersky Internet Suite who have the associated extension installed may sometimes see webpages like Gmail fail to load.  This failure is due to the main Kaspersky software being out of date, and is thus fixed by making sure the latest version is installed. 
  • Some users are still seeing favorites get duplicated.  This issue should be reduced now that automatic deduplication has been introduced into Insider channels, but we’re still rolling that out in Stable.  We’ve also seen duplication happen when running the manual deduplicator on multiple machines before either machine has a chance to fully sync its changes, so make sure to leave plenty of time in between runs of the deduplicator. 
  • Some users are seeing “wobbling” behavior when scrolling using trackpad gestures or touchscreens, where scrolling in one dimension also causes the page to subtly scroll back and forth in the other.  Note that this only affects certain websites and seems to be worse on certain devices.  This is most likely related to our ongoing work to bring scrolling back to parity with Edge Legacy’s behavior, so if this behavior is undesirable, you can temporarily turn it off by disabling the edge://flags/#edge-experimental-scrolling flag. 


We couldn’t do this without you! 


17 Replies
Thank you for the ability to change the font in Immersive Reader.
I want to reiterate Paul's gratitude for the ability to change font in Immersive Reader is immensely helpful when it comes to reading comfortably. Thanks Team Edge !

The Passwords Page in Settings is still blank. 3 versions now on Edge Dev on M1 - Apple Silicon.



So, yet another new toggle in the Appearance page in Canary for something I couldn't care less about, but still nothing to restore a good, useable UI for left and tight clicking on say 20 more extension buttons than can be displayed in the toolbar. This remains, a basic, fundamental issue for me that no amount of other bells, whistles and shiny toys makes up for. I continue checking each Dev and Canary build to see is something has been done, but am basically losing hope and only opening new Dev and Canary builds once each to check that one thing. Meanwhile I am (re-)committing to another browser for actual browsing, while using Google Chrome on the odd occasion I have to use a chromium browser because while it shares the loss of the previous good UI for using many more extensions than fit on the toolbar, I can fit 15 extension buttons on Chrome's toolbar in the space I can only fit 10 on Edge's because you're using much more widely spaced buttons (the same spacing Chrome uses on its off by default 'touch' layout). This slightly mitigates the loss of the good UI for extension buttons not on the toolbar - not anything like enough for Chrome to be my regular browser, but enough to make it preferable over Edge if I have to use a chromium browser for the odd thing (mostly rare sites where either videos only play in a chromium browser, or dropdown menus only work in Chromium).


So, as before, if no good, useable UI for use of many more extensions than fit on the toolbar appears in Canary and Dev before your remove the current one in Stable, that is the day I'll uninstall all versions of Edge from desktop and Android phone.

We're still tracking the blank settings page and are investigating how to fix it!
Finally, page hangs issue is fixed. Atleast for me.


I proposed a usable UI for the extensions button here

@josh_bodner Middle clicking and using the mouse to scroll up/down has been broken for a few weeks now on Linux. This is a great way to scroll on something like a Thinkpad - click the middle mouse button and use the track nub to scroll up/down.  It'd be wonderful if this feature was restored.

The Show cards from your Microsoft account section of edge://settings/payments does not appear at all in dev and canary. It does appear in stable and beta. I can't remember when this started but it wasn't this build. One consequence is that with canary adding the feature to roam payment info by adding a local card to the MSA is that once the card is saved to the account, it disappears from Edge.

On Linux, Ozone Wayland, the issue that creates empty windows with addons like Twitch Now and crashes the browser has been resolved. Hopefully the browser also won't crash on popups (e.g. right-click context menu).

I will still use Ozone X11 for the time being because not having IME frameworks support sucks.
Please keep track of the GTK3 IM module support issue and backport it when implemented by Igalia. Note that GTK3 IM module would be better than the relevant Wayland protocol extensions support because Wayland's devs still didn't figure out popup handling for IME, so no candidate box (Chinese) or syllable block assembly preview (Korean).

Hi, still issues with STATUS_BREAKPOINT issue on several websites (incl. Tested on Versie 92.0.902.22 (Officiële build) beta (64-bits) and Versie 93.0.926.0 (Officiële build) dev (64-bits).
Any suggestions?

Apparently solved by renaming msedge.exe

Fix Error 'status_breakpoint' on Chrome and Edge - Chrome Story



This update refuses to install on a 32-bit machine running Win10 19043.1081. It consistently gives error 7 (0x80040902). The same machine has successfully updated progressively to 93.0.936.0 (Canary). Feedback submitted.


Here's hoping that this week's update (29 June?) works.




Bug on address bar. The "F" is black not white. Ubuntu 21.04.



To wrap this up, the update to Dev 93.0.933.1 was successful. There must have been a bug in the .926 32-bit installer.

We're still rolling out two-way support for that payment syncing, so it may just be that your latest builds got an unlucky roll of the dice during the rollout.
We're still tracking a couple of causes of this that came from Chromium, so the fix should be coming from there as well.


@josh_bodner wrote (but later deleted?)


If you try to manually download and install the update, does anything different happen?

No. I tried first before uninstalling .916, then after. Same error every time. It looks like there may be a fault in  - which should be fixed, if so.