Dev channel update to 93.0.916.1 is live


Hello Insiders!  Today we’re releasing build 93.0.916.1 to the Dev channel.  Alongside this, we’re excited to announce a campaign to spur extension development and usage:


Over the next month, users who install an extension can also register to win some awesome prizes:  For the full rules, see


We also would like to draw attention to an in-depth study of how we recently improved visual accessibility of a feature in the F12 Dev Tools:  There’s a lot to consider when dealing with accessibility, and we think this will be very informative for web devs who want to improve their products in similar way.  Now, for everything else new this week: 


Added features: 


  • Enabled support for a management policy from Chromium to control if CECPQ2 is Enabled. 
  • Enabled support for the management policy to control if Local Browser Data Share is Enabled, which lets surfaces in Windows search through the browser’s user data. 


Improved reliability: 


  • Fixed an issue on Mac where the browser sometimes doesn’t open. 
  • Fixed a crash on launch. 
  • Fixed an issue where clicking on the … menu sometimes crashes the browser. 
  • Fixed a crash when using the Collections popup menu. 
  • Fixed a crash when clicking the Vertical Tabs button. 
  • Fixed a crash when setting the default browser. 
  • Fixed a crash when clicking the … menu in PWAs. 
  • Fixed an issue where selecting the Define option from the mini context menu crashes the browser. 


Changed behavior: 


  • Fixed an issue where certain website permission Settings pages appear blank. 
  • Fixed an issue where searching for Settings brings up inaccurate results. 
  • Fixed an issue where the keyboard shortcut to enter Immersive Reader works on pages it isn’t supposed to. 
  • Fixed an issue where password generation puts the new password in more fields than necessary. 
  • Fixed an issue where the profile switcher is appearing on PWAs that aren’t eligible for profile switching. 
  • Fixed an issue where the … menu in PWAs sometimes doesn’t render properly. 
  • Fixed an issue where turning on vertical tabs when in full screen sometimes leads to tabs no longer being visible.  
  • Fixed an issue where UI is unexpectedly pink. 
  • Fixed an issue where pasting content into a Collection sometimes creates extra text notes. 
  • Fixed an issue where dragged vertical tabs don’t follow the mouse cursor properly. 


Known issues: 


  • Certain extensions such as the Microsoft Editor extension don’t work on Linux.  As soon as they’re installed, they crash and are disabled.  We’re currently investigating. 
  • Users of certain ad blocking extensions may experience playback errors on Youtube.  As a workaround, temporarily disabling the extension should allow playback to proceed.  See this help article for more details. 
  • Some users are still running into an issue where all tabs and extensions immediately crash with a STATUS_INVALID_IMAGE_HASH error.  The most common cause of this error is outdated security or antivirus software from vendors like Symantec, and in those cases, updating that software will fix it. 
  • Users of the Kaspersky Internet Suite who have the associated extension installed may sometimes see webpages like Gmail fail to load.  This failure is due to the main Kaspersky software being out of date, and is thus fixed by making sure the latest version is installed. 
  • Some users are still seeing favorites get duplicated.  This issue should be reduced now that automatic deduplication has been introduced into Insider channels, but we’re still rolling that out in Stable.  We’ve also seen duplication happen when running the manual deduplicator on multiple machines before either machine has a chance to fully sync its changes, so make sure to leave plenty of time in between runs of the deduplicator. 
  • Some users are seeing “wobbling” behavior when scrolling using trackpad gestures or touchscreens, where scrolling in one dimension also causes the page to subtly scroll back and forth in the other.  Note that this only affects certain websites and seems to be worse on certain devices.  This is most likely related to our ongoing work to bring scrolling back to parity with Edge Legacy’s behavior, so if this behavior is undesirable, you can temporarily turn it off by disabling the edge://flags/#edge-experimental-scrolling flag. 


As always, thanks for all of your feedback! 


38 Replies

@josh_bodner I only just noticed this the other day in canary but apparently it is broken in beta, dev, and canary while still correct in stable.  Specifically, the sorting of site names in the password list changed from an intelligent sort by eTLD+1 then the prefix to sorting by the entire host name.  The consequence of this is that with the good sort, related hosts are grouped together as shown below.




With the new bad sort order, related hosts are scattered around.


To be blunt, wherever host names are sorted, they should be sorted by eTLD+1 then prefix so that related sites are grouped.

Hi, is anyone else having memory type error messages using Edge Dev?  Only recently I've started to get various messages:  "Error code: Out of Memory"; "RESULT_CODE_HUNG"; SBOX_FATAL_MEMORY_EXCEEDED"?   I get a variety of messages when I try to open Google's calendar, and other websites.  When I click within Amazon this happens.  These errors do not happen within Edge Stable.  Only recently this started happening.  I've checked memory (16GB Ram); closed everything else out, and still get these messages.   I feel like it is something within Dev.  I get the same result with Dev In Private mode.   I've reset Edge Dev, deleted history, cookies, etc., and still get these errors.  Set all Flags to default.   No changes.  Otherwise my machine is acting normally and so is Edge Stable.   The error codes seem to come from certain pages - not all.   So maybe something specific within Dev that changed recently?   Even when the page says "Out of Memory", Task Manager does not show a resource issue. Using Windows Defender, no 3d party anti-virus, and also tried with all extensions disabled.    Thanks, Kent

I am disappointed to see that still page freezes are not fixed, while this issue makes browser almost unusable. Also, mostly it happens in Google search page, is it intentional to force us to use Bing?



No platform changes, only Edge Dev updates, and with 93.0.910.5 and later, Edge Dev has become pretty unusable.

The issue persists with 93.0.916.1


1. Start Edge Dev

2. (this is just an example that I am using as a test - I am not into fuses...)

3. Video doesn't play and page hangs - with pop-up to close page or wait.

4. Browser Task Manager shows CPU for that tab exceeding 100%, which is weird.

5. Page eventually times out with "This page is having a problem - try coming back later".

Salient points:

- This ONLY started with 93.0.910.5
- The repro is solid
- The issue doesn't exist with 91.0.864.48 in the same environment
- The issue doesn't exist with Chrome 91.0.4472.106

[Linux] edge://settings/passwords is still blank when there is saved password.
This issue reminds me that edge://settings/importData had displayed blank. Console log indicates it is very similar failure as far as I remember. It looks like no countermeasure is taken for this kind of circumstances...




I already sent some of these through the Feedback button and posted them on the subreddits but I receive no answer and didn't saw them being mentioned in the known issues list.


Linux related bugs

Tested latest 93.0.916.1 build.

Edge is packaged and run as Flatpak sandboxed app. The source release for the Flatpak is the official Debian deb packaging.


* Ozone is not enabled by default, Google's devs already done this for their 93 unstable builds, please see
As Chrome, X11 platform should be the default because Wayland has still some serious limitations like no support for IME frameworks.
The only downside of Ozone that I know of is that it breaks VAAPI, at least on my system, but the current Edge builds don't seem to even have VAAPI enabled so it doesn't change much ATM, and Igalia will probably fix this, see edit: Scratch that, VAAPI is working with Ozone and is actually enabled in Edge. It seems like I'm hitting a bug that breaks VAAPI but I can work around it by packaging an updated libva version with my Flatpak app.

* Accelerated 3D graphics is broken with Ozone X11.

Ozone X11 issue, not affecting Ozone Wayland or the old X11 backend.
Edge specific bug, no issue with Chrome.

Not a regression, it exists at least since Edge Beta 91.0.864.37.

Basically, Edge is failing to find and falls back to Swiftshader and this is only happening with the Ozone X11 backend.

I already added a workaround here to the packaging on Flathub-beta, but it should be fixed in the distributed Edge binary release as this is not happening with Chrome.

edit: I posted more details about this issue here.


* Edge is doing something strange with popup windows on Linux when running as a native Wayland client with Ozone, at least when using Sway as Wayland compositor.
This is an Edge specific issue, Chrome is working correctly.
Some popup windows and tooltips causing Edge to crash, this happens at least with the Element chat web app when opening the app context menu by right-clicking on a room name.
Some extensions like Twitch Now create a mostly transparent popup window with the Edge logo which causes the browser to crash, see the screenshot.



* Changing Overall appearance from light to dark (or the other way around) in one profile doesn't change the selected setting (dark or light) in other profiles but the change actually being applied.

I'm not sure this is even Linux-specific but I haven't tested other platforms.


* Warning when the Extensions on edge:// URLs flag is enabled:

You're using an unsupported command-line flag: --extensions-on-edge-urls. This poses stability and security risks.

This might be a platform agnostic issue but I only tested Linux.



Linux feature requests


* Official Flatpak packaging please, distributed via Flathub / Flathub-beta repo.

Including the Flatpak sandboxing patches from the Chromium packaging to avoid zypak's LD_PRELOAD hack.

Use this chance to provide an aarch64 build as with the Flatpak runtime you only need to support one aarch64 target.


* Add a dedicated button for toggling dark mode.
The overall appearance setting is one of my favorite Edge features considering that none of the Linux Desktop related foundations (Freedesktop, Gnome, KDE, ...) even tried to suggest a dark mode protocol.
Going to the Settings-> Appearance page every time can be annoying so it would be great if we can have a dedicated button to toggle dark mode that could be added to the toolbar or even just to the Ellipsis menu.
Map this button to a hotkey combination or at least allow the user to set it manually.

Also, make the overall appearance setting accessible through the extensions API.

This request might also fit in the platform-agnostic requests below.



Platform agnostic feature requests


* Dark mode: the Edge flag Force Dark Mode for Web Contents should be linked to the overall appearance setting and should only be in effect if the overall appearance is dark. This should help us avoid extensions like Dark Reader.


* Dark mode: set a theme per overall appearance settings and this should be a profile saved setting which is also synced.


* Improved password vault. There's no reason why we should need to depend on services like Lastpass for basic features like password history, manually adding passwords and etc.


* Better session backup, restore, sync, and adopt handling.
Take some notes from extensions like Session Buddy and Tab Session Manager.


* Vertical tabs: map a hotkey for expanding/collapsing the pane.
Maybe have 3 modes for the pane: collapsed, expanded/pinned, and temporarily expanded / auto-collapsing (expand triggered by an event/hotkey and a countdown timer will collapse it back). Make this available through the extensions API.


* Vertical tabs: auto-hide toolbar.
I already have the titlebar hidden, I don't need that toolbar as I have hotkeys mapped to extensions and I'm using Vimium-C to navigate.


* Allow renaming PWAs.
We can name non-PWA apps as we like but not PWAs.


* Sync some global browser settings with the profiles.
This already being done or applied for the Allow extensions from other stores setting.

Some browser settings are actually set per profile and they are not being synced currently, like extensions keyboard shortcuts (edge://extensions/shortcuts).

I guess that it might be wise to tie some of these settings to the specific platform, so sync these settings separately for each platform. For example, hotkeys set in Win10 might collide with system hotkeys of Mac OS.

Of course, make this feature toggleable and allow selecting what to sync.

Examples: Extensions hotkeys, visible extensions icons in the toolbar, appearance settings (vertical tabs, toolbar), enabled flags (per platform), languages settings (like spell check languages), 


* Reader view: allow using extensions.

Some extensions could be useful for reader view, like extensions used for navigation (Vimium C, Surfing Keys) or language learning (dictionaries, translators, Chinese Traditional-Simplified convert, adding Pinyin to text, and etc).


* Translate: add keyboard hotkey to toggle page translation state (on/off).



Mobile specific features


* Better session management and adoption/import. The current tab syncing feature is not really what I'm looking for. I want to be able to start a session on my desktop, continue on mobile, and return back to the desktop.

* Tab groups support.

* Per-site cookies policy like in the desktop and allow to override in InPrivate mode

* Vertical tabs. At least on iPad OS.



iOS specific features


* Fix YouTube fullscreen.
* PiP support.
* Bring back the 92.884.2 feature. I'm sure the devs know what it is, it appeared in 92.884.2 and then disappear soon after.
* Gestures: pinch -> all tabs view/overview, swipe from left/right edge -> back/forward in history
Force desktop mode / always request desktop site.



Addons store feature requests/issues


* Dark theme/prefers-color-scheme support, please. The current state is that Edge tries to blind us users at night as there's no dark theme and extensions like Dark Reader can't work in the store.
* Please allow extensions to work on the store pages and also on the Chrome web store so we could use extensions like Vimium-C or Surfing Keys to navigate. Let use at least enable this in edge://flags.

* Addons reviews are too slow. Addons in the store are always behind the Chrome web store.

On linux, the newest release, 93.0.916.1, still have these problems.
(1) On settings page, enter anything into the search box and the whole page still goes blank.
(2) Certain web pages still come up blank.
(3) Tab closing order still not correct. Example, Open new 5 tabs from 1, close #5 and tab focus goes to original or all the way to the left. This happens on any closed tab. Focus should go to the tab left or right of the one being closed.
Hello, I just updated. On my Windows ver no problems. On my M1 MacBook I am still getting in Settings - Passwords a blank page. Here is the console output:

command.js:1 Failed to load resource: net::ERR_FAILED
assert.js:85 crbug/1173575, non-JS module files deprecated.
(anonymous) @ assert.js:85
util.js:320 crbug/1173575, non-JS module files deprecated.
(anonymous) @ util.js:320
promise_resolver.js:84 crbug/1173575, non-JS module files deprecated.
(anonymous) @ promise_resolver.js:84
icon.js:159 crbug/1173575, non-JS module files deprecated.
(anonymous) @ icon.js:159
ui.js:213 crbug/1173575, non-JS module files deprecated.
(anonymous) @ ui.js:213
keyboard_shortcut_list.js:94 crbug/1173575, non-JS module files deprecated.
(anonymous) @ keyboard_shortcut_list.js:94
parse_html_subset.js:218 crbug/1173575, non-JS module files deprecated.
(anonymous) @ parse_html_subset.js:218
load_time_data.js:215 crbug/1173575, non-JS module files deprecated.
(anonymous) @ load_time_data.js:215
lib_react.chunk.js:9 TypeError: Cannot read property 'value' of undefined
at Uu.isPasswordVulnerable (settings.bundle.js:1)
at settings.bundle.js:1
at (<anonymous>)
at Uu.mapUiEntryWithPasswordToTableData (settings.bundle.js:1)
at Uu.<anonymous> (settings.bundle.js:1)
at Uu.getFilteredSavedTableData (lib_common.chunk.js:25)
at Uu.sortTableData (settings.bundle.js:1)
at Uu.renderSavedPasswordsTable (settings.bundle.js:1)
at Uu.render (settings.bundle.js:1)
at Ha (lib_react.chunk.js:9)
at Ua (lib_react.chunk.js:9)
at ku (lib_react.chunk.js:9)
at ml (lib_react.chunk.js:9)
at vl (lib_react.chunk.js:9)
at ul (lib_react.chunk.js:9)
at lib_react.chunk.js:9
at t.unstable_runWithPriority (lib_common.chunk.js:38)
at Bi (lib_react.chunk.js:9)
at Yi (lib_react.chunk.js:9)
at qi (lib_react.chunk.js:9)
at j (lib_react.chunk.js:9)
at Yt (lib_react.chunk.js:9)
iu @ lib_react.chunk.js:9
lib_react.chunk.js:9 Uncaught TypeError: Cannot read property 'value' of undefined
at Uu.isPasswordVulnerable (settings.bundle.js:1)
at settings.bundle.js:1
at (<anonymous>)
at Uu.mapUiEntryWithPasswordToTableData (settings.bundle.js:1)
at Uu.<anonymous> (settings.bundle.js:1)
at Uu.getFilteredSavedTableData (lib_common.chunk.js:25)
at Uu.sortTableData (settings.bundle.js:1)
at Uu.renderSavedPasswordsTable (settings.bundle.js:1)
at Uu.render (settings.bundle.js:1)
at Ha (lib_react.chunk.js:9)
at Ua (lib_react.chunk.js:9)
at ku (lib_react.chunk.js:9)
at ml (lib_react.chunk.js:9)
at vl (lib_react.chunk.js:9)
at ul (lib_react.chunk.js:9)
at lib_react.chunk.js:9
at t.unstable_runWithPriority (lib_common.chunk.js:38)
at Bi (lib_react.chunk.js:9)
at Yi (lib_react.chunk.js:9)
at qi (lib_react.chunk.js:9)
at j (lib_react.chunk.js:9)
at Yt (lib_react.chunk.js:9)

Hope this helps, Bob
Another week of canaries and a dev, and still not a sign of either a return of the old UI for left and right clicking on far more extension buttons than will fit in the toolbar or a new, good replacement. So I continue to be unable to recommend Edge, and remain ready to uninstall both desktop and Android versions of Edge the moment Stable loses the good UI for extension buttons not in the toolbar if dev and canary still have nothing other than the extensions button, which would be OK as well but is no good as a replacement.

@Kent Herring @Woody Woodman (WOODY)


Check that discussion from @Eric_Lawrence out. Appears to be the same bug, but what do I know?
It should already be fixed in the latest Canary build.

It is indeed very likely to be the same bug that we had inherited from upstream. 93.923, currently in Canary, has the fix. The fix should be in the next Dev build. Sorry for the inconvenience.

(As an aside, the Upload ID from the edge://crashes page is helpful for us to be able to look at the specific details of any crashes encountered).

@rshupak since we used to have those sorted correctly, I can't imagine that this change was intentional, so I'll ask the team about it.  

@atlanto we've got a bug open for the Passwords page being blank on both Linux and Mac, so we'll get this sorted out!  

@BigEd As far as the Settings pages going blank, I'm wondering if it happening when you search has the same cause as when it you go to the passwords management page.  If so, I'd expect that once the password page gets fixed, so would searching, so please be on the lookout for the fix for the password page and let me know if searching still isn't fixed at that point.  


For the other webpages, do you have consistent examples of ones that go blank, or is it random?  

The one page I can recall is my solar panel display site
Would not even display the login page, just a plain blank page, refresh would not help.
While at it, please have them fix the sorting of the cookie block, allow, and clear on exit lists onedge://settings/content/cookies. These inappropriately sort by reverse order the host name components so that all .co hosts sort before all .com before all .net before all .org. This is really weird. This too should use eTLD+1 with the modification that an entry in the list may be an eTLD which is sorted as is.

All site name lists should likely be sorted as eTLD+1 then prefix for the same reason.


So, I have one error: 


- Histogram: Microsoft.Accessibility.UIAClient recorded 1 samples (flags = 0x41)

612857738  -O                                                                        (1 = 100.0%)


BUT the recorded number doesn't increase with further invocation of that YouTube example (

Once that Youtube tab has hung, F12 is not operational (works on other open tabs, but not this one).

msedge.exe --disable-renderer-accessibility had no effect.


Edgecrash did auto upload I see (upload ID d20b808e-73fc-4297-a845-b8a2aa0c2fd6)




I am very much missing the extension for quick translations - i ask others to do it too!