Dev channel update to 91.0.831.1 is live


Hello Insiders!  Today we’re releasing build 91.0.831.1 to the Dev channel.  To start out, we’ve got two big features we’re excited to unveil, as well as some other exciting community updates: 



As for all of this week’s new features and fixes: 


Added features: 


  • Added an option to the right-click menu to open the current page in Immersive Reader.  Note that this option is only available on pages that are eligible for Immersive Reader to begin with. 
  • Added the ability to use the system theme on Linux. 
  • Added a management policy to control opening a PDF in Secure Mode.  Note that updates to documentation or administrative templates may not have occurred yet. 
  • Added a management policy to control if New Tab Page Content is Enabled, specifically content from Microsoft News.  Note that updates to administrative templates or documentation may not be available yet. 


Improved reliability: 


  • Fixed a crash on launch. 
  • Fixed a crash when using Family Safety. 
  • Fixed a crash when submitting feedback. 
  • Fixed an issue where navigating to certain websites crashes Edge in Kiosk mode. 
  • Fixed an issue where Application Guard windows sometimes unexpectedly close. 
  • Fixed an issue where Edge crashes on close, causing the prompt to restore tabs to unexpectedly appear the next time it’s opened. 
  • Fixed an issue where websites like Youtube sometimes crash soon after loading. 
  • Fixed an issue where PWAs or websites installed as apps sometimes fail to open. 
  • Fixed an issue where the Web Widget sometimes appears frozen or blank. 
  • Fixed an issue where some websites don’t load the first time when using Family Safety, forcing the user to manually re-load the page. 
  • Fixed an issue where URL suggestions when the typed URL results in a failed navigation but is similar to a known URL are broken. 


Changed behavior: 


  • Fixed an issue where the autofill suggestion popup appears more times than expected per page. 
  • Fixed an issue where autofill popups appear on fields where they aren’t relevant or expected. 
  • Fixed an issue where pinning a website to the Start menu via the edge://apps menu fails. 
  • Fixed an issue where clicking a desktop notification from a PWA or website installed as an app doesn’t open the app to that specific content if the app wasn’t open. 
  • Fixed an issue where the right-click menu option to add all tabs to a Collection sometimes is disabled unexpectedly in one menu when it works in another. 
  • Fixed an issue where images sometimes don’t load when viewing pages in Immersive Reader. 
  • Fixed an issue where printing via an extension fails. 
  • Fixed an issue where media keys on keyboards sometimes don’t work. 
  • Fixed an issue where individual tabs can’t be restored from previous windows in the Recently Closed section of the History popup because the windows don’t expand.
  • Fixed an issue where users with multiple cameras are sometimes unable to switch which camera a website is using because the selection dropdown is disabled. 
  • Fixed an issue where tab hover cards sometimes get stuck onscreen, even over other applications. 
  • Fixed an issue where Kids Mode sometimes can’t be escaped from since re-opening Edge after exiting Kids Mode results in going right back into Kids Mode. 
  • Fixed an issue where the management policy to Redirect Sites From Internet Explorer Prevent BHO Install sometimes doesn’t work after updating Edge. 
  • Deprecated the management policy to control whether or not Tab Freezing is Enabled.  This policy has been succeeded by management policies for Sleeping Tabs. 


Known issues: 


  • Certain extensions such as the Microsoft Editor extension don’t work on Linux.  As soon as they’re installed, they crash and are disabled.  We’re currently investigating. 
  • Users of certain ad blocking extensions may experience playback errors on Youtube.  As a workaround, temporarily disabling the extension should allow playback to proceed.  See this help article for more details. 
  • Some users are still running into an issue where all tabs and extensions immediately crash with a STATUS_INVALID_IMAGE_HASH error.  The most common cause of this error is outdated security or antivirus software from vendors like Symantec, and in those cases, updating that software will fix it. 
  • Users of the Kaspersky Internet Suite who have the associated extension installed may sometimes see webpages like Gmail fail to load.  This failure is due to the main Kaspersky software being out of date, and is thus fixed by making sure the latest version is installed. 
  • Some users are still seeing favorites get duplicated.  This issue should be reduced now that automatic deduplication has been introduced into Insider channels, but we’re still rolling that out in Stable.  We’ve also seen duplication happen when running the manual deduplicator on multiple machines before either machine has a chance to fully sync its changes, so make sure to leave plenty of time in between runs of the deduplicator. 
  • Some users are seeing “wobbling” behavior when scrolling using trackpad gestures or touchscreens, where scrolling in one dimension also causes the page to subtly scroll back and forth in the other.  Note that this only affects certain websites and seems to be worse on certain devices.  This is most likely related to our ongoing work to bring scrolling back to parity with Edge Legacy’s behavior, so if this behavior is undesirable, you can temporarily turn it off by disabling the edge://flags/#edge-experimental-scrolling flag. 


As always, it’s your feedback that makes all this possible! 


52 Replies


@PedroLamas wrote:
Where are the Global Media Controls? They seem to be missing now on the latest Edge Dev, but are still present on Edge Stable...


try enabling this flag if you don't see Global media controls flags: 



honestly I think it's time to turn it on by default and remove the flags completely. it's been turned on by default on Chrome for a while now.

That worked perfectly!! Thank you!! :)


I totally agree:


@eduardobragaxz wrote:
It bothers me a bit that the history flyout has a three dot menu with only three buttons inside. Why not just lay those buttons next to the spyglass and pin buttons?


@PedroLamas wrote:
That worked perfectly!! Thank you!! :)

You're very welcome :)

Unfortunately, on the Linux version, Edge is now bound to glibc v2.18 instead of glibc v2.17.


As a result, it is not possible to install Microsoft Edge v91.0.831.1 anymore on CentOS 7, Red Hat Enterprise Linux 7 and others (Oracle, etc) that are built on glibc v2.17.

This is what yum returns when trying to update Edge (in French but you will understand):

---> Le paquet microsoft-edge-dev.x86_64 0:91.0.825.0-1 sera mis à jour
---> Le paquet microsoft-edge-dev.x86_64 0:91.0.831.1-1 sera utilisé
--> Traitement de la dépendance : pour le paquet : microsoft-edge-dev-91.0.831.1-1.x86_64
--> Résolution des dépendances terminée
Erreur : Paquet : microsoft-edge-dev-91.0.831.1-1.x86_64 (microsoft-edge-dev)
Requiert :


Would you plan to attach to version 2.17 back again or is it necessary to keep binding to version 2.18 for new features?

@PedroLamas wrote:
Where are the Global Media Controls? They seem to be missing now on the latest Edge Dev, but are still present on Edge Stable...

The flag has been unexpired in Canary so keep an eye out for the next Dev update =)

I got the same error.

I only use edge for testing so it is annoying but not critical. I know that Redhat 7 and it's derivatives are considered old and if dropping glibc 2.17 is MS's decision then so be it. We will just send the Edge testing further downstream where Windows desktops dominate.

Importing favorites will be blank. This problem exists in 90.0.803.0 and later, but it has not been resolved, so I cannot use the importing favorites function and hope to fix it in the next version. Thank you! This is F12 data.
The system version I use: windwos7sp1 x64 Windows10 19042

assert.js:85 crbug/1173575, non-JS module files deprecated.
(匿名) @ assert.js:85
util.js:320 crbug/1173575, non-JS module files deprecated.
(匿名) @ util.js:320
promise_resolver.js:84 crbug/1173575, non-JS module files deprecated.
(匿名) @ promise_resolver.js:84
icon.js:157 crbug/1173575, non-JS module files deprecated.
(匿名) @ icon.js:157
ui.js:213 crbug/1173575, non-JS module files deprecated.
(匿名) @ ui.js:213
keyboard_shortcut_list.js:94 crbug/1173575, non-JS module files deprecated.
(匿名) @ keyboard_shortcut_list.js:94
command.js:304 crbug/1173575, non-JS module files deprecated.
(匿名) @ command.js:304
parse_html_subset.js:194 crbug/1173575, non-JS module files deprecated.
(匿名) @ parse_html_subset.js:194
load_time_data.js:243 crbug/1173575, non-JS module files deprecated.
(匿名) @ load_time_data.js:243
lib_react.chunk.js:17 TypeError: Cannot read property 'name' of undefined
at Td.getBrowserOptionsItem (settings.bundle.js:1)
at Td.getBrowserOptions (settings.bundle.js:1)
at Td.getImportDialogModal (settings.bundle.js:1)
at Td.render (settings.bundle.js:1)
at Aa (lib_react.chunk.js:17)
at La (lib_react.chunk.js:17)
at vu (lib_react.chunk.js:17)
at cl (lib_react.chunk.js:17)
at ul (lib_react.chunk.js:17)
at Zu (lib_react.chunk.js:17)
at lib_react.chunk.js:17
at t.unstable_runWithPriority (lib_common.chunk.js:28)
at Vo (lib_react.chunk.js:17)
at Ko (lib_react.chunk.js:17)
at Qo (lib_react.chunk.js:17)
at el (lib_react.chunk.js:17)
at Object.notify (lib_react.chunk.js:1)
at e.t.notifyNestedSubs (lib_react.chunk.js:1)
at e.t.handleChangeWrapper (lib_react.chunk.js:1)
at v (lib_react.chunk.js:1)
at lib_react.chunk.js:25
at dispatch (lib_react.chunk.js:1)
at settings.bundle.js:1
eu @ lib_react.chunk.js:17
importData:1 Error handling response: TypeError: Cannot read property 'name' of undefined
at Td.getBrowserOptionsItem (edge://settings/settings.bundle.js:1:710772)
at Td.getBrowserOptions (edge://settings/settings.bundle.js:1:711181)
at Td.getImportDialogModal (edge://settings/settings.bundle.js:1:701445)
at Td.render (edge://settings/settings.bundle.js:1:716891)
at Aa (edge://settings/lib_react.chunk.js:17:69876)
at La (edge://settings/lib_react.chunk.js:17:69671)
at vu (edge://settings/lib_react.chunk.js:17:105470)
at cl (edge://settings/lib_react.chunk.js:17:96717)
at ul (edge://settings/lib_react.chunk.js:17:96642)
at Zu (edge://settings/lib_react.chunk.js:17:93672)
at edge://settings/lib_react.chunk.js:17:45314
at t.unstable_runWithPriority (edge://settings/lib_common.chunk.js:28:3844)
at Vo (edge://settings/lib_react.chunk.js:17:45023)
at Ko (edge://settings/lib_react.chunk.js:17:45259)
at Qo (edge://settings/lib_react.chunk.js:17:45194)
at el (edge://settings/lib_react.chunk.js:17:93963)
at Object.notify (edge://settings/lib_react.chunk.js:1:49287)
at e.t.notifyNestedSubs (edge://settings/lib_react.chunk.js:1:49923)
at e.t.handleChangeWrapper (edge://settings/lib_react.chunk.js:1:49991)
at v (edge://settings/lib_react.chunk.js:1:88780)
at edge://settings/lib_react.chunk.js:25:7878
at dispatch (edge://settings/lib_react.chunk.js:1:92518)
at edge://settings/settings.bundle.js:1:2195576

@josh_bodner hi! I sent couple of feedbacks.. Is there a way for users to get access to the tickets? Is there a plan to opensource Edge?


Edge on Ubuntu works great apart from the import favorites feature that is broken (apparently it's not specific to Linux) and... that is badly rendered. I had no issue with any other site, but this very forum in particular, renders badly and prevent me to access the "replies" to comments. It works better after choosing "Discussion Options > Printer Friendly Page" 

Thanks for the great browser!

I am on Ubuntu 20.04.2 (latest updates installed) and when I tried to run Edge (91.0.831.1-1) after installing the .deb file (installed cleanly), it gives me the message; "Trace/breakpoint trap (core dumped)". There's no core file generated to permit analysis. Could you provide some pointers to resolve this issue?

@mkathe cores on Ubuntu are forwarded to apport, and get archived, together with the cmdline used to start the program, into .crash files under /var/crash, that you can extract with apport-unpack. hope this helps... You should also have something logged in the journal.

@frigo thanks for that tip, will look into the problem and revert in a minute or two.
Okay @mkathe (which is myself), got to the root of the problem, thanks to @frigo for the tip about locating the core file.
The problem of a crash on startup occurs because of the absence of certain library functions from the default install of Ubuntu 20.04.2, even if all the updates have been installed.
Problem can be resolved by issuing "sudo apt install -f" after installing the .deb for Edge. This should install the required library (libatomic) automatically and prevent further crashes.

@josh_bodner Thanks for the sync option.

@josh_bodner Am experiencing crash when switching desktops on Win 10. Do not usually use this feature so am not sure if this is a new problem or not. 

Which Windows 10 build are you on?
Build 16299.1087.
The flag temporarily expired, but it should be back now!
We're looking into this, thanks for reporting it!
Would it be possible to send a screenshot of what the forums look like when you try (and fail) to reply? I wouldn't expect there to be an issue in the way websites are rendered that's different between OS's, unless you've got a specific text scaling or DPI setting or something on your machine that would be different on others.