Dev channel update to 90.0.782.0 is live


Hello Insiders!  Today we’re releasing build 90.0.782.0 to the Dev channel.  As you can see, this is the first build of major version 90 to land in Dev, and with it comes some exciting new features. 



As for everything else: 


Added features: 


  • Improved on smoothness and latency when inking PDFs.  For more details, click here:
  • Added the Collections item to the … menu in InPrivate windows since Collections are now supported in InPrivate. 
  • Improved the Cookies In Use dialog to show more information about a given cookie. 
  • Added a management policy to manage the Smart Actions Block List, which prevents certain context menu actions from being available, and for Windows Hello For HTTP Auth Enabled to control whether or not the basic credential prompt appears for NTLM or Negotiate.  Note that updates to administrative templates or documentation may not be available yet. 
  • Enabled support for the management policy from Chromium to configure the Managed Configuration Per Origin for websites installed as apps. 


Improved reliability: 


  • Fixed an issue where multiple EdgeUpdate processes may be seen running at the same time in Windows Task Manager. 
  • Fixed a crash when copying a URL from the address bar. 
  • Fixed a crash when opening a new tab. 
  • Fixed a crash when using the new Favorites or History popup. 
  • Fixed a crash when using Find On Page. 
  • Fixed a crash when using speech recognition. 
  • Fixed a crash when sharing a Collection. 
  • Fixed a crash when using search engine shortcuts to search for something from the address bar. 
  • Fixed an issue where certain popups from IE mode tabs can become hidden, blocking all interaction with the window. 
  • Fixed an issue where opening Edge via certain shortcuts causes manual updates to fail. 


Changed behavior: 


  • Fixed an issue where setting Autoplay settings to Block causes Read Aloud online voices to fail. 
  • Fixed an issue where newly-opened tabs are blank. 
  • Fixed an issue where certain trackpads cause scrolling to happen too fast. 
  • Disabled ShyUI in PWAs and websites installed as apps. 
  • Fixed an issue where opening a PWA or website installed as an app sometimes results in two windows being opened:  the regular app window but with no content, and a generic browser popup window with the content. 
  • Fixed an issue where switching profiles in a PWA sometimes fails. 
  • Fixed an issue where the Favorites or History menus sometimes appear in the wrong place on screen. 
  • Fixed an issue where searching for a Setting sometimes doesn’t work. 
  • Fixed an issue where there are sometimes duplicate Edge shortcuts on the Taskbar.   
  • Fixed an issue where Immersive Reader shows up as eligible on certain websites it shouldn’t. 
  • Fixed an issue where certain websites installed as apps have too big of an icon when their tile is pinned to the Start menu. 
  • Fixed an issue where websites installed as apps are missing the … icon on their … menu button. 
  • Fixed an issue where the save button when editing a Collection item is invisible. 
  • Obsoleted the management policy for Stricter Mixed Content Treatment Enabled.  Note that this policy hasn’t been functional since version 85. 


Known issues:  


  • Certain extensions such as the Microsoft Editor extension don’t work on Linux.  As soon as they’re installed, they crash and are disabled.  We’re currently investigating. 
  • Users of certain ad blocking extensions may experience playback errors on Youtube.  As a workaround, temporarily disabling the extension should allow playback to proceed.  See for more details. 
  • Some users are still running into an issue where all tabs and extensions immediately crash with a STATUS_INVALID_IMAGE_HASH error.  The most common cause of this error is outdated security or antivirus software from vendors like Symantec, and in those cases, updating that software will fix it. 
  • Users of the Kaspersky Internet Suite who have the associated extension installed may sometimes see webpages like Gmail fail to load.  This failure is due to the main Kaspersky software being out of date, and is thus fixed by making sure the latest version is installed. 
  • Some users are seeing favorites get duplicated after we made some previous fixes in that area. The most common way this is triggered is by installing the Stable channel of Edge and then signing into it with an account that has already signed into Edge before.  This issue should be reduced now that automatic deduplication has been introduced into Insider channels.  However, we’ve also seen duplication happen when running the manual deduplicator on multiple machines before either machine has a chance to fully sync its changes, so while we wait for the automatic deduplication to make it to Stable, make sure to leave plenty of time in between runs of the deduplicator. 
  • Some users are seeing “wobbling” behavior when scrolling using trackpad gestures or touchscreens, where scrolling in one dimension also causes the page to subtly scroll back and forth in the other.  Note that this only affects certain websites and seems to be worse on certain devices.  This is most likely related to our ongoing work to bring scrolling back to parity with Edge Legacy’s behavior, so if this behavior is undesirable, you can temporarily turn it off by disabling the edge://flags/#edge-experimental-scrolling flag. 


In addition to Dev, we’re also releasing version 89 to Beta this week, so be on the lookout for that if you’re also a Beta user! 


51 Replies



@Ebsolas wrote:
Ok, I'm fine with the new features additions for the history menu and downloads and what have you, but please make it optional.

In my use case when I go to the history tab I am generally doing a deep dive into the things I searched for months in the past, so the pop up adding several extra clicks really is a bummer.

The download widget is also abominable. I use an old laptop as an HTPC. Yeah, interacting with that thing is actually impossible from across the room. I use mouse without borders to interact with it, so sitting at my desk where the only keyboard is and trying to click the infinitely small widget text is a nightmare. Please allow for this to be configured in settings. All I ask.



I'd advise using Remote Desktop instead,

Remote Desktop properly sets the correct scaling for the display you are using. it has client for all devices. I use Remote desktop on my 5inch smart phone to control my Windows 10, and i never have any problem with these flyouts because everything is scaled properly to my 5 inch mobile display.

you can add many computers, either in home network or from the Internet, to your Remote Desktop client and control all of them with the same mouse + keyboard.


also supports seamless file transfer, microphone/speaker pass-through and more.



about search in history and having extra clicks, you don't have to go to here all the time: 



you want to use search? the flyout has the same search. you get the same results. there is also a Pin option where you can Pin all the flyouts to have a bigger area.


@josh_bodner The new "Cookie in use" dialog is a step back in my opinion. We use the dialog mostly to clear selected cookies. Previously the focus was set to the next cookie when one was deleted, now we first have to select the next cookie before we can delete it. So if we have three cookies in a row that can be deleted, we have to click six times (select cookie, click delete, repeat). Previously, we only had to click the first cookie and then click delete three times.

Please improve the dialog so that the previous behavior is restored.

@moghaazi are there any settings in edge://settings/system that change your ability to use this feature?  If not, it's quite possible this is just something we haven't implemented yet on Linux.  There are quite a few features like sign in and sync that aren't available yet, so it's good to know that this never worked for you.  I'll ask the team if that's expected.  

@Red_namalas Is it possible that this is just a permissions issue, like that the site no longer has permission to use your camera/mic?  Or have you tried spoofing your UA string to make Meet think you're using Chrome?  (To do that, use the Network Conditions tool in the F12 Dev tools).  

Edge and Chrome already have an "Allow list" or "exception list" for 3rd party cookie blocking.

it happens when you check this box:



@HotCakeX As I look at that checkbox, the lack of space between it and the buttons makes me think it's still experimental.  I actually don't have it at all in my Canary, and I have a bunch of flags turned on!  I'm glad you got this figured out, but now I'm curious about that box given how ambiguous it is.  


@josh_bodner wrote:

Edge and Chrome already have an "Allow list" or "exception list" for 3rd party cookie blocking.

it happens when you check this box:



@HotCakeX As I look at that checkbox, the lack of space between it and the buttons makes me think it's still experimental.  I actually don't have it at all in my Canary, and I have a bunch of flags turned on!  I'm glad you got this figured out, but now I'm curious about that box given how ambiguous it is.  

Yes you are right, that box got removed few canary versions ago.

I had to use sync + stable channel's check box to get 3rd party cookie blocking on canary.



@moghaazi oh and also in the meantime, could you get some debug info for us?  

  1. Try a demo:
  2. If it fails, navigate Edge to edge://push-internals. This is a diagnostic page that captures push messaging errors.
  3. Before sharing the contents of that page, remove the "Endpoint", "Device ID", and "Channel ID" data since that's personal.  Really, the last section about errors is most important.
Type: Portable WNS client 2.0
State: Disconnected
Disconnected: 2/11/2021, 3:11:46 AM GMT+2
Disconnect reason: Not started
Connection attempts: 0

@moghaazi perfect, this helps a lot, thanks!

@moghaazi Looks like this was an easy fix.  That error message described exactly what the problem was:  we forgot to publish a file on Linux that is needed for this to work.  The fix should make it into a build in the next week or two.  Thanks for helping us figure out what was going on!  

I have several remote desktop apps I use. However, using them for my tv computer doesn't work in my use case (I'm not going to hash out the reasons why, but I've tried this in the past and it doesn't work for me) and doesn't make clicking the history widget any easier.

And yes, I do always need to go to the edge://history/all I have trouble reading the new history widget. It's cramped and overwhelming and I find it unusable when trying to find past pages, even if it's something I had open today. Even on my desktop computer it feels claustrophobic and makes me feel anxious whenever it is opened. Pinned or not.