Dev channel update to 85.0.531.1 is live


Hello Insiders!  Today we’re releasing build 85.0.531.1 to the Dev channel.  It’s a small week this week since it’s the first one for major version 85.  Everything noteworthy it contains is: 


Added features: 


  • Added a setting to enable preloading of certain webpages for faster searches and browsing. 


Improved reliability: 


  • Fixed an issue on Mac where new installations of Edge sometimes crash on launch. 
  • Fixed an issue where closing the browser too soon after importing data from another browser sometimes causes a crash. 
  • Fixed an issue where pasting content when Information Protection is enabled sometimes crashes the tab. 
  • Fixed an issue where attempting to restart Edge on Mac to apply an update gives an error message instead of updating the browser. 


Changed behavior: 


  • Fixed an issue where tabs sometimes appear at their minimum width, even when there’s space for them to be larger. 
  • Fixed an issue where scrolling down a page sometimes causes it to jump back up to the top. 
  • Fixed an issue where unpinning and re-pinning Edge to the Taskbar sometimes creates a shortcut to the wrong profile. 
  • Fixed an issue where the … menu button sometimes disappears at small window sizes. 
  • Fixed an issue on Mac where Shy UI sometimes disappears while being interacted with. 
  • Fixed an issue where the highlighted word sometimes doesn’t match what’s being dictated when reading PDFs aloud. 
  • Fixed an issue where printing a PDF sometimes doesn’t center the content on the printed page, leading to cut-off content. 
  • Fixed an issue where the default printer is sometimes forgotten or reset. 
  • Fixed an issue where the Immersive Reader toolbar sometimes disappears when the window isn’t wide enough. 
  • Fixed an issue where translating content in Immersive Reader sometimes leaves grammar markings from the previous language on the page. 
  • Fixed an issue where Youtube videos embedded on webpages aren’t shown in Immersive Reader when they should be. 
  • Fixed an issue where clicking the “Complete sign in” button sometimes doesn’t enable sync until the browser is restarted. 
  • Fixed an issue where Application Guard windows sometimes don’t get proxy settings applied properly. 


Known issues: 


  • Users of the Kaspersky Internet Suite who have the associated extension installed may sometimes see webpages like Gmail fail to load.  This failure is due to the main Kaspersky software being out of date, and is thus fixed by making sure the latest version is installed. 
  • Some users are seeing favorites get duplicated after we made some previous fixes in that area. The most common way this is triggered is by installing the Stable channel of Edge and then signing into it with an account that has already signed into Edge before.  Fixing this should be easier now that the deduplicator tool is available.  However, we’ve also seen duplication happen when running the deduplicator on multiple machines before either machine has a chance to fully sync its changes, so while we wait for some of the fixes we’ve made to come to Stable, make sure to leave plenty of time in between runs of the deduplicator.  We hope that this will be improved now that version 81 is released to Stable. 
  • After an initial fix for it recently, some users are still experiencing Edge windows becoming all black.  Opening the Browser Task Manager (keyboard shortcut is shift + esc) and killing the GPU process usually fixes it.  Note that this only appears to affect users with certain hardware and is most easily triggered by resizing an Edge window. 
  • Some users are seeing “wobbling” behavior when scrolling using trackpad gestures or touchscreens, where scrolling in one dimension also causes the page to subtly scroll back and forth in the other.  Note that this only affects certain websites and seems to be worse on certain devices.  This is most likely related to our ongoing work to bring scrolling back to parity with Edge Legacy’s behavior, so if this behavior is undesirable, you can temporarily turn it off by disabling the edge://flags/#edge-experimental-scrolling flag. 
  • There are some issues where users with multiple audio output devices sometimes don’t get any sound from Edge. In one case, Edge becomes muted in the Windows Volume Mixer and unmuting it fixes it.  In another, restarting the browser fixes it. 


As always, we couldn’t do this without you!

39 Replies
First - I can not log onto my Bank. I cleared my cash to no avail. TD Bank asked me to try to log in using Chrome and it works fine, I also have had links in mails that didn't work. And some links in Social Media that didn't work.
Please bring back Global Media Controls

@cmescher (and everybody else who's been asking for it) as of this week's Dev build, the Global Media Controls flag should be back.  

@Tom_Fox there is indeed:  Since the implementation is something we've inherited from Google (minus any Google-specific services that we would have replaced with our own), there is lots of Google documentation you can refer to, for example:  There are other things controlled by this setting/policy that I don't know of any documentation for though.  

@VincentBech given all the reports of people having trouble with clearing browsing data, our engineering team has put some work on their backlog to give this whole area a good inspection and scrubbing.  

@Eyal_Shahar (and everybody else seeing favorites duplication) we've identified some new bugs in this area that we inherited from upstream Chromium.  Both us on the Edge side and the folks working on Chromium are actively looking into it.  

@Glowtape we've got some other reports of people on Windows 10 version 2004 experiencing bluescreens from their Nvidia 20x0 drivers while playing video in Edge.  While we're looking into it, you might also try running Edge with the --disable-playready-hardware-drm flag, as that's helped some people, although doing so may limit the quality of video that you can view, so you'll want to remember to take that flag off once the issue gets fixed.  

@waltnich in general, you can report issues by going to ... > Help and feedback > Send feedback.  In this case, it would be helpful to know exactly what you're seeing when you say you can't log in.  Is the page loading endlessly?  Do you get an error from the website or from Edge?  Is the page not loading at all?  If it's that last one, we know we had an issue recently where clicking links from outside applications doesn't work if Edge has an update waiting to be installed (see our known issues).  

@basil3143 as of this week's Dev channel update, the Global Media Controls flag should be back.  

Hello Josh. I get the problem randomly but always logging onto TD Bank. I will be using my experience with TD.

When I put in my credentials a pink box apears at the top of the credentials box that says "Something doesn't match. Please try again. You can also retrieve your user name or reset your password via the "Forgot user name and/or password?" link."

I contacted TD and they said they don't know what that is. They, from their end, tried to monitor my login but nothing is happening at their end. They offered that it is a browser issue. It started after the last build drop.     @josh_bodner 

@waltnich are you using Edge's autofill to fill in your password?  If so, it sounds like maybe it's got the wrong password stored for some reason.  If you try to manually type in your login info, does it work?  

No Josh. I do let the auto-fill option deploy and I have been using Last Pass forever - BUT, I have been manually inputting the TD Bank login.. I performed all of the steps you offered thru AI and your telephone tech who was certain he could fix it (but couldn't) He put in the ticket. I don't know if I am connected thru that contact or from requests I have made independently. But I've exhausted normal protocal@josh_bodner 

@waltnich one easy way to check and see if it's a browser issue or a website issue would be to try a different browser, or at least something like InPrivate mode.  

@josh_bodner I have a suspicion that josh bodner is AI. Waste of time pat answers.


@waltnich I promise I'm not :smile: It's just very hard to tell whether website issues are due to problems with the browser, the extensions you use, the website itself, user error, some configuration of the device you're using, etc.  Asking about InPrivate, for example, was to try to rule out extension interference since extensions don't run in InPrivate by default.  Another thing I'd be very interested in is if it works in Guest windows or new profiles.  Figuring out exactly where a bug reproduces is almost as important as how to reproduce it, since that info (or trying a different browser altogether) would go a long way to ruling out if it's your specific Edge profile that's somehow gotten corrupted, which we've seen before.  

Sorry Josh but it started to feel AI when you ask questions that were all done at the start. I think maybe somebody at MS hadtransferred me to a blog? or simular because they don't want to work on this. If so, just be honest with me. I don't accept the opportunity to use beta and then when it glitches you dump me. I thought the idea was that the glitch that hits me will hit others and MS wants to find these glitches. This is my only glitch but if you leave me with a one line "idea" every day, quite honestly, that's crap.@josh_bodner 

@waltnich You're right, it's very possible this is something that might affect other people, which is why I'm trying to get as much information as possible about when you do and don't see it.  I just don't know who you've already talked with to know what all they tried with you.  I'd still like to know if it works in InPrivate in Edge, and if you're up for testing some more, if it works in a different profile (you can just create a new profile and then delete it when you're done).  Also, when I said other browsers, I should have been more specific and said other versions of Edge.  Since you're seeing this behavior in the Dev channel and it started recently, it would be good to download Canary and try it in there, which would be the best way to determine whether it's something wrong with the whole browser or just something that's gone wrong with your profile data, since those two possible bugs are in very different parts of the program.  

OK, Josh. more testing. The last rep started very confident. Gave him on-line access, so I'm not sure what it was he was doing. Spent a lot of time and concluded it had to go to the mail beta group.. But we can't get anything done one post daily.
My original IE from before I downloaded the Edge Beta has upgraded to Edge and that browser opens fine. I don't think that browser is set to sync with my other systems because my new Bookmarks/Favorites setup is the old one in that browser..

@waltnich yeah, sorry, this probably isn't the best forum for actively getting you back into a working state; that's just not what our main focus is here, so it's good that you're also working with support agents.  I don't know which support agents you've tried already, but in case you weren't aware, we've also got agents dedicated to the browser, and you can open a ticket from  

Thanks Josh, I'll give that a try.

I've got used to having different browsers open, it's not really inconvenient.@josh_bodner