Dev channel update to is live


Hello insiders, today we’re releasing build to the Dev Channel!  It’s another small change list this week as we begin our work on major version 79.  Some of the most noteworthy changes include: 


New Features:


  • Enabled the static certificate pinning feature that was originally available in Chrome.
  • Added a keyboard shortcut to mute tabs on Mac.
  • Added support for hyphenated words when performing single-word intranet searches.


Increased Stability:


  • Fixed an issue where watching DRM video like Netflix causes some devices to freeze.
  • Fixed an issue where webpages sometimes crash when watching certain videos.
  • Fixed a crash when using Read Aloud.
  • Fixed an issue where using ctrl+F to find something on a webpage while certain things on the page are highlighted leads to a crash.
  • Fixed some issues with Application Guard sessions not starting.
  • Fixed an issue where navigation in Application Guard windows doesn’t work.


Improved Behavior:


  • Fixed an issue where context menus sometimes don’t show all contents properly.
  • Fixed an issue where the autosuggest popup appears on fields where it shouldn’t.
  • Fixed an issue where a collection that’s deleted in one browser window isn’t immediately deleted from other browser windows.
  • Fixed an issue where the translation popup didn’t have a button to close it.
  • Fixed some issues when adding or deleting words in the spellcheck dictionary.
  • Fixed an issue where using the keyboard shortcut to open the downloads page on an IE mode tab opens Edge’s downloads, not IE’s.
  • Fixed an issue where opening the downloads page on an IE mode tab sometimes doesn’t open it in the foreground.
  • Fixed an issue where installing IE mode sites as apps doesn’t properly show the site’s icon.
  • Fixed an issue where the new tab button is invisible on Windows 7 if the Aero theme is used.
  • Fixed an issue where the loading spinner shows up unexpectedly on items in collections.


As always, we appreciate all of your suggestions and feedback! 


29 Replies

@josh_bodner Have just tried this Dev version on my Surface Go and it just crashes out.  Open Edge Dev, it stays there for about 20 seconds then closes itself every time.  Have checked everything else is up-to-date and rebooted, but same result.  Perhaps an issue with Windows 10 in S mode which the Surface Go uses?

@josh_bodner How long do updates take to propagate? I'm a MacOS user and every time I check for updates after a new build is out, it says that it's up to date. I don't recall Edge Dev ever successfully updating itself on its own. Almost a week after the new build is announced, I end up manually downloading the installer and installing Edge again.

I was looking forward to this new feature, however the media autoplay setting is missing in my site permission settings @josh_bodner 



Scrolling is definitely an issue. One scroll of the mouse wheel makes huge jump on the page. This is also the case even after adjusting the scroll settings.

Same thing here - no option in settings for Media Autoplay


279 seems to have broken a couple of websites, namely Twitter and Gitbook. They still work on original Edge and Chrome so it's not a problem with my PC.


however on 279, there is now no content, just the spinny wheel or blank screen.



@HTBruceM and everybody else who is asking about it,  


The media autoplay setting was recently removed from edge://flags because we are actively working on the feature and are going to add it to Edge's settings.  It's addition to settings is currently under a controlled rollout, which means it could be added or removed from a machine at any time.  Once the rollout is complete and everybody has access to it, I'll mention it in the release notes.  


When edge is closed, it automatically updates itself. Are you looking at the version number its giving you and comparing it to the one that was released, or just waiting for an update?

@Ronald Lawrimore 

Are you using the smooth scrolling flag or the default scrolling. If not, enable smooth scrolling and see if that fixes the problem.

@cjc2112 Turns out I had Microsoft Autoupdate set to manual. I probably set it that way a long time ago because Office updates were pestering me every time I used Word. :smile: