Debian Edge And Edge Add On Page...


Running Edge in a Crostini container on a Chromebook.  Been using it for a few days, got it set up properly and all is well.


Then, I ran into a minor complication not related to Edge - some issues with other repos updating properly.  So I decided to just wipe Crostini off of the Chromebook, and start from a fresh Linux install again.


Everything went perfectly  - Crositini installed, updated properly and Edge installed flawlessly.  But, during set up, I noticed that the MS Edge Add On Page would not show content in the content area on the page. Header and footer is there, just blank in between.


So, I uninstalled my blockers, thinking that must be it.  Nope, I reset Edge's settings to default, in the event I set something that is stopping the content from displaying.  No dice.  Keep in mind, my original Edge install from the other day worked just fine with the Add On page.


So I uninstalled Edge again, destroyed Crostini, and started with another fresh Linux install.  Again, everything went perfectly.  This time, I didn't set up Edge at all, just installed it.  It still won't display the content on the Add On page.  All other pages work perfectly.  Since I did a reinstall of Crostini, there's no chance that there are any config files, cache files, etc., hanging about.


On last clue - if I search for an extension using Google, say "Edge Addon UblockOrigin" I can go straight to that page for that add on, and I can use the breadcrumbs from there to walk back to the Add On Home to install any other addons I want.


So, what could be stopping the display of the content on the MS Add On home page?

2 Replies
Just went back to try this again. Now I am getting an OAuth error:
Request Id: 0fc5e174-8fac-49cd-8f2c-a5fc37101000
Correlation Id: fb9859c6-4755-42c8-9db4-89ab46f24dcc
Timestamp: 2021-03-10T15:20:04Z
Message: AADSTS50196: The server terminated an operation because it encountered a client request loop. Please contact your app vendor.

What's happening? This page worked just fine over the past few days.

There's something going on with that Add On page, for sure.  I continue to try different things.  It looks like blocking to me.  My Edge install is in a new Crostini environment, with all default Edge settings.


Maybe this is just what I can expect with a beta page running on a Dev build browser!