Compatibility View Settings

%3CLINGO-SUB%20id%3D%22lingo-sub-1798444%22%20slang%3D%22zh-CN%22%3ECompatibility%20View%20Settings.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1798444%22%20slang%3D%22zh-CN%22%3E%3CP%3EIE%20browser%20has%20compatibility%20view%20setting.%20How%20to%20set%20it%20in%20edge%3F%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22icey_wu_0-1603183555230.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F227940i039A19629C4FB103%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22icey_wu_0-1603183555230.png%22%20alt%3D%22icey_wu_0-160318355230.png.%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1798499%22%20slang%3D%22en-US%22%3ERe%3A%20Compatibility%20View%20Settings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1798499%22%20slang%3D%22en-US%22%3EEdge%20has%20IE-mode%20but%20in%20order%20to%20use%20it%20I%20think%20you%20should%20take%20care%20of%20this%20problem%20first%20which%20I%20believe%20it's%20still%20not%20fixed%3F%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fhow-to-allow-sites-to-be-reloaded-in-internet-explorer-mode%2Fm-p%2F1778756%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fhow-to-allow-sites-to-be-reloaded-in-internet-explorer-mode%2Fm-p%2F1778756%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1798572%22%20slang%3D%22zh-CN%22%3ERe%3A%20Compatibility%20View%20Settings.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1798572%22%20slang%3D%22zh-CN%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX.%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThrough%20group%20policy%20settings%2C%20I%20found%20that%20IE%20mode%20can%20be%20set%2C%20but%20the%20compatibility%20view%20setting%20was%20not%20found.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1798647%22%20slang%3D%22en-US%22%3ERe%3A%20Compatibility%20View%20Settings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1798647%22%20slang%3D%22en-US%22%3ESo%20you%20are%20using%20Windows%2010%20Enterprise%20latest%20version%20(2004)%20and%20you%20don't%20have%20that%20option%20in%20Edge%20stable%2086.%3CBR%20%2F%3E%3CBR%20%2F%3EWell%20there%20is%20also%20this%20policy%20you%20can%20use%20to%20do%20this%20automatically%3A%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fedge-ie-mode-policies%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fdeployedge%2Fedge-ie-mode-policies%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3Ethis%20doesn't%20require%20manually%20loading%20websites%20in%20IE%20mode%2C%20you%20can%20define%20your%20website's%20address%20in%20that%20policy%20and%20Edge%20will%20load%20it%20in%20IE%20mode%20whenever%20you%20go%20to%20that%20website.%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1801920%22%20slang%3D%22zh-CN%22%3ERe%3A%20Compatibility%20View%20Settings.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1801920%22%20slang%3D%22zh-CN%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX.%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20try%20to%20set%20the%20definition%20in%20the%20%3CA%20href%3D%22http%3A%2F%2Fwww.baidu.com%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ewww.baidu.com%3C%2FA%3E%20it%20runs%20automatically%20in%20IE%20mode%2C%20but%20it%20doesn't%20seem%20to%20be%20implemented%20on%20the%20client%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22icey_wu_0-1603245583254.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F228192iCA5B511CA754FBF2%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22icey_wu_0-1603245583254.png%22%20alt%3D%22icey_wu_0-1603245583254.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22icey_wu_1-1603245605536.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F228193i8B1232D78226CFC0%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22icey_wu_1-1603245605536.png%22%20alt%3D%22icey_wu_1-1603245605536.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1802207%22%20slang%3D%22zh-CN%22%3ERe%3A%20Compatibility%20View%20Settings.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1802207%22%20slang%3D%22zh-CN%22%3ECan%20the%20IE%20compatibility%20view%20settings%20be%20achieved%20through%20the%20configuration%20group%20policy%20describeed%20by%20you%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1802853%22%20slang%3D%22en-US%22%3ERe%3A%20Compatibility%20View%20Settings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1802853%22%20slang%3D%22en-US%22%3EYes%2C%20but%20on%20a%20managed%20PC%2C%20that's%20where%20I%20tried%20and%20it%20worked.%3CBR%20%2F%3Eso%20you%20either%20need%20an%20MDM%20like%20intune%20or%20a%20Windows%20server.%3C%2FLINGO-BODY%3E
Contributor

IE browser has compatibility view setting. How to set it in edge?

icey_wu_0-1603183555230.png

 

22 Replies
Edge has IE-mode but in order to use it I think you should take care of this problem first which I believe it's still not fixed?
https://techcommunity.microsoft.com/t5/discussions/how-to-allow-sites-to-be-reloaded-in-internet-exp...

@HotCakeX 

Through group policy settings, I found that IE mode can be set, but the compatibility view setting was not found

So you are using Windows 10 Enterprise latest version (2004) and you don't have that option in Edge stable 86.

Well there is also this policy you can use to do this automatically:
https://docs.microsoft.com/en-us/deployedge/edge-ie-mode-policies

this doesn't require manually loading websites in IE mode, you can define your website's address in that policy and Edge will load it in IE mode whenever you go to that website.

@HotCakeX 

I try to set the definition in the policy www.baidu.com It runs automatically in IE mode, but it doesn't seem to be implemented on the client

icey_wu_0-1603245583254.png

icey_wu_1-1603245605536.png

 

Can the IE compatibility view settings be achieved through the configuration group policy described by you?
Yes, but on a managed PC, that's where I tried and it worked.
so you either need an MDM like intune or a Windows server.
In addition to GPO settings, is there a way for the client to set the IE compatibility mode?
It's this: edge://settings/defaultBrowser
but you said you can't have it, so your option is GPO

@HotCakeX 

If I enable ie compatibility through group policy, users can choose whether to use IE compatibility mode.

 

Can the compatibility view in ie be achieved by opening ie compatibility mode in the figure below?

icey_wu_0-1603768313308.png

 

So you have that option after all, how did you get it? last time you said you didn't have it
I get this option by setting group policy
Oh, well yes the button does what it says, users can use it to run a website in IE compatibility mode on demand.

@HotCakeX 

I have a website developed by myself, which can be opened only by not checking the content in the red box below in the compatibility mode of IE.

 

So in edge, how to achieve this effect?

icey_wu_1-1604049405424.png

 

 

 

Sorry I don't remember the English title of those check boxes, don't know what they are for..

@HotCakeX

 

I intercepted the English page, as shown in the figure below

icey_wu_0-1604286530324.png

 

 

If you website only loads when you don't check those boxes then don't do that, instead use the this: edge://settings/defaultBrowser
to reload website on demand in IE mode
I've turned on IE mode, but I haven't found the relevant settings
Okay this is really confusing now.

use this
https://techcommunity.microsoft.com/t5/discussions/compatibility-view-settings/m-p/1821525/highlight...

that you said you could get from group policy

@HotCakeX 

Hello, I only got the following results through group policy. You can find the option to open in IE mode in more tools

icey_wu_0-1604370437203.png

 

But now I have a website. Originally, I opened the compatibility view in ie, and then opened it after canceling the option of red box in the figure below.

icey_wu_1-1604370452332.png

 

So my question now is, can I use IE mode in edge to achieve my original effect in IE? Do not need to do other configuration?