Chromium Edge not to login Google services after update

Occasional Contributor

I've just updated my Chromium Edge for Mac to Version 80.0.361.66 (Official build) (64-bit) and now I can't login to Google with MFA enabled. It says that this browser is not secure enough to use Google as below. Is anyone having the same issue as mine? I think that a greedy browser war has been begun by Google..


Edit: I finally resolved the issue by re-installing the app. I don't know the root-cause, but it's not from Google for sure.

Screen Shot 2020-03-13 at 11.32.37 AM.png

10 Replies

@wondong thanks for reporting this. Were you looking at Chrome Extensions? Can you share the URL you were hitting when you saw this?




No, it's not related to Extension. I don't have any and I didn't try getting any.

Belows were my steps. I go to "" and click "sign in" on the top then follow a login process.

After I hit my password, it supposed to have the second factor (either App auth or SMS), but insecure browser error comes.


Screen Shot 2020-03-13 at 1.03.36 PM.pngScreen Shot 2020-03-13 at 1.03.42 PM.pngScreen Shot 2020-03-13 at 1.05.07 PM.png

Hey @wondong, I work with John on Edge - I grabbed a nearby mac and confirmed the version matches yours and tried to reproduce the issue but wasn't able to.


My theory right now is that there might be something relating to the OS that google isn't happy with? Could you provide your OS version as well as check a few random things for me:


- Is your machine date/time correct for where your timezone?

- Would it be possible to try and reproduce the issue with Chrome (install Chrome and try?)

- Do you see any login issues in other places, like youtube or totally non-google related sites that require login?


Let me know how these go.


@shon348 Thanks for the reply.

I have the latest version of Chromium Edge, Edge BETA, Edge CAN and Google Chrome.

I tried to logout, clear cache, visit "", sign-in and try again with private mode on all browsers.


Results are that it worked all except Chromium Edge. My OS version is 10.15.3. I cannot login Youtube or any sites that requires Google login, but I can login Facebook,, and o365. And yes, my clock is set with no issue on EST zone.


The only drawback is that after updating my Chromium Edge, my browser profile (My MSN ID) was logged out and I got a new app icon on Mac taskbar. It used to be the same app icon and logged-in status before. Also, Google login couldn't recognize an update browser as the same browser so it gives me a sign-in button.


Let me know if you need anytime else.

Screen Shot 2020-03-13 at 2.23.05 PM.pngScreen Shot 2020-03-13 at 2.13.16 PM.pngScreen Shot 2020-03-13 at 2.11.54 PM.png

@wondong this is pretty interesting that it works on Canary, Beta and Google Chrome.


If you haven't already, could you also try the Dev version of Microsoft Edge? Available here: my guess is that it will work just like Canary, Beta and Chrome.


Usually Canary, Dev and Beta are newer versions of our browser, so if we did something recently to break you logging into Google, you would see it in Canary/Beta or Dev but not Stable (e.g. Just plain Microsoft Edge). Since you are seeing in Stable (older) but not newer (canary/dev/beta) this leads me to think that something went wrong with your Microsoft Edge (stable) install that didn't go wrong with Canary and Beta. 


If you haven't tried this already, could you try uninstalling Microsoft Edge (stable) by dragging it from Applications inside Finder to the recycle bin. Reboot your machine for good measure - and try and install it again? 


Sorry for the annoyance.



I just fired up my Mac 10.15.3 virtual machine and tested the scenario, using latest Edge canary, I could successfully login to my Google account







@shon348 Not a problem. I uninstalled and re-installed my Edge and it worked!

After the installation, I got all windows opened before the update including gmail.

Strange thing is that I can't find any history when I had Google login issue as below. My Edge has been updated automatically after 10:34 AM, and I re-installed my Edge before 5:44 PM. Of cause, I browsed many sites between 10:34 AM and 5:44 PM, but nothing is listed. I guess that the update might create a kind of new instance, which lacks some components so Google may recognize it as insecure browser. I trashed my old one but not emptied yet. If you want, I can provide it. Thank you for resolving the issue. Screen Shot 2020-03-13 at 5.50.17 PM.png

@HotCakeX Thanks for confirmation. I resolved the issue by re-installing the app. It might be a problem during update.

@wondong Glad you got it working. 

Let us know if you get into that state again and we can revisit. I think the missing history is expected as we don't have history syncing to the cloud yet.