Change Location of Temp/Cache Directory

%3CLINGO-SUB%20id%3D%22lingo-sub-954939%22%20slang%3D%22en-US%22%3EChange%20Location%20of%20Temp%2FCache%20Directory%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-954939%22%20slang%3D%22en-US%22%3E%3CP%3EMy%20office%20uses%20Server%202016%20RDS%20servers%20with%20UPDs%20and%20FSLogix.%20We%20have%20installed%20the%20Edge%20Insider%20Preview%20on%20the%20RDS%20servers%20for%20testing.%20I%20was%20hoping%20to%20install%20the%20LastPass%20extension%20for%20Edge%20Insiders%2C%20which%20I%20used%20successfully%20on%20my%20personal%20computer.%20However%2C%20when%20trying%20to%20install%20extensions%20in%20Edge%20Insider%2C%20I%20get%20this%20error%3A%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F150924iEBCFC6FFA0417905%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20had%20previously%20had%20a%20similar%20issue%20when%20we%20installed%20Google%20Chrome%20on%20RDS%2C%20and%20the%20fix%20was%20to%20create%20a%20separate%20policy%20that%20sets%20the%20temp%20directory%20in%20Chrome%20to%20the%20user's%20%25localappdata%25%5CMicrosoft%5COutlook%5CChromeData%20directory%2C%20so%20the%20temp%20files%20would%20be%20included%20in%20FSLogix.%20I%20was%20hoping%20to%20do%20something%20similar%20with%20Edge%2C%20but%20I%20don't%20see%20any%20way%20of%20changing%20the%20cache%20directory%20in%20Edge.%20Can%20someone%20point%20me%20to%20it%3F%20If%20it's%20not%20possible%2C%20can%20it%20be%20submitted%20as%20a%20feature%20request%3F%20We%20can't%20install%20extensions%20in%20Edge%20using%20FSLogix%20without%20this%20ability.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-954939%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Eextensions%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-956234%22%20slang%3D%22en-US%22%3ERe%3A%20Change%20Location%20of%20Temp%2FCache%20Directory%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-956234%22%20slang%3D%22en-US%22%3E%3CP%3EI%20was%20actually%20able%20to%20figure%20this%20out.%20I%20found%20the%20link%20to%20the%20ADMX%20templates%20on%20the%20main%20page%2C%20and%20used%20those%20to%20set%20the%20same%20GPO%20we%20used%20in%20Chrome%20(%22Set%20the%20user%20data%20directory%22)%20for%20Edge%2C%20and%20redirected%20the%20user's%20%25localappdata%25%5CMicrosoft%5COutlook%20folder%2C%20so%20they%20could%20access%20it%20in%20their%20session.%20Working%20just%20fine%20now.%20Thanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

My office uses Server 2016 RDS servers with UPDs and FSLogix. We have installed the Edge Insider Preview on the RDS servers for testing. I was hoping to install the LastPass extension for Edge Insiders, which I used successfully on my personal computer. However, when trying to install extensions in Edge Insider, I get this error: 

 

clipboard_image_0.png

 

We had previously had a similar issue when we installed Google Chrome on RDS, and the fix was to create a separate policy that sets the temp directory in Chrome to the user's %localappdata%\Microsoft\Outlook\ChromeData directory, so the temp files would be included in FSLogix. I was hoping to do something similar with Edge, but I don't see any way of changing the cache directory in Edge. Can someone point me to it? If it's not possible, can it be submitted as a feature request? We can't install extensions in Edge using FSLogix without this ability. 

 

Thanks!

1 Reply
Highlighted

I was actually able to figure this out. I found the link to the ADMX templates on the main page, and used those to set the same GPO we used in Chrome ("Set the user data directory") for Edge, and redirected the user's %localappdata%\Microsoft\Outlook folder, so they could access it in their session. Working just fine now. Thanks!