Canary Edge .2167 crashing

Iron Contributor

This latest update is crashing bad. Can barely get a Feedback sent.

It's not shutting down correctly the night before, because in the AM

I get asked if I want to Restore Pages.

The new Copilot is opening on its own.

Totally unusable right now.

10 Replies

@CrazyKats this is happening to me and been happening since the build last Friday.. The 13th appropriately enough. 

Getting same problem. Doesn't even stay open long enough to click feedback button.. Copilot opening automatically on edge canary startup.. That needs to be disabled.... Dennis5mile


When you right click Canary and choose "New InPrivate window" it seems to be usable.  But, when you try and use settings, it opens in normal mode and crashes...   Searching to find where to turn off Copilot from auto-starting....



Ok, I am using Canary right now and it seems to be stable. What I did was to go InPrivate, then settings, then sidebar then Copilot. Once in Copilot first disable auto open then disable show copilot. Restart canary and all seems to be working fine as I am using it now to type this reply..


Version 120.0.2168.0 (Official build) canary (64-bit)


Almost 30 minutes now and still running stable with copilot turned off.....


An hour later, opening/closing/copying/pasting between 9 tabs closing all 9 tabs and Canary is still up and running with no trouble by disabling Copilot.... 


Still running Canary Version 120.0.2168.0 (Official build) canary (64-bit) for hours now and still NO problems with Copilot turned OFF.......

Changed the Setting so will see how it goes.
So the common thing seems to be copilot opening the sidebar in Canary.
I have been using version 2168 since it updated with no issues. To be clear, I do not use the sidebar and thus, do not use copilot. And from all the replies to this and other threads, I would agree that copilot seems to be the issue.

@Bebop210 seems stable as a stone and I've done no disabling of copilot as I really enjoy it. Thanks to the MS devs

I tried just disabling the sidebar and leaving Copilot and all has been good.
Updated to .2171 and still no problem.