Canary 99.0.1131.0 crash on launch on Mac after update this afternoon

New Contributor

I used Edge Canary (last previous update appears to have been 99.0.1127.0) several times today. It apparently picked up an update this afternoon (99.0.1131.0, around 1 pm) while in use. I later closed it, and when I tried to reopen a bit ago, it crashed upon loading the start screen (helpfully telling me Edge didn't close properly each time). Can't launch it anymore.

 

On MacOS Monterey here. Nothing else seems amiss.

24 Replies
same thing happening on my m1 mac mini which is running Monterey 12.2 Beta (21D5025f). cant launch edge anymore, it just crashes.
Same here on monterey 12.1. Edge canary immediatly crashes upon launch if not a few seconds after.

Same here, i am on OSX Monterey 12.1

 

 

Yep, mine too. Although to confirm, I'm on Monterey 12.2 beta.
Me too. I'm on macOS Big Sur 11.3.1.
Same here. Monterey 12.1, MacBook Pro M1, Edge Canary 99.0.1131.0

Hey everyone! Thank you very much for reporting and confirming what you're seeing. The team is aware of this and investigating, and I may need to circle back for more information from this thread as they let me know what would help. However, in the meantime, I'll share any updates as I get them. 

 

Thanks for your patience! 

Alex Rowell (she/her)
Community Manager - Microsoft Edge

Same for me, macOS 21.1 and latest stable Version of MS Edge. It crashes instantly, no window comes up. Just see the icon for a short time in my dock and then its gone without any error shown.
The logs show in the system console dont give me any hints at all...but there are some.
I am also seeing the same on macOS Monterey 12.0.1. I have downloaded and installed the latest version from MS website and that doesn't make a difference. Any ideas when this will be fixed?

@Darren Gowing not answering to you, only using ur quote ;)

 

More than 3 days for fix a crash when start a browser (in alpha mode) don't talk very fine about the dev team

 

 

Hey folks, just a quick update that the team is still working on this. I'll update in this thread when I've got a confirmed timeline and/or version number for the fix.

Hi everyone, I just re-downloaded it (for M1 Mac) and the link now points to v. 99.0.1127.0

@benedetto in Intel chip version change version also.... but!!! .... continue crashing!!!!

@rubenovich did you delete v. 99.0.1131.0 first? That's what I had to do before installing v.1127.
That did it for me. I tried installing without deleting, but it still crashed. I deleted it from Applications, emptied trash, and installed with the 1127 installer, and it's working again.