Can't post in this forum in Edge

Steel Contributor

I repeatedly tried to post my last message here this evening in Edge Canary but failed. Then I tried repeatedly in Edge Dev, and failed. Finally I loaded this site in Firefox, copied and pasted from the failing Edges, posted, and it worked straight away.


In Edge Canary and Dev, every attempt to post failed with an error message about how the post contained incorrect HTML, which had been autocorrected so check it's still OK and then post again, but every attempt to post again just produced the same error message. I just typed text without any formatting. I even copied, then 'pasted as plain text' back. I can't even see any HTML, correct or otherwise, although on re-loading saved content there's a blink-and-you'll miss it moment when I catch a flash of HTML as it's re-loading.


This also happened in Edge Canary when I posted yesterday, but it did then work when I tried again in Edge Dev.


What gives? Why is the forum software apparently adding invisible faulty HTML in Edge Canary and now Dev that prevents the post being accepted, then claiming it's corrected it but then again objecting to faulty HTML? How do I get to post to this forum about Edge in Edge? Is there some way to turn off use of HTML in the posts or at least let me see it?

11 Replies
community related discussions belong to Lounge

anyway, do you have Microsoft Editor extension installed?

But this appears to be an Edge problem, not a community problem. The community is working fine for me in Firefox. This is an Edge problem with a website that just happens to be the Edge Community.


I do have Editor extension installed. I'll try disabling it and see if it makes a difference.



I've disabled the Microsoft Editor extension, and as I have to post to test, this post is the test. If it goes that would indicate the Microsoft Editor Extension (well, its interaction with these latest updates of Edge Canary and Dev) is the culprit.


Let's see ...

OK, that post from Canary worked, so Microsoft Editor it is.

I suppose I'll need to test after each update to see if the problem's cleared, but that means trying to post each time, with the post appearing after it's fixed. I'll test by replying to this topic so the success when it comes doesn't clog up someone else's topic.


@DavidGB Looks like it is an issue with the forum, because Microsoft Editor does not cause problems on any other site. I had been seeing this issue since many days and it was driving me crazy!

best response confirmed by DavidGB (Steel Contributor)


You're welcome,

the thing is, the Editor extension adds hidden HTML code to the posts and that's why you get that error in the forum.

it could trigger this error on other forums too if they don't allow them to be posted.


I mentioned this to community mods and they said they are aware of it and contacted Editor extension team as well to let them know about this problem. hopefully it gets fixed soon, but until then I've disabled Editor extension.

@DavidGB , @HotCakeX , @Rohit Yadav 


Off-topic: Hi, is Microsoft Editor similar to Grammarly?


Yes, pretty much

give it a try

@Deleted Yeah, it is a new editing extension from Microsoft, building up on the same technology that powers the Office apps. It includes support for autocorrect, suggesting grammar corrections and language refinements to make your text even better. It is available for Edge and Chrome. 



Don't know where else to post this, cause I can't post a new post, 

Keep getting this message: 


I have removed all text but 1 sentence and get the same error. 


I have tried different browsers in private mode.

Andy advise would be appreciated.