Can't download extensions

Copper Contributor

Hi all,


I can't install extensions from the store in my browser. It gives me a network error, but my network is fine. Anyone have any guesses? I'm in (Official buildcanary (64-bit).



7 Replies

@athosbr99 - thank you for your feedback! Can you provide more details - what is the store URL that you are using? Is this only happening with Nano adblocker or is it for all extensions on store?

@Balaje_Krishnan Hi! I tried with uBlock Origin and Nano Adblocker and both showed the same error. However I rebooted the computer to install my latest Windows Insider updated and the problem went away and I can't reproduce anymore. I don't know if it is related or not, but its fixed for me now.

@athosbr99 - thanks for the report out! Do keep us posted if you encounter this issue again. Thanks!

@Balaje_Krishnan I'm getting the same issue. If I choose "Resume" in the bottom bar, it will complete the download and start trying to install the extension. However when it disappeared from the bottom bar (looks like install completed), actually no extension was installed. (I also checked edge://extensions/ page)

Extensions from Chrome Web Store can be installed without errors, there may be something wrong with Microsoft Store.


@the1812 - thanks for reporting this. We will take a look at this.

Thank you @Balaje_Krishnan for helping @athosbr99 out with this issue.

@athosbr99 I'm having same issue on version 90.0.818.39 on mac