Bug in Edge browser on multiple monitors and menu button

Copper Contributor

I have a multi-monitor setup. If I click the menu button (...) the menu is incorrectly stretched, filled with white space and displayed on the wrong monitor. Some of the menu items then can't be clicked (and moving the mouse over to a different monitor to click a menu item isn't very intuitive anyway). This happens whether or not there is space for the menu to be shown on the primary display. Doesn't happen on Chrome.overlappedEdge.png

20 Replies


Hi there, you are welcome to the Microsoft Edge Insider Community Hub!

Which channel of Microsoft Edge are you using where you are seeing this bug?

Thanks for reporting the issue here. I would recommend you to send feedback about this bug through the in-app feedback tool in Microsoft Edge (Alt+Shift+I) with the diagnostics attached in order to help the Microsoft Edge dev team to resolve your issue as soon as possible.

@TheShaunSaw Version 86.0.622.3 (Official build) dev (64-bit)


Thank you.


I have submitted it through feedback as well. Unfortunately, the screenshot sent through the tool is unhelpful since the problem is shown on a different monitor!


I notice today that hover text (e.g. on MS Search page) is offset below and to the right as well (as shown in the attached).


You'll see on the other attachment that there are 3 monitors - the SurfaceBookPro at the bottom, and then 2 monitors above it.


Perhaps my multiple-monitor setup is unusual?

@AmateurD I have what appears to be a similar issue.

Menus open on different monitor in multi-monitor setup. Happens when Edge is open on second monitor - menu opens on monitor 3 (built-in screen). Issue does not occur on Monitor 1 or the built-in screen.
Setup - 2 x 24" Monitors + Laptop built in screen.
Dell Latitude 7490 connected to a C-Dock.
Monitor 1 connected to C-Dock DisplayPort - 1980 x 1080. Scale - 100%
Monitor 2 connected to C-Dock HDMI 1980 x 1080. Scale - 100%
Built-in display - 1980 x 1080. Scale 150%


I was able to obtain a screenshot demonstrating the issue using the PrtScn key.

I have also submitted this to the feedback.

@WayneGjaltema  I have the same error, 

I have  

LG 32" display 

and another LG 24" display 


@TheShaunSaw this bug persists in version 89.0.774.50 (Official build) beta (64-bit).

@josh_bodner @MissyQ @johnjansen 

Can you please look into this issue. I think many people would be facing it and it is important to solve it as soon as possible.

@TheShaunSaw I have the same problem in my work office, but it just cropped up recently for me. I have a triple display. When Edge is expanded on screen 1, the pop-up menu shows up on screen 3. If I reduce Edge down as a window on screen 1, I can open the menu within the browser itself.


I don't have this problem with Edge at home using a 2-monitor setup. Seems like Edge believes it shouldn't be contained to one browser in the 3-browser set, but I can't find the difference in settings between the two systems.


Following this closely.


I experience the same problem. Edge menus show up on the other monitors and are often outside of the window so they can't be used. This is my Edge version.


Running on a Dell Latitude 7480 with two extended extra monitors connected, one with COM-port and the other with Display port. O/S is according to this:



Also, it affects the menus of other Microsoft applications. In this case the CRM system we are using which is a Dynamics 365 system. So the bug practically stops me from switching over from Chrome now.



Any updates on this?  I just started having this issue.  I switched over to Edge for my default browser and discovered this problem.  Edge is up to date, so obviously, MS has not fixed this.  




No change as far as I can tell. I have learned to get used to it I suppose. Shame they haven't picked it up yet.

@AmateurD, I have found a couple work arounds:


1.  Ensure all 3 monitors have the same scale and layout "Change the size of text, apps, and other items".  Sometimes laptop monitors will have that set to 150% recommended.

2.  Ensure the monitors are in the correct sequence (i.e. 3-2-1 or 1-2-3)


Both these options worked for me.

Yes. I have a 3-monitor setup on a work computer and this is a coding problem, apparently.
A menu (favorites, for example) should opn on the browser window on the screen on which has the actively used window, not a monitor or 2 over. It's not correct; Google Chrome has the same problem. We cannot open different browser types to combat this and the system is admin controlled (VPN / internal), limited to one browser type. Thanks.
Ensuring all 3 monitors are on the same scale worked for me (laptop display was set to 125% by recommended/default), thanks!


I have a new Microsoft Surface Pro which recommends a 200% view with two Acer monitors at 100%. The problem corrects if I change the third (built-in) monitor to 100%. Unfortunately, the content is too small to use as a 3rd monitor when I do that. I have to change the resolution on the Surface to 1280x960 to make it usable. Not the best workaround, but a workaround. 


This bug started in December of 21 for the first time. 

The issue still persists for me on Version 100.0.1185.50 (Official build) (64-bit), please do look into it.

Here is what fixed this for me:
1. Go to your Display Settings.
2. Make sure your monitor 1 (in my case the laptop internal monitor) is the main display. To do this select the monitor 1 and scroll down to the Multiple Displays section and check the box which says "Make this my main display"

Can confirm issue still exists on Version 104.0.1293.47 (Official build) (64-bit). Setting scale on right display to the same value as center display solved the issue, but this should not be required. I checked Firefox not having the issue.

@host1812 The issue no longer occurs. I have no idea when the issue was resolved. My laptop had Windows reinstalled from scratch a couple months back.



If you or anyone else in this discussion are still having this issue, I have found a solution. Though, I do not know how permanent it is. 


I use a Dell XPS 1500 with two 23" Dell monitors connected via Dell Universal Dock. A few months ago, I incidentally solved the problem while disconnecting and reconnecting my displays and was never quite sure what solved it until now. I had to do a complete reset of my computer recently and after reinstalling all my software and applications this problem came back. Here are the steps I recall:


  1. Change the projection to show only on the PC screen (internal display)
  2. Physically, disconnect the PC from the docking station
  3. Restart PC
  4. After rebooting, connect the PC back to the docking station
  5. Change projection back to "extend"


I'd like to note that all my preferred display settings (scaling, resolution, main display) were all set prior to following these steps, so I did not have to change anything after the problem was resolved. These steps could also vary depending on how the displays are all connected (docking station, desktop, etc.)


Hope this helps someone.