Broken accessibility in stable version

Occasional Contributor

Hi there,
I submited feedback from the app already, but I think that its extremely important to talk about this issues here.
I am using new Microsoft Edge from the first Canary build and I was so happy because it was accessible with screen readers, like any other Chromium based browser. Sometimes, in some builds, some features were les accessible, but after my report fix happened quickly.
However, your last changes leads to worse senario.
From Canary build 81.0.392, screen readers have issues. Something is broken. But, its not the worse thing. You applyed the same in stable version 79, even this version in Canary and Dev worked great.
NVDA screen reader just freezing and wont read anything on the page last 3 days. With JAWS, situation is a bit better, but... We cannot control any edit field, including address bar, edit controls. I can type text, but cannot read with arrow keys what is entered. Now, I am typing this in Chrome.  Work with some comboboxes, listboxes is so hard, slow or unresponsive. Cannot navigate thrue history...
From the first build until monday, everything worked great. Just restore accessibility state on that time. You made one improvement with this break. Edge now alerting thrue screen readers password saving dialog etc...
I just wanted to introduce new edge to the blind community, because I expected the same experience, but something went wrong on your side.

Update. Thanks to@nikitat1260, we found that disabling flag Native UI Automation restoring accessibility to normal operation. Its probably means that this implementation not yet ready to be turned on.

And, just a small feedback. You made shortcut key for read allowed option, but no shortcut key for Immersive reader. It will be so useful for screen reader users.
If you have any suggestions what flag to turn off or to make some changes, or if you need more diagnostic data I am ready to help.

2 Replies

@agasoft Hello. I use nvda and I also have these problems. I recommend also writing in nvda. I think this needs to be addressed nvda together with microsoft as a temporary solution, try to disable the flag of the Native UI Automation


Yes, you are right. Somehow I managed to disable this flag and things are working again. However, this flag was disabled until last monday and everything was correct. I think that this flag dont need to be enabled yet, because things are not ready. Or, Microsoft need to work with NVAccess and Freedom scientific to find solution. I am now in Edge again. Thanks for your helpful tip. I will update my report.