Bing searches spikes cpu usage

%3CLINGO-SUB%20id%3D%22lingo-sub-1880063%22%20slang%3D%22en-US%22%3EBing%20searches%20spikes%20cpu%20usage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1880063%22%20slang%3D%22en-US%22%3E%3CP%3EBing%20searches%20spikes%20cpu%20usage%20so%20high%20that%20the%20fans%20starts%2C%20and%20Edge%20gets%20stuck.%3C%2FP%3E%3CP%3EAt%20the%20same%20time%2C%20if%20I%20somehow%20delete%20the%20search%20page%2C%20wait%20for%20a%20while%20for%20the%20laptop%20to%20settle%20and%20then%20search%20with%20Google%2C%20it%20doesn't%20spike%20the%20cpu%20usage.%20Lately%2C%20I%20am%20not%20using%20Bing%20for%20any%20web%20search.%3C%2FP%3E%3CP%3E%3CSPAN%3EVersion%2088.0.692.0%20(Official%20build)%20dev%20(64-bit)%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1880173%22%20slang%3D%22en-US%22%3ERe%3A%20Bing%20searches%20spikes%20cpu%20usage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1880173%22%20slang%3D%22en-US%22%3EThere%20could%20be%20various%20reasons.%3CBR%20%2F%3EAre%20you%20using%20any%20custom%20flags%3F%3CBR%20%2F%3ETry%20to%20temporarily%20disable%20all%20your%20extensions%2C%20see%20if%20it%20makes%20any%20difference.%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1884657%22%20slang%3D%22en-US%22%3ERe%3A%20Bing%20searches%20spikes%20cpu%20usage%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1884657%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BThere%20are%20no%20extensions%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Bing searches spikes cpu usage so high that the fans starts, and Edge gets stuck.

At the same time, if I somehow delete the search page, wait for a while for the laptop to settle and then search with Google, it doesn't spike the cpu usage. Lately, I am not using Bing for any web search.

Version 88.0.692.0 (Official build) dev (64-bit) 

4 Replies
There could be various reasons.
Are you using any custom flags?
Try to temporarily disable all your extensions, see if it makes any difference.

@HotCakeX There are no extensions

 

@HotCakeX 

This is a problem that happens most of the time. The first search works alright, but the continuing further to next pages from that blocks the browser and spikes the CPU. 

 

This is anyway the development release, and for Linux on Kubuntu. If anyone of the developers read this, hope some action would be taken, before the final release. 

Use the feedback button to send this bug report, it sends additional data, if you have access to "recreate my problem? in Edge feedback tool, do that too, if you really want your issue to be fixed